aboutsummaryrefslogtreecommitdiff
path: root/mail/wmbiff/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-11-18 15:44:26 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-11-18 15:44:26 +0000
commit90bd7b15f09dc8f35e696df22a789624015dafd8 (patch)
tree77b89cfcd047bf21d3647908d87fac02b15d5c3a /mail/wmbiff/Makefile
parent1039b2ad7fb186cac0d473ceb16418f5b322c700 (diff)
downloadports-90bd7b15f09dc8f35e696df22a789624015dafd8.tar.gz
ports-90bd7b15f09dc8f35e696df22a789624015dafd8.zip
Notes
Diffstat (limited to 'mail/wmbiff/Makefile')
-rw-r--r--mail/wmbiff/Makefile45
1 files changed, 27 insertions, 18 deletions
diff --git a/mail/wmbiff/Makefile b/mail/wmbiff/Makefile
index 23101afb9b9f..30eeea12e7cb 100644
--- a/mail/wmbiff/Makefile
+++ b/mail/wmbiff/Makefile
@@ -5,35 +5,44 @@
# $FreeBSD$
#
-PORTNAME= wmbiff
-PORTVERSION= 0.4.26
-PORTREVISION= 1
-CATEGORIES= mail windowmaker afterstep
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+PORTNAME= wmbiff
+PORTVERSION= 0.4.27
+CATEGORIES= mail windowmaker afterstep
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An xbiff-like Window Maker dock app
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An xbiff-like Window Maker dock app
-USE_X_PREFIX= yes
+OPTIONS= GNUTLS "Support for SSL" off
-OPTIONS= GNUTLS "Support for SSL" off
+USE_X_PREFIX= yes
+USE_XPM= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= wmbiff.1
+MAN5= wmbiffrc.5
+PLIST_FILES= bin/wmbiff \
+ lib/wmbiff/security.debian.rb \
+ %%DATADIR%%/sample.wmbiffrc \
+ %%DATADIR%%/skins/wmbiff-master-contrast.xpm \
+ %%DATADIR%%/skins/wmbiff-master-led.xpm
+PLIST_DIRS= %%DATADIR%%/skins \
+ %%DATADIR%% \
+ lib/wmbiff
.include <bsd.port.pre.mk>
-.ifdef WITH_GNUTLS
-LIB_DEPENDS+= gcrypt.13:${PORTSDIR}/security/libgcrypt \
- gnutls.12:${PORTSDIR}/security/gnutls
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gcrypt.13:${PORTSDIR}/security/libgcrypt \
+ gnutls.12:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+= --with-libgnutls-prefix=${LOCALBASE} \
+ --with-libgcrypt-prefix=${LOCALBASE}
.else
CONFIGURE_ARGS+= --disable-crypto
.endif
-USE_XPM= yes
-GNU_CONFIGURE= yes
-
-MAN1= wmbiff.1
-MAN5= wmbiffrc.5
-
post-install:
@${ECHO_MSG} "===> Installing sample.wmbiffrc to ${DATADIR}"
@${ECHO_MSG} "===> Modify it to suit your needs and copy to ~/.wmbiffrc"