aboutsummaryrefslogtreecommitdiff
path: root/mail/wmbiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2020-08-28 18:42:06 +0000
committerRenato Botelho <garga@FreeBSD.org>2020-08-28 18:42:06 +0000
commit5b97b29b26f52269cb955c1d9063dacd2b951491 (patch)
tree50a5fccd8eec55781c06b97db4125ad3ab51d9d8 /mail/wmbiff
parentab4131af5776c1fac2ebb5e48080fbc5af0658fa (diff)
downloadports-5b97b29b26f52269cb955c1d9063dacd2b951491.tar.gz
ports-5b97b29b26f52269cb955c1d9063dacd2b951491.zip
Fix build with clang11 and other tweaks
- Add -fcommon for now to fix build with clang11 - Pet portlint - Add missing dependencies to USE_XORG - Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=546793
Diffstat (limited to 'mail/wmbiff')
-rw-r--r--mail/wmbiff/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/mail/wmbiff/Makefile b/mail/wmbiff/Makefile
index f70013d5d8c5..c9056160456c 100644
--- a/mail/wmbiff/Makefile
+++ b/mail/wmbiff/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wmbiff
PORTVERSION= 0.4.27
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= mail windowmaker afterstep
MASTER_SITES= SF
@@ -12,20 +12,23 @@ COMMENT= xbiff-like Window Maker dock app
LICENSE= GPLv2
-OPTIONS_DEFINE= GNUTLS
-
USES= shebangfix xorg
+
+OPTIONS_DEFINE= GNUTLS
SHEBANG_FILES= scripts/security.debian.rb
-USE_XORG= xpm
+USE_XORG= x11 xext xpm
GNU_CONFIGURE= yes
+# Temporary fix to build with clang11
+CFLAGS+= -fcommon
+
PLIST_FILES= bin/wmbiff \
lib/wmbiff/security.debian.rb \
man/man1/wmbiff.1.gz \
man/man5/wmbiffrc.5.gz \
- %%DATADIR%%/sample.wmbiffrc \
- %%DATADIR%%/skins/wmbiff-master-contrast.xpm \
- %%DATADIR%%/skins/wmbiff-master-led.xpm
+ ${DATADIR}/sample.wmbiffrc \
+ ${DATADIR}/skins/wmbiff-master-contrast.xpm \
+ ${DATADIR}/skins/wmbiff-master-led.xpm
GNUTLS_LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libgnutls.so:security/gnutls