aboutsummaryrefslogtreecommitdiff
path: root/mail/wmmaiload
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-09-30 19:24:30 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-09-30 19:24:30 +0000
commit1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66 (patch)
tree8b44219153a720f367633c8fe248933750735b7d /mail/wmmaiload
parent7cb0f3c9b4ec333deb7e94ba00c6dc2d3b9c6220 (diff)
downloadports-1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66.tar.gz
ports-1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66.zip
Let USES=localbase add -L${LOCALBASE}/lib to LIBS instead of LDFLAGS.
USES=localbase:ldflags can be used to set LDFLAGS. Normally LDFLAGS appears too early on the command line causing some ports to link with their own libraries in LOCALBASE (if installed) instead of WRKSRC. Also make use of _USES_POST so -L${LOCALBASE}/lib is added as late as possible after anything a port Makefile might set. Use _USES_POST instead of .include in libedit.mk and libarchive.mk so things like 'USES=libedit localbase:ldflags' work correctly. Fix some issues with LIBS in some ports. Switch ports that don't support LIBS to localbase:ldflags. PR: 212987 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=423014
Diffstat (limited to 'mail/wmmaiload')
-rw-r--r--mail/wmmaiload/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/mail/wmmaiload/Makefile b/mail/wmmaiload/Makefile
index a56b07108009..57e6dd08f0f0 100644
--- a/mail/wmmaiload/Makefile
+++ b/mail/wmmaiload/Makefile
@@ -12,16 +12,14 @@ COMMENT= Incoming mail monitor dockapp with a similar look to wmcpuload
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake localbase pkgconfig tar:bzip2
+USES= gmake localbase:ldflags pkgconfig ssl tar:bzip2
USE_XORG= xpm
USE_GNOME= gtk20
-USE_OPENSSL= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
-MAKE_ENV= DEBUG_CFLAGS="-I${OPENSSLINC}" \
- DEBUG_LDFLAGS="-L${OPENSSLLIB}"
-
-CFLAGS+= -D_GNU_SOURCE
+CPPFLAGS+= -I${OPENSSLINC} -D_GNU_SOURCE
+LDFLAGS+= -L${OPENSSLLIB}
+MAKE_ENV= DEBUG_CFLAGS="" DEBUG_LDFLAGS=""
PLIST_FILES= bin/wmmaiload bin/wmmaiload-config \
man/man1/wmmaiload.1.gz man/man1/wmmaiload-config.1.gz