aboutsummaryrefslogtreecommitdiff
path: root/mail/xc-mail/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2000-10-04 04:52:56 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2000-10-04 04:52:56 +0000
commit34b7bd26df86098f01124bedcea95b79da81900c (patch)
tree8ef7cff773ee511dd9b8a1dbabb346d8243c917a /mail/xc-mail/Makefile
parent1452e5f02e2ef9bcbb6f31c8f0014d80ffc7f0cf (diff)
downloadports-34b7bd26df86098f01124bedcea95b79da81900c.tar.gz
ports-34b7bd26df86098f01124bedcea95b79da81900c.zip
Notes
Diffstat (limited to 'mail/xc-mail/Makefile')
-rw-r--r--mail/xc-mail/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/mail/xc-mail/Makefile b/mail/xc-mail/Makefile
new file mode 100644
index 000000000000..f7b53b140760
--- /dev/null
+++ b/mail/xc-mail/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xc-mail
+# Date created: 2000-10-01
+# Whom: Trevor Johnson <trevor@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xc-mail
+PORTVERSION= 20001001 # from CVS
+CATEGORIES= mail
+MASTER_SITES= http://people.freebsd.org/~trevor/
+
+MAINTAINER= trevor@FreeBSD.org
+
+LIB_DEPENDS= Xclasses.1:${PORTSDIR}/x11-toolkits/xclasses
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+CONFIGURE_ARGS= \
+ --includedir=${X11BASE}/include/ \
+ --libdir=${X11BASE}/lib/ \
+ --x-includes=${X11BASE}/include/ \
+ --x-libraries=${X11BASE}/lib/
+
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LDFLAGS="-L${X11BASE}/lib" \
+ LIBS="-L${X11BASE}/lib"
+
+.include <bsd.port.mk>