aboutsummaryrefslogtreecommitdiff
path: root/mail/xcite
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2018-02-01 18:03:09 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2018-02-01 18:03:09 +0000
commita3cc513bfc69ef10d52ed310dd9a6e6bb8c57491 (patch)
tree4a6b8513515fb032f2183d945863a1d39dbcd0c1 /mail/xcite
parent7a6d87cd185d39c7023ee32da472cca4f391e7f2 (diff)
downloadports-a3cc513bfc69ef10d52ed310dd9a6e6bb8c57491.tar.gz
ports-a3cc513bfc69ef10d52ed310dd9a6e6bb8c57491.zip
Flavorize and modernize Emacs ports
- Convert USE_EMACS to USES=emacs - Remove editors/emacs-nox11 (refer to nox flavors of editors/emacs and editors/emacs-devel) - Permit default Emacs flavor to be specified in make.conf - Rename japanese/migemo-emacs23 to japanese/migemo-emacs - Update and simplify audio/emms and fix build on FreeBSD 10 [1] - Update databases/bbdd and fix build on FreeBSD 10 [1] - Update editors/emacs-devel - Ensure Makefile shell commands that change directory are executed in a subshell - Silence some portlint warnings [1] By not depending on base texinfo PR: 225404 Reviewed by: antoine Approved by: portmgr (mat) ashish (maintainer) Differential Revision: https://reviews.freebsd.org/D13506
Notes
Notes: svn path=/head/; revision=460621
Diffstat (limited to 'mail/xcite')
-rw-r--r--mail/xcite/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/mail/xcite/Makefile b/mail/xcite/Makefile
index c53ea09c82cf..d7e79c5da496 100644
--- a/mail/xcite/Makefile
+++ b/mail/xcite/Makefile
@@ -3,17 +3,17 @@
PORTNAME= xcite
PORTVERSION= 1.60
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= mail elisp
MASTER_SITES= http://www.gentei.org/~yuuji/software/
-PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
DISTNAME= ${PORTNAME}.el
EXTRACT_SUFX= # empty
MAINTAINER= ume@FreeBSD.org
COMMENT= Exciting Cite for any Mail/News reading modes on Emacs
-USE_EMACS= yes
+USES= emacs
NO_WRKSUBDIR= yes
@@ -25,14 +25,14 @@ PLIST_FILES= ${EMACS_VERSION_SITE_LISPDIR}/${DISTNAME} \
${EMACS_VERSION_SITE_LISPDIR}/${DISTNAME}c
do-build:
- @cd ${WRKSRC} && ${EMACS_CMD} -batch -q -no-site-file -no-init-file \
- -f batch-byte-compile ${DISTNAME}
+ @(cd ${WRKSRC} && ${EMACS_CMD} -batch -q -no-site-file -no-init-file \
+ -f batch-byte-compile ${DISTNAME})
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}
- @${INSTALL_DATA} ${WRKSRC}/${DISTNAME} \
+ ${INSTALL_DATA} ${WRKSRC}/${DISTNAME} \
${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}
- @${INSTALL_DATA} ${WRKSRC}/${DISTNAME}c \
+ ${INSTALL_DATA} ${WRKSRC}/${DISTNAME}c \
${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}
.include <bsd.port.mk>