aboutsummaryrefslogtreecommitdiff
path: root/mail/xmailbox
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-07-04 19:42:45 +0000
committerSteve Price <steve@FreeBSD.org>1998-07-04 19:42:45 +0000
commit47c434f9bb9d52796e193942ae440d660ea3a584 (patch)
tree801b9c1a2b0878072cfe3bc4e6d0b6ebb0d1637c /mail/xmailbox
parent16a83387567e7d7889d89a0cda53fe47cfe9980c (diff)
downloadports-47c434f9bb9d52796e193942ae440d660ea3a584.tar.gz
ports-47c434f9bb9d52796e193942ae440d660ea3a584.zip
Initial import of xmailbox version 2.5.
xmailbox - mailbox checker with sound and animation for X PR: 6748 Submitted by: andy@icc.surw.chel.su
Notes
Notes: svn path=/head/; revision=11720
Diffstat (limited to 'mail/xmailbox')
-rw-r--r--mail/xmailbox/Makefile35
-rw-r--r--mail/xmailbox/distinfo1
-rw-r--r--mail/xmailbox/files/patch-aa29
-rw-r--r--mail/xmailbox/files/patch-ab16
-rw-r--r--mail/xmailbox/files/patch-ac11
-rw-r--r--mail/xmailbox/pkg-comment1
-rw-r--r--mail/xmailbox/pkg-descr10
-rw-r--r--mail/xmailbox/pkg-plist9
8 files changed, 112 insertions, 0 deletions
diff --git a/mail/xmailbox/Makefile b/mail/xmailbox/Makefile
new file mode 100644
index 000000000000..68c8412f98d4
--- /dev/null
+++ b/mail/xmailbox/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: xmailbox
+# Version required: 2.5
+# Date created: 23 May 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= xmailbox-2.5
+CATEGORIES= mail x11
+MASTER_SITES= ${MASTER_SITE_XCONTRIB}
+MASTER_SITE_SUBDIR= applications
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+
+USE_IMAKE= yes
+
+MAN1= xmailbox.1
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/xmailbox ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/xmailbox.man ${PREFIX}/man/man1/xmailbox.1
+ @ ${INSTALL_DATA} ${WRKSRC}/XMailbox.ad ${PREFIX}/lib/X11/app-defaults/XMailbox
+ @ ${MKDIR} ${PREFIX}/share/xmailbox
+ @ ${INSTALL_DATA} ${WRKSRC}/dingdong.au ${PREFIX}/share/xmailbox
+ @ ${INSTALL_DATA} ${WRKSRC}/ugotmail.au ${PREFIX}/share/xmailbox
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/xmailbox
+ @ ${INSTALL_DATA} ${WRKSRC}/DISCLAIMER ${PREFIX}/share/doc/xmailbox
+ @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xmailbox
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/xmailbox/distinfo b/mail/xmailbox/distinfo
new file mode 100644
index 000000000000..eae76e986483
--- /dev/null
+++ b/mail/xmailbox/distinfo
@@ -0,0 +1 @@
+MD5 (xmailbox-2.5.tar.gz) = 31ac48e470724267ec00f8f93ccf22af
diff --git a/mail/xmailbox/files/patch-aa b/mail/xmailbox/files/patch-aa
new file mode 100644
index 000000000000..6ca1d4791246
--- /dev/null
+++ b/mail/xmailbox/files/patch-aa
@@ -0,0 +1,29 @@
+--- Imakefile Wed Jul 16 16:36:17 1997
++++ /home/andy/tmp/wrk/Imakefile Sat May 23 23:17:12 1998
+@@ -5,7 +5,7 @@
+ # Note: you need to have XPM 3.4 or higher!
+ #------------------------------------------
+ #
+-XPMINCDIR = /usr/include/X11
++XPMINCDIR = $(X11BASE)/include/X11
+ XPMLIBDIR = /usr/X11/lib
+ XPMLIB = -L$(XPMLIBDIR) -lXpm
+
+@@ -20,7 +20,7 @@
+ # Comment the following define if you
+ # want audio support
+ #------------------------------------------
+-#define NO_AUDIO /* */
++/* #define NO_AUDIO /* */
+
+ #------------------------------------------
+ # Uncomment the following define if your
+@@ -42,7 +42,7 @@
+ # uncomment the following define to
+ # turn on sound support.
+ #------------------------------------------
+-/* SUN_AUDIO = -DSUN_AUDIO /* */
++SUN_AUDIO = -DSUN_AUDIO /* */
+
+ #------------------------------------------
+ # Uncomment the following define if you
diff --git a/mail/xmailbox/files/patch-ab b/mail/xmailbox/files/patch-ab
new file mode 100644
index 000000000000..f87044adad2f
--- /dev/null
+++ b/mail/xmailbox/files/patch-ab
@@ -0,0 +1,16 @@
+--- MailboxP.h Mon Jul 1 11:13:47 1996
++++ /home/andy/tmp/wrk/MailboxP.h Sun May 24 00:39:39 1998
+@@ -40,12 +40,10 @@
+
+ #ifdef SYSV
+ #define MAILBOX_DIRECTORY "/usr/mail"
+-#else
+-#ifdef SVR4
++#elif defined(SVR4) || defined(__FreeBSD__)
+ #define MAILBOX_DIRECTORY "/var/mail"
+ #else
+ #define MAILBOX_DIRECTORY "/usr/spool/mail"
+-#endif
+ #endif
+
+ typedef struct { /* new fields for mailbox widget */
diff --git a/mail/xmailbox/files/patch-ac b/mail/xmailbox/files/patch-ac
new file mode 100644
index 000000000000..df147ef8cdc4
--- /dev/null
+++ b/mail/xmailbox/files/patch-ac
@@ -0,0 +1,11 @@
+--- XMailbox.ad Wed Jul 16 16:13:32 1997
++++ /home/andy/tmp/wrk/XMailbox.ad Sat May 23 23:30:34 1998
+@@ -9,7 +9,7 @@
+ xmailbox*mailAnimOnce: true
+ ! xmailbox*mailAnimUpdate: 1000
+ ! xmailbox*mailapp: echo 'setenv LINES 25; setenv COLUMNS 80; xterm -n Elm -e elm' | /bin/csh -f -s
+-! xmailbox*mailSndFile: /usr/public/lib/sounds/bong.au
++xmailbox*mailSndFile: /usr/X11R6/share/xmailbox/ugotmail.au
+ ! xmailbox*mailSndComm: /usr/public/bin/play %s
+ ! xmailbox*nomailXpmFile: /usr/X11/include/X11/pixmaps/mail0.xpm
+ ! xmailbox*mailXpmFile: /usr/X11/include/X11/pixmaps/mail1.xpm
diff --git a/mail/xmailbox/pkg-comment b/mail/xmailbox/pkg-comment
new file mode 100644
index 000000000000..99b2f89c633f
--- /dev/null
+++ b/mail/xmailbox/pkg-comment
@@ -0,0 +1 @@
+Mailbox checker with sound and animation for X Window System.
diff --git a/mail/xmailbox/pkg-descr b/mail/xmailbox/pkg-descr
new file mode 100644
index 000000000000..15fd3b7dd8b4
--- /dev/null
+++ b/mail/xmailbox/pkg-descr
@@ -0,0 +1,10 @@
+The xmailbox program displays, by default, an image of a mailbox. When
+there is no mail, the image shown is that of a mailbox with its flag down.
+When new mail arrives, the image changes to that of a mailbox with the
+flag up, its door open and a letter visible inside. It can also optionally
+play a sound through the sound-card. The NCD audio server, the rplay sound
+package, FreeBSD Sun-compatible audio drivers, and an external sound player
+program are supported. By default, pressing any mouse button in the image
+forces xmailbox to remember the current size of the mail file as being the
+``empty'' size and to change its image accordingly. In addition, the user
+can optionally invoke his/her favorite mail retrieving program.
diff --git a/mail/xmailbox/pkg-plist b/mail/xmailbox/pkg-plist
new file mode 100644
index 000000000000..fd93212fea1b
--- /dev/null
+++ b/mail/xmailbox/pkg-plist
@@ -0,0 +1,9 @@
+bin/xmailbox
+lib/X11/app-defaults/XMailbox
+man/man1/xmailbox.1.gz
+share/doc/xmailbox/DISCLAIMER
+share/doc/xmailbox/README
+share/xmailbox/dingdong.au
+share/xmailbox/ugotmail.au
+@dirrm share/doc/xmailbox
+@dirrm share/xmailbox