aboutsummaryrefslogtreecommitdiff
path: root/mail/xpbiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-06-30 22:16:06 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-06-30 22:16:06 +0000
commit9ace98228e88e1b320f4128144c153e743684a44 (patch)
tree86c35ca7c1615835011a7ceb1f273c1188213d59 /mail/xpbiff
parentc84a4252969e4ee09dedc9a278978aaf2d951584 (diff)
downloadports-9ace98228e88e1b320f4128144c153e743684a44.tar.gz
ports-9ace98228e88e1b320f4128144c153e743684a44.zip
- Fix the build with modern GCC [1]
- Unquote BROKEN message per portlint(1) Reported by: pointyhat (logs) [1]
Notes
Notes: svn path=/head/; revision=194545
Diffstat (limited to 'mail/xpbiff')
-rw-r--r--mail/xpbiff/Makefile2
-rw-r--r--mail/xpbiff/files/LocPixmap.c3
2 files changed, 3 insertions, 2 deletions
diff --git a/mail/xpbiff/Makefile b/mail/xpbiff/Makefile
index 72dc58d7e053..f6c080c42784 100644
--- a/mail/xpbiff/Makefile
+++ b/mail/xpbiff/Makefile
@@ -31,7 +31,7 @@ YOUBINBINDIR= ${LOCALBASE}
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
+BROKEN= Does not compile on !i386
.endif
do-extract:
diff --git a/mail/xpbiff/files/LocPixmap.c b/mail/xpbiff/files/LocPixmap.c
index 30d37d435079..7c89f3b5d32f 100644
--- a/mail/xpbiff/files/LocPixmap.c
+++ b/mail/xpbiff/files/LocPixmap.c
@@ -45,6 +45,8 @@
* LocatePixmapFile - read a pixmap file using the normal defaults
*/
+static char **split_path_string();
+
Pixmap LocatePixmapFile (screen, name, srcname, srcnamelen,
widthp, heightp, mask)
Screen *screen;
@@ -63,7 +65,6 @@ Pixmap LocatePixmapFile (screen, name, srcname, srcnamelen,
unsigned int width, height;
int xhot, yhot;
int i;
- static char **split_path_string();
/*