aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-06 15:46:07 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-06 15:46:07 +0000
commit1e35438288f8f306e9810c558420a60a599ead18 (patch)
tree38cb13943fae31a96e63fd0fb046a9526fb9eee1 /mail
parent45a84fe0d9f097900d34c869d9ad09c2915e3385 (diff)
downloadports-1e35438288f8f306e9810c558420a60a599ead18.tar.gz
ports-1e35438288f8f306e9810c558420a60a599ead18.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Net-Server-Mail/Makefile33
-rw-r--r--mail/p5-Net-Server-Mail/distinfo2
-rw-r--r--mail/p5-Net-Server-Mail/pkg-descr10
-rw-r--r--mail/p5-Net-Server-Mail/pkg-plist13
5 files changed, 59 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index c9f7b4fe8570..4e9f534ab464 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -251,6 +251,7 @@
SUBDIR += p5-Mail-Verify
SUBDIR += p5-Net-QMTP
SUBDIR += p5-Net-SMTP-Server
+ SUBDIR += p5-Net-Server-Mail
SUBDIR += p5-POE-Component-SMTP
SUBDIR += p5-Sendmail-Milter
SUBDIR += p5-vpopmail
diff --git a/mail/p5-Net-Server-Mail/Makefile b/mail/p5-Net-Server-Mail/Makefile
new file mode 100644
index 000000000000..79687a0a1074
--- /dev/null
+++ b/mail/p5-Net-Server-Mail/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Net-Server-Mail
+# Date created: 6th February 2004
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Server-Mail
+PORTVERSION= 0.08
+CATEGORIES= mail perl5
+MASTER_SITES= ftp://ftp.rhapsodyk.net/pub/devel/perl/Net-Server-Mail/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Implementation of SMTP, ESMTP and LMTP protocols
+
+RUN_DEPENDS= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Server::Mail.3 \
+ Net::Server::Mail::ESMTP.3 \
+ Net::Server::Mail::ESMTP::Extension.3 \
+ Net::Server::Mail::LMTP.3 \
+ Net::Server::Mail::SMTP.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= This port needs Perl 5.006 or greater, please upgrade your Perl
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Net-Server-Mail/distinfo b/mail/p5-Net-Server-Mail/distinfo
new file mode 100644
index 000000000000..00195f8dc608
--- /dev/null
+++ b/mail/p5-Net-Server-Mail/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-Server-Mail-0.08.tar.gz) = 6ebc3d9ee6739443dae8dbd960bfcd6e
+SIZE (Net-Server-Mail-0.08.tar.gz) = 13676
diff --git a/mail/p5-Net-Server-Mail/pkg-descr b/mail/p5-Net-Server-Mail/pkg-descr
new file mode 100644
index 000000000000..4bb58269ea36
--- /dev/null
+++ b/mail/p5-Net-Server-Mail/pkg-descr
@@ -0,0 +1,10 @@
+This module is a versatile and extensible implementation of the SMTP protocol
+and its different evolutions like ESMTP and LMTP. The event driven
+object-oriented API makes easy to incorporate the SMTP protocol to your
+programs.
+
+Other SMTPd implementations don't support useful ESMTP extensions and the LMTP
+protocol. Their interface design precludes adding them later. So I've decided
+to rewrite a complete implementation with extensibility in mind.
+
+WWW: http://rs.rhapsodyk.net/devel/net-server-mail/
diff --git a/mail/p5-Net-Server-Mail/pkg-plist b/mail/p5-Net-Server-Mail/pkg-plist
new file mode 100644
index 000000000000..4c78a2eb2afd
--- /dev/null
+++ b/mail/p5-Net-Server-Mail/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server/Mail/.packlist
+%%SITE_PERL%%/Net/Server/Mail.pm
+%%SITE_PERL%%/Net/Server/Mail/ESMTP.pm
+%%SITE_PERL%%/Net/Server/Mail/ESMTP/Extension.pm
+%%SITE_PERL%%/Net/Server/Mail/ESMTP/PIPELINING.pm
+%%SITE_PERL%%/Net/Server/Mail/ESMTP/8BITMIME.pm
+%%SITE_PERL%%/Net/Server/Mail/LMTP.pm
+%%SITE_PERL%%/Net/Server/Mail/SMTP.pm
+@dirrm %%SITE_PERL%%/Net/Server/Mail/ESMTP
+@dirrm %%SITE_PERL%%/Net/Server/Mail
+@dirrm %%SITE_PERL%%/Net/Server
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server/Mail
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server