aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-08 11:26:08 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-08 11:26:08 +0000
commit235efa454d978201f50d6d3f8592c857cd831f65 (patch)
tree99c2302d3ff74a09dec76959ff802280200eb510 /mail
parent1ca8b4795e4dc4cedbcef7425f504a396ee449c7 (diff)
downloadports-235efa454d978201f50d6d3f8592c857cd831f65.tar.gz
ports-235efa454d978201f50d6d3f8592c857cd831f65.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/mls/Makefile24
-rw-r--r--mail/mls/distinfo1
-rw-r--r--mail/mls/files/patch-Makefile29
-rw-r--r--mail/mls/pkg-descr13
-rw-r--r--mail/mls/pkg-plist1
6 files changed, 69 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 0bf5511c6418..e544d6a1de81 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -159,6 +159,7 @@
SUBDIR += mini_sendmail
SUBDIR += minimalist
SUBDIR += ml
+ SUBDIR += mls
SUBDIR += mmc
SUBDIR += mmr
SUBDIR += movemail
diff --git a/mail/mls/Makefile b/mail/mls/Makefile
new file mode 100644
index 000000000000..a46c425908e6
--- /dev/null
+++ b/mail/mls/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: mls
+# Date created: 21 apr 2003
+# Whom: The Anarcat <anarcat@anarcat.ath.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mls
+PORTVERSION= 1.2.2
+CATEGORIES= mail
+MASTER_SITES= http://marki.host.sk/MLS/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= anarcat@anarcat.ath.cx
+COMMENT= Program for generating various statistics on emails
+
+MAN1= mls.1
+MANCOMPRESSED= yes
+
+MAKE_ARGS+= DESTDIR=${PREFIX}
+USE_GMAKE= yes
+ALL_TARGET= mls
+
+.include <bsd.port.mk>
diff --git a/mail/mls/distinfo b/mail/mls/distinfo
new file mode 100644
index 000000000000..948ff4e2e775
--- /dev/null
+++ b/mail/mls/distinfo
@@ -0,0 +1 @@
+MD5 (mls-1.2.2.tgz) = cee1c0f0c7411271df88e83682ef4684
diff --git a/mail/mls/files/patch-Makefile b/mail/mls/files/patch-Makefile
new file mode 100644
index 000000000000..b726b915a1b3
--- /dev/null
+++ b/mail/mls/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- Makefile.orig Sat Feb 15 05:16:21 2003
++++ Makefile Mon Apr 21 23:18:27 2003
+@@ -5,13 +5,13 @@
+
+ # -m386 (486,pentium,pentiumpro)
+ #OPTIMIZE=-O7 -mpentiumpro
+-OPTIMIZE=-O3
++#OPTIMIZE=-O3
+
+ # debug symbols will be stripped anyway during 'make install'
+ DEBUG=-g
+
+ #### DON'T CHANGE ANYTHING BELOW ####
+-DESTDIR=/usr/local
++DESTDIR?=/usr/local
+ CFLAGS=-Wall $(OPTIMIZE) $(DEBUG)
+ LIBS=-lm
+ CC=gcc
+@@ -31,8 +31,8 @@
+ $(CC) $(CFLAGS) -c mls_text.c -o mls_text.o
+
+ install: mls
+- install -m 755 -g root -o root -s mls $(DESTDIR)/bin
+- install -m 644 -g root -o root mls.1 $(DESTDIR)/man/man1
++ install -m 755 -g wheel -o root -s mls $(DESTDIR)/bin
++ install -m 644 -g wheel -o root mls.1 $(DESTDIR)/man/man1
+ gzip -9f $(DESTDIR)/man/man1/mls.1
+ @echo "**************************************************************"
+ @echo "*** To use HTML feature or PHP wrapper, copy contents of ***"
diff --git a/mail/mls/pkg-descr b/mail/mls/pkg-descr
new file mode 100644
index 000000000000..fae5fbbd73e8
--- /dev/null
+++ b/mail/mls/pkg-descr
@@ -0,0 +1,13 @@
+mls will read mailbox file in MBOX format and display various
+statistical data about it. You can specify input and ouput files (can
+be stdin/stdout), language used for output (in this version
+Slovak/English/Italian/Francais/Deutsch/Spanish/Serbian), error and
+diagnostic msgs are always printed in english. You can also specify
+text which will be displayed instead of standart title in output (can
+be used for automatic mailing of produced output).
+
+It also supports cache file for faster re-generation of stats from the
+same input file. It is useful when you want to show statistics on web
+- you can use HTML output & PHP wrapper.
+
+WWW: http://marki.host.sk/MLS/
diff --git a/mail/mls/pkg-plist b/mail/mls/pkg-plist
new file mode 100644
index 000000000000..a6e933438cda
--- /dev/null
+++ b/mail/mls/pkg-plist
@@ -0,0 +1 @@
+bin/mls