aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2006-05-25 16:26:50 +0000
committerSimon Barner <barner@FreeBSD.org>2006-05-25 16:26:50 +0000
commit2e39d08eeb5b0b6c7a239fcd245c8c8b0bcfe8db (patch)
treeb0f8e09781c1e5e8ef23af7b990e12595341dcaf /mail
parentc06b24019d8e89f62a6757eaf261841fc733b8db (diff)
downloadports-2e39d08eeb5b0b6c7a239fcd245c8c8b0bcfe8db.tar.gz
ports-2e39d08eeb5b0b6c7a239fcd245c8c8b0bcfe8db.zip
- Use %%RC_SUBR%% [1]
- Fix typo in Makefile [1] - Fix recursive calls of rc script on older systems (requested in [2]) - Bump PORTREVISION PR: 97876 [1], 97335 [2] Submitted by: Jeremy Chadwick <freebsd@jdc.parodius.com> [1], Veselin Slavov <vess@slavof.net> [2]
Notes
Notes: svn path=/head/; revision=163376
Diffstat (limited to 'mail')
-rw-r--r--mail/fetchmail/Makefile4
-rw-r--r--mail/fetchmail/files/fetchmail.in12
2 files changed, 11 insertions, 5 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 2da5a6ee1fcd..07ed95df5c2c 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -11,7 +11,7 @@
PORTNAME= fetchmail
PORTVERSION= 6.3.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= http://download.berlios.de/%SUBDIR%/ \
http://home.pages.de/~mandree/%SUBDIR%/ \
@@ -24,7 +24,7 @@ COMMENT= Batch mail retrieval utility for IMAP/POP2/POP3/ETRN/ODMR
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root.crt:${PORTSDIR}/security/ca-roots
USE_RC_SUBR= fetchmail
-FETCHMAILRC= ${PREFIX}/etc//fetchmailrc
+FETCHMAILRC= ${PREFIX}/etc/fetchmailrc
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/mail/fetchmail/files/fetchmail.in b/mail/fetchmail/files/fetchmail.in
index 5fc35e05fefa..de7a8c5dc2fd 100644
--- a/mail/fetchmail/files/fetchmail.in
+++ b/mail/fetchmail/files/fetchmail.in
@@ -46,7 +46,7 @@
# * `awaken': Sends a signal to the daemon(s) to check for new mail
# immediately
-. /etc/rc.subr
+. %%RC_SUBR%%
name=fetchmail
rcvar=`set_rcvar`
@@ -56,6 +56,12 @@ pidfile=/var/run/fetchmail/${name}.pid
extra_commands="awaken"
awaken_cmd="fetchmail_awaken"
+if [ -f %%PREFIX%%/etc/rc.d/fetchmail ]; then
+ fetchmail_script=/usr/local/etc/rc.d/fetchmail
+elif [ -f %%PREFIX%%/etc/rc.d/fetchmail.sh ]; then
+ fetchmail_script=/usr/local/etc/rc.d/fetchmail.sh
+fi
+
# read settings, set default values
load_rc_config "$name"
: ${fetchmail_enable="NO"}
@@ -106,7 +112,7 @@ else
# calls of this script
for user in ${fetchmail_users}; do
echo "===> fetchmail user: ${user}"
- %%PREFIX%%/etc/rc.d/fetchmail $1 ${user}
+ $fetchmail_script $1 ${user}
retcode="$?"
if [ "0${retcode}" -ne 0 ]; then
failed="${user} (${retcode}) ${failed:-}"
@@ -120,7 +126,7 @@ else
# There is only one global configuration file
globalconfig=GLOBALCONFIG
fi
- %%PREFIX%%/etc/rc.d/fetchmail $1 `id -u -n` $globalconfig
+ $fetchmail_script $1 `id -u -n` $globalconfig
retcode="$?"
if [ "0${retcode}" -ne 0 ]; then
failed="${user} (${retcode}) ${failed:-}"