aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2007-04-03 15:17:44 +0000
committerXin LI <delphij@FreeBSD.org>2007-04-03 15:17:44 +0000
commit3c7cffe97de0c8817d882feea0c93187a13cea73 (patch)
treeba583ecfc24333c79c200f826dcae9ee4619a1b5 /mail
parent6773e13e84a30a334308e4231051d096c74d7e5b (diff)
downloadports-3c7cffe97de0c8817d882feea0c93187a13cea73.tar.gz
ports-3c7cffe97de0c8817d882feea0c93187a13cea73.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/extman/Makefile43
-rw-r--r--mail/extman/distinfo3
-rw-r--r--mail/extman/files/pkg-message.in3
-rw-r--r--mail/extman/pkg-descr7
-rw-r--r--mail/extman/pkg-plist243
6 files changed, 300 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 8a845b570f1d..654467aeeb91 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -125,6 +125,7 @@
SUBDIR += exipick
SUBDIR += exmh2
SUBDIR += extmail
+ SUBDIR += extman
SUBDIR += ezmlm
SUBDIR += ezmlm-idx
SUBDIR += ezmlm-web
diff --git a/mail/extman/Makefile b/mail/extman/Makefile
new file mode 100644
index 000000000000..f6cc6765af4f
--- /dev/null
+++ b/mail/extman/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: extman
+# Date created: 3 April 2007
+# Whom: Chifeng QU <chifeng@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= extman
+PORTVERSION= 0.2.2
+CATEGORIES= mail
+MASTER_SITES= http://www.extmail.org/dist/extman/%SUBDIR%/ \
+ http://chifeng.cosoft.org.cn/extman/%SUBDIR%/
+
+MAINTAINER?= chifeng@gmail.com
+COMMENT= Web interface to manage Virtual Accounts
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+
+OPTIONS= MySQL "Use MySQL support" On \
+ LDAP "Use LDAP support" Off
+
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MySQL)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+.endif
+.if defined(WITH_LDAP)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/LDAP.pm:${PORTSDIR}/databases/p5-DBD-LDAP
+.endif
+
+OWCGIDIR= ${PREFIX}/www/extman
+
+do-install:
+ @${MKDIR} ${OWCGIDIR}
+ @cd ${WRKSRC} && ${CP} -Rpf * ${OWCGIDIR}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/mail/extman/distinfo b/mail/extman/distinfo
new file mode 100644
index 000000000000..d12ebb4f1dda
--- /dev/null
+++ b/mail/extman/distinfo
@@ -0,0 +1,3 @@
+MD5 (extman-0.2.2.tar.gz) = 2c480d25a91422eb87f2eae3672c33e2
+SHA256 (extman-0.2.2.tar.gz) = 7710b183ef809afd46afc494a14409134ba5457f5f01a21275973b404b96ff36
+SIZE (extman-0.2.2.tar.gz) = 535033
diff --git a/mail/extman/files/pkg-message.in b/mail/extman/files/pkg-message.in
new file mode 100644
index 000000000000..df2cdd31655d
--- /dev/null
+++ b/mail/extman/files/pkg-message.in
@@ -0,0 +1,3 @@
+Please run this script, from extmail to copy PMs :
+ %%PREFIX%%/www/extman/lib/Ext/buildpkg.sh
+
diff --git a/mail/extman/pkg-descr b/mail/extman/pkg-descr
new file mode 100644
index 000000000000..c72e68070d2c
--- /dev/null
+++ b/mail/extman/pkg-descr
@@ -0,0 +1,7 @@
+ExtMan -- Web interface to manage Virtual Accounts
+
+It was written in pure perl, support account store in mysql/ldap, can easily
+customize accroding html template, other backend support will be available
+soon
+
+WWW: http://www.extmail.org
diff --git a/mail/extman/pkg-plist b/mail/extman/pkg-plist
new file mode 100644
index 000000000000..ffc663582c81
--- /dev/null
+++ b/mail/extman/pkg-plist
@@ -0,0 +1,243 @@
+share/nls/POSIX
+share/nls/en_US.US-ASCII
+www/extman/AUTHORS
+www/extman/ChangeLog
+www/extman/INSTALL
+www/extman/README
+www/extman/Version
+www/extman/addon/README
+www/extman/addon/cleanup.sql
+www/extman/addon/courbd.ttf
+www/extman/addon/courier-authlib-ldap.patch
+www/extman/addon/font.ttf
+www/extman/addon/mailgraph_ext/AUTHORS
+www/extman/addon/mailgraph_ext/CHANGES
+www/extman/addon/mailgraph_ext/COPYING
+www/extman/addon/mailgraph_ext/README
+www/extman/addon/mailgraph_ext/README.ext
+www/extman/addon/mailgraph_ext/VERSION
+www/extman/addon/mailgraph_ext/mailgraph-init
+www/extman/addon/mailgraph_ext/mailgraph_ext.pl
+www/extman/addon/mailgraph_ext/qmonitor-init
+www/extman/addon/mailgraph_ext/qmonitor.pl
+www/extman/addon/mailgraph_ext/queue_mkrrd.sh
+www/extman/addon/mailgraph_ext/queue_stat.sh
+www/extman/addon/passwd2ext.pl
+www/extman/addon/upgrade_0.16_to_0.2beta3.sql
+www/extman/addon/upgrade_0.2.0_to_0.2.1.sql
+www/extman/addon/upgrade_0.2.1_to_0.2.2.sql
+www/extman/addon/upgrade_0.2beta3_to_0.2.0.sql
+www/extman/cgi/alias.cgi
+www/extman/cgi/captcha.cgi
+www/extman/cgi/domain.cgi
+www/extman/cgi/groupmail.cgi
+www/extman/cgi/index.cgi
+www/extman/cgi/manager.cgi
+www/extman/cgi/overview.cgi
+www/extman/cgi/signup.cgi
+www/extman/cgi/user.cgi
+www/extman/cgi/viewlog.cgi
+www/extman/docs/README.postfix
+www/extman/docs/backport
+www/extman/docs/extmail.schema
+www/extman/docs/extmail.sql
+www/extman/docs/init.ldif
+www/extman/docs/init.sql
+www/extman/docs/ldap_virtual_alias_maps.cf
+www/extman/docs/ldap_virtual_domains_maps.cf
+www/extman/docs/ldap_virtual_limit_maps.cf
+www/extman/docs/ldap_virtual_mailbox_maps.cf
+www/extman/docs/ldap_virtual_sender_maps.cf
+www/extman/docs/mysql_virtual_alias_maps.cf
+www/extman/docs/mysql_virtual_domains_maps.cf
+www/extman/docs/mysql_virtual_limit_maps.cf
+www/extman/docs/mysql_virtual_mailbox_maps.cf
+www/extman/docs/mysql_virtual_sender_maps.cf
+www/extman/html/default/ac.js
+www/extman/html/default/autocomplete.css
+www/extman/html/default/default.css
+www/extman/html/default/edit_alias.html
+www/extman/html/default/edit_domain.html
+www/extman/html/default/edit_groupmail.html
+www/extman/html/default/edit_manager.html
+www/extman/html/default/edit_user.html
+www/extman/html/default/editor.html
+www/extman/html/default/error.html
+www/extman/html/default/images/alias.gif
+www/extman/html/default/images/attach.gif
+www/extman/html/default/images/backup.gif
+www/extman/html/default/images/common/advclose.gif
+www/extman/html/default/images/common/bar0.gif
+www/extman/html/default/images/common/bar1.gif
+www/extman/html/default/images/common/bar2.gif
+www/extman/html/default/images/common/bar3.gif
+www/extman/html/default/images/common/bar4.gif
+www/extman/html/default/images/common/bar5.gif
+www/extman/html/default/images/common/bar6.gif
+www/extman/html/default/images/common/bar7.gif
+www/extman/html/default/images/common/bar8.gif
+www/extman/html/default/images/common/bar9.gif
+www/extman/html/default/images/common/bb_alipay.gif
+www/extman/html/default/images/common/bb_bold.gif
+www/extman/html/default/images/common/bb_center.gif
+www/extman/html/default/images/common/bb_clear.gif
+www/extman/html/default/images/common/bb_code.gif
+www/extman/html/default/images/common/bb_color.gif
+www/extman/html/default/images/common/bb_contract.gif
+www/extman/html/default/images/common/bb_email.gif
+www/extman/html/default/images/common/bb_expand.gif
+www/extman/html/default/images/common/bb_flash.gif
+www/extman/html/default/images/common/bb_fly.gif
+www/extman/html/default/images/common/bb_image.gif
+www/extman/html/default/images/common/bb_indent.gif
+www/extman/html/default/images/common/bb_italic.gif
+www/extman/html/default/images/common/bb_left.gif
+www/extman/html/default/images/common/bb_menupop.gif
+www/extman/html/default/images/common/bb_orderedlist.gif
+www/extman/html/default/images/common/bb_outdent.gif
+www/extman/html/default/images/common/bb_qq.gif
+www/extman/html/default/images/common/bb_quote.gif
+www/extman/html/default/images/common/bb_ra.gif
+www/extman/html/default/images/common/bb_redo.gif
+www/extman/html/default/images/common/bb_removeformat.gif
+www/extman/html/default/images/common/bb_right.gif
+www/extman/html/default/images/common/bb_rm.gif
+www/extman/html/default/images/common/bb_separator.gif
+www/extman/html/default/images/common/bb_table.gif
+www/extman/html/default/images/common/bb_underline.gif
+www/extman/html/default/images/common/bb_undo.gif
+www/extman/html/default/images/common/bb_unlink.gif
+www/extman/html/default/images/common/bb_unorderedlist.gif
+www/extman/html/default/images/common/bb_url.gif
+www/extman/html/default/images/common/bb_wma.gif
+www/extman/html/default/images/common/bb_wmv.gif
+www/extman/html/default/images/common/icon_signinxspace.gif
+www/extman/html/default/images/common/index.htm
+www/extman/html/default/images/common/jsmenu.gif
+www/extman/html/default/images/common/medal1.gif
+www/extman/html/default/images/common/medal10.gif
+www/extman/html/default/images/common/medal2.gif
+www/extman/html/default/images/common/medal3.gif
+www/extman/html/default/images/common/medal4.gif
+www/extman/html/default/images/common/medal5.gif
+www/extman/html/default/images/common/medal6.gif
+www/extman/html/default/images/common/medal7.gif
+www/extman/html/default/images/common/medal8.gif
+www/extman/html/default/images/common/medal9.gif
+www/extman/html/default/images/common/minus.gif
+www/extman/html/default/images/common/notice.gif
+www/extman/html/default/images/common/number0.gif
+www/extman/html/default/images/common/number1.gif
+www/extman/html/default/images/common/number2.gif
+www/extman/html/default/images/common/number3.gif
+www/extman/html/default/images/common/number4.gif
+www/extman/html/default/images/common/number5.gif
+www/extman/html/default/images/common/number6.gif
+www/extman/html/default/images/common/number7.gif
+www/extman/html/default/images/common/number8.gif
+www/extman/html/default/images/common/number9.gif
+www/extman/html/default/images/common/online_admin.gif
+www/extman/html/default/images/common/online_guest.gif
+www/extman/html/default/images/common/online_member.gif
+www/extman/html/default/images/common/online_moderator.gif
+www/extman/html/default/images/common/online_supermod.gif
+www/extman/html/default/images/common/plus.gif
+www/extman/html/default/images/common/rss.gif
+www/extman/html/default/images/common/sigline.gif
+www/extman/html/default/images/common/spacer.gif
+www/extman/html/default/images/common/watermark.gif
+www/extman/html/default/images/common/xml.gif
+www/extman/html/default/images/common/zoomin.gif
+www/extman/html/default/images/common/zoomout.gif
+www/extman/html/default/images/del.gif
+www/extman/html/default/images/domain.gif
+www/extman/html/default/images/edit.gif
+www/extman/html/default/images/fck_strip.gif
+www/extman/html/default/images/hint_sm.gif
+www/extman/html/default/images/home.gif
+www/extman/html/default/images/logo.gif
+www/extman/html/default/images/passwd.gif
+www/extman/html/default/images/sort_asc.gif
+www/extman/html/default/images/sort_desc.gif
+www/extman/html/default/images/tbk.gif
+www/extman/html/default/images/toploading.gif
+www/extman/html/default/images/user.gif
+www/extman/html/default/index.html
+www/extman/html/default/js/common.js
+www/extman/html/default/js/editor.js
+www/extman/html/default/js/menu.js
+www/extman/html/default/manlib.js
+www/extman/html/default/multifile_new.inc
+www/extman/html/default/navbar.html
+www/extman/html/default/overview.html
+www/extman/html/default/overview_alias.html
+www/extman/html/default/overview_manager.html
+www/extman/html/default/overview_user.html
+www/extman/html/default/passwd.html
+www/extman/html/default/signup.html
+www/extman/html/default/viewlog_all.html
+www/extman/html/images/donate.png
+www/extman/html/images/extman_logo.gif
+www/extman/html/index.html
+www/extman/html/plugins/chkupdate/chkupdate.js
+www/extman/html/plugins/chkupdate/style.css
+www/extman/html/plugins/phprpc_client.js
+www/extman/html/plugins/rpc_init.js
+www/extman/lang/en_US
+www/extman/lang/zh_CN
+www/extman/lang/zh_TW
+www/extman/libs/Crypt/PasswdMD5.pm
+www/extman/libs/Ext/CGI.pm
+www/extman/libs/Ext/CaptCha.pm
+www/extman/libs/Ext/Config.pm
+www/extman/libs/Ext/DateTime.pm
+www/extman/libs/Ext/GD.pm
+www/extman/libs/Ext/GraphLog.pm
+www/extman/libs/Ext/HashDir.pm
+www/extman/libs/Ext/Lang.pm
+www/extman/libs/Ext/Mgr.pm
+www/extman/libs/Ext/Mgr/LDAP.pm
+www/extman/libs/Ext/Mgr/MySQL.pm
+www/extman/libs/Ext/MgrApp.pm
+www/extman/libs/Ext/MgrApp/Alias.pm
+www/extman/libs/Ext/MgrApp/Domain.pm
+www/extman/libs/Ext/MgrApp/GroupMail.pm
+www/extman/libs/Ext/MgrApp/Login.pm
+www/extman/libs/Ext/MgrApp/Manager.pm
+www/extman/libs/Ext/MgrApp/OverView.pm
+www/extman/libs/Ext/MgrApp/Signup.pm
+www/extman/libs/Ext/MgrApp/User.pm
+www/extman/libs/Ext/MgrApp/ViewLog.pm
+www/extman/libs/Ext/Passwd.pm
+www/extman/libs/Ext/RFC822.pm
+www/extman/libs/Ext/Session.pm
+www/extman/libs/Ext/Template.pm
+www/extman/libs/Ext/Utils.pm
+www/extman/libs/Ext/buildpkg.sh
+www/extman/libs/HTML/KTemplate.pm
+www/extman/tools/expireusers.pl
+www/extman/tools/maildirmake.pl
+www/extman/tools/reportusage.pl
+www/extman/tools/t_hashdir.pl
+www/extman/webman.cf
+@dirrm www/extman/tools
+@dirrm www/extman/libs/HTML
+@dirrm www/extman/libs/Ext/MgrApp
+@dirrm www/extman/libs/Ext/Mgr
+@dirrm www/extman/libs/Ext
+@dirrm www/extman/libs/Crypt
+@dirrm www/extman/libs
+@dirrm www/extman/lang
+@dirrm www/extman/html/plugins/chkupdate
+@dirrm www/extman/html/plugins
+@dirrm www/extman/html/images
+@dirrm www/extman/html/default/js
+@dirrm www/extman/html/default/images/common
+@dirrm www/extman/html/default/images
+@dirrm www/extman/html/default
+@dirrm www/extman/html
+@dirrm www/extman/docs
+@dirrm www/extman/cgi
+@dirrm www/extman/addon/mailgraph_ext
+@dirrm www/extman/addon
+@dirrmtry www/extman