aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-29 14:38:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-29 14:38:52 +0000
commit4242259086f83c81ee2da8e6cd53a3a5498b1faa (patch)
treed9a365256016153327422b2086198f125e0bc8c7 /mail
parent6470d34864662296f97144110bfb5aa2b264b25c (diff)
downloadports-4242259086f83c81ee2da8e6cd53a3a5498b1faa.tar.gz
ports-4242259086f83c81ee2da8e6cd53a3a5498b1faa.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/claws-mail-mailmbox/Makefile28
-rw-r--r--mail/claws-mail-mailmbox/distinfo3
-rw-r--r--mail/claws-mail-mailmbox/files/patch-configure.ac15
-rw-r--r--mail/claws-mail-mailmbox/pkg-descr1
-rw-r--r--mail/sylpheed-claws-mailmbox/Makefile28
-rw-r--r--mail/sylpheed-claws-mailmbox/distinfo3
-rw-r--r--mail/sylpheed-claws-mailmbox/files/patch-configure.ac15
-rw-r--r--mail/sylpheed-claws-mailmbox/pkg-descr1
9 files changed, 95 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 7e58e00a013d..122b94ebbdc1 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -523,6 +523,7 @@
SUBDIR += swaks
SUBDIR += sylpheed
SUBDIR += sylpheed-claws
+ SUBDIR += sylpheed-claws-mailmbox
SUBDIR += sylpheed-claws-perl
SUBDIR += sylpheed-claws-smime
SUBDIR += sylpheed2
diff --git a/mail/claws-mail-mailmbox/Makefile b/mail/claws-mail-mailmbox/Makefile
new file mode 100644
index 000000000000..55a7f92de2df
--- /dev/null
+++ b/mail/claws-mail-mailmbox/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: sylpheed-claws-mailmbox
+# Date created: 3 April 2006
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mailmbox
+PORTVERSION= 1.11
+CATEGORIES= mail
+MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
+PKGNAMEPREFIX= sylpheed-claws-
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= Mbox maildir plugin for sylpheed-claws
+
+BUILD_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
+RUN_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= autoconf:259
+
+PLIST_FILES= lib/sylpheed-claws/plugins/mailmbox.a \
+ lib/sylpheed-claws/plugins/mailmbox.la \
+ lib/sylpheed-claws/plugins/mailmbox.so
+
+.include <bsd.port.mk>
diff --git a/mail/claws-mail-mailmbox/distinfo b/mail/claws-mail-mailmbox/distinfo
new file mode 100644
index 000000000000..59310b662822
--- /dev/null
+++ b/mail/claws-mail-mailmbox/distinfo
@@ -0,0 +1,3 @@
+MD5 (mailmbox-1.11.tar.gz) = d0f51ecd981a6dd20563179cb10f65d9
+SHA256 (mailmbox-1.11.tar.gz) = cf0f9209550a8b6786bebb18c93bb85bcdf8d2c12fd235097fcaeb45148afe8f
+SIZE (mailmbox-1.11.tar.gz) = 390371
diff --git a/mail/claws-mail-mailmbox/files/patch-configure.ac b/mail/claws-mail-mailmbox/files/patch-configure.ac
new file mode 100644
index 000000000000..26a4ea428414
--- /dev/null
+++ b/mail/claws-mail-mailmbox/files/patch-configure.ac
@@ -0,0 +1,15 @@
+--- configure.ac.orig Wed Apr 5 20:29:56 2006
++++ configure.ac Wed Apr 5 20:30:49 2006
+@@ -27,7 +27,11 @@
+ # Check for sylpheed-claws
+ #
+ PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 1.9.100.160)
+-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++if test -z $prefix ; then
++ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++else
++ SYLPHEED_CLAWS_PLUGINDIR=$prefix/lib/sylpheed-claws/plugins
++fi
+ AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
+ AC_SUBST(SYLPHEED_CLAWS_LIBS)
+ AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)
diff --git a/mail/claws-mail-mailmbox/pkg-descr b/mail/claws-mail-mailmbox/pkg-descr
new file mode 100644
index 000000000000..34128d66ab5a
--- /dev/null
+++ b/mail/claws-mail-mailmbox/pkg-descr
@@ -0,0 +1 @@
+This plugin handles mailboxes in mbox format.
diff --git a/mail/sylpheed-claws-mailmbox/Makefile b/mail/sylpheed-claws-mailmbox/Makefile
new file mode 100644
index 000000000000..55a7f92de2df
--- /dev/null
+++ b/mail/sylpheed-claws-mailmbox/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: sylpheed-claws-mailmbox
+# Date created: 3 April 2006
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mailmbox
+PORTVERSION= 1.11
+CATEGORIES= mail
+MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
+PKGNAMEPREFIX= sylpheed-claws-
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= Mbox maildir plugin for sylpheed-claws
+
+BUILD_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
+RUN_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= autoconf:259
+
+PLIST_FILES= lib/sylpheed-claws/plugins/mailmbox.a \
+ lib/sylpheed-claws/plugins/mailmbox.la \
+ lib/sylpheed-claws/plugins/mailmbox.so
+
+.include <bsd.port.mk>
diff --git a/mail/sylpheed-claws-mailmbox/distinfo b/mail/sylpheed-claws-mailmbox/distinfo
new file mode 100644
index 000000000000..59310b662822
--- /dev/null
+++ b/mail/sylpheed-claws-mailmbox/distinfo
@@ -0,0 +1,3 @@
+MD5 (mailmbox-1.11.tar.gz) = d0f51ecd981a6dd20563179cb10f65d9
+SHA256 (mailmbox-1.11.tar.gz) = cf0f9209550a8b6786bebb18c93bb85bcdf8d2c12fd235097fcaeb45148afe8f
+SIZE (mailmbox-1.11.tar.gz) = 390371
diff --git a/mail/sylpheed-claws-mailmbox/files/patch-configure.ac b/mail/sylpheed-claws-mailmbox/files/patch-configure.ac
new file mode 100644
index 000000000000..26a4ea428414
--- /dev/null
+++ b/mail/sylpheed-claws-mailmbox/files/patch-configure.ac
@@ -0,0 +1,15 @@
+--- configure.ac.orig Wed Apr 5 20:29:56 2006
++++ configure.ac Wed Apr 5 20:30:49 2006
+@@ -27,7 +27,11 @@
+ # Check for sylpheed-claws
+ #
+ PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 1.9.100.160)
+-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++if test -z $prefix ; then
++ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++else
++ SYLPHEED_CLAWS_PLUGINDIR=$prefix/lib/sylpheed-claws/plugins
++fi
+ AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
+ AC_SUBST(SYLPHEED_CLAWS_LIBS)
+ AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)
diff --git a/mail/sylpheed-claws-mailmbox/pkg-descr b/mail/sylpheed-claws-mailmbox/pkg-descr
new file mode 100644
index 000000000000..34128d66ab5a
--- /dev/null
+++ b/mail/sylpheed-claws-mailmbox/pkg-descr
@@ -0,0 +1 @@
+This plugin handles mailboxes in mbox format.