aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorEygene Ryabinkin <rea@FreeBSD.org>2012-03-03 04:26:17 +0000
committerEygene Ryabinkin <rea@FreeBSD.org>2012-03-03 04:26:17 +0000
commit5ee41df74e99a32738d6f5b8843f289ae9bdd42f (patch)
treef319d54c124bed8d80c9b29dfa18c1dbced6852b /mail
parentfa3060ce8026a834a44d83db82f5510559f8462e (diff)
downloadports-5ee41df74e99a32738d6f5b8843f289ae9bdd42f.tar.gz
ports-5ee41df74e99a32738d6f5b8843f289ae9bdd42f.zip
New port: mail/mu
Mu is the mail indexer that uses Xapian as the search engine. In my tests it is blazingly fast, at least 5 times faster than nmzmail and it understands cyrillic ;)) QA page: http://codelabs.ru/fbsd/ports/qa/mail/mu/0.9.8.1
Notes
Notes: svn path=/head/; revision=292562
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/mu/Makefile41
-rw-r--r--mail/mu/distinfo2
-rw-r--r--mail/mu/files/mu-ask4
-rw-r--r--mail/mu/files/patch-mu-cmd-find.c11
-rw-r--r--mail/mu/pkg-descr7
-rw-r--r--mail/mu/pkg-plist2
7 files changed, 68 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 0b4476c45c98..6fde1a096ed1 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -301,6 +301,7 @@
SUBDIR += mreport
SUBDIR += msgconvert
SUBDIR += msmtp
+ SUBDIR += mu
SUBDIR += mulberry
SUBDIR += mutt
SUBDIR += mutt-devel
diff --git a/mail/mu/Makefile b/mail/mu/Makefile
new file mode 100644
index 000000000000..1dabd79ec2b6
--- /dev/null
+++ b/mail/mu/Makefile
@@ -0,0 +1,41 @@
+# New ports collection Makefile for: mu
+# Date created: 2 March 2012
+# Whom: rea@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= mu
+PORTVERSION= 0.9.8.1
+CATEGORIES= mail
+MASTER_SITES= http://mu0.googlecode.com/files/
+
+MAINTAINER= rea@FreeBSD.org
+COMMENT= Mail searching frontend for Xapian
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= xapian:${PORTSDIR}/databases/xapian-core \
+ gmime:${PORTSDIR}/mail/gmime24
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= glib20 pkgconfig
+
+MAN1= mu-cfind.1 mu-easy.1 mu-extract.1 mu-find.1 mu-index.1 \
+ mu-mkdir.1 mu-view.1 mu-add.1 mu-remove.1 mu-server.1 mu.1 \
+ mug.1
+MAN5= mu-bookmarks.5
+
+CFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --with-gui=none
+
+do-install:
+ cd ${WRKSRC}/src && ${INSTALL_PROGRAM} mu ${PREFIX}/bin
+ cd ${FILESDIR} && ${INSTALL_SCRIPT} mu-ask ${PREFIX}/bin
+ cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN1} ${MANPREFIX}/man/man1
+ cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN5} ${MANPREFIX}/man/man5
+
+.include <bsd.port.mk>
diff --git a/mail/mu/distinfo b/mail/mu/distinfo
new file mode 100644
index 000000000000..f01344761239
--- /dev/null
+++ b/mail/mu/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mu-0.9.8.1.tar.gz) = 03423eb633e50ce589212001123dd12c8b09484f68ab1e33f5a8d2e203ea7963
+SIZE (mu-0.9.8.1.tar.gz) = 1004294
diff --git a/mail/mu/files/mu-ask b/mail/mu/files/mu-ask
new file mode 100644
index 000000000000..708d2b177851
--- /dev/null
+++ b/mail/mu/files/mu-ask
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+read -p "Query: " query
+exec mu find "$@" $query
diff --git a/mail/mu/files/patch-mu-cmd-find.c b/mail/mu/files/patch-mu-cmd-find.c
new file mode 100644
index 000000000000..6b1b9d049cd2
--- /dev/null
+++ b/mail/mu/files/patch-mu-cmd-find.c
@@ -0,0 +1,11 @@
+--- src/mu-cmd-find.c.orig 2012-03-02 23:03:51.892426975 +0400
++++ src/mu-cmd-find.c 2012-03-02 23:04:27.156423697 +0400
+@@ -476,7 +476,7 @@
+ return FALSE;
+ }
+
+- if (count) {
++ if (!count) {
+ g_set_error (err, 0, MU_ERROR_NO_MATCHES,
+ "no existing matches for search expression");
+ return FALSE;
diff --git a/mail/mu/pkg-descr b/mail/mu/pkg-descr
new file mode 100644
index 000000000000..8cba3c5757d2
--- /dev/null
+++ b/mail/mu/pkg-descr
@@ -0,0 +1,7 @@
+mu is a tool for dealing with e-mail messages stored
+in the Maildir-format, on Unix-like systems.
+mu's main purpose is to help you to find the messages
+you need, quickly; in addition, it allows you to view messages,
+extract attachments, create new maildirs, ...
+
+WWW: http://www.djcbsoftware.nl/code/mu/
diff --git a/mail/mu/pkg-plist b/mail/mu/pkg-plist
new file mode 100644
index 000000000000..674e540cf9b1
--- /dev/null
+++ b/mail/mu/pkg-plist
@@ -0,0 +1,2 @@
+bin/mu
+bin/mu-ask