aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2019-09-20 12:21:11 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2019-09-20 12:21:11 +0000
commit7aca2531e2d785929c4477143e265a8d9b0b516b (patch)
tree5eb143508ff1769e64395b54d8a3b09e1576fba0 /mail
parent2a5ef470852066fb4e7c665bc1bb5be0b206d82b (diff)
downloadports-7aca2531e2d785929c4477143e265a8d9b0b516b.tar.gz
ports-7aca2531e2d785929c4477143e265a8d9b0b516b.zip
Welcome PHP 7.4 RC 1 in the ports-tree.
There are many greater changes including: - New module ffi - Remove interbase module - Remove recode module - Remove wddx module - Many modules changes the build switches - Many modules changes the config format, so patches needed to be recreated Special thanks to tobik and ale for their support. Reviewed by: tobik, ale, joneum Sponsored by: PHP Update Service Differential Revision: https://reviews.freebsd.org/D21349
Notes
Notes: svn path=/head/; revision=512406
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/php74-imap/Makefile11
-rw-r--r--mail/php74-imap/files/patch-config.m447
3 files changed, 59 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 4ee03707d9ed..a4d35b449a42 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -483,6 +483,7 @@
SUBDIR += php71-imap
SUBDIR += php72-imap
SUBDIR += php73-imap
+ SUBDIR += php74-imap
SUBDIR += phplist
SUBDIR += phpmailer
SUBDIR += phpmailer6
diff --git a/mail/php74-imap/Makefile b/mail/php74-imap/Makefile
new file mode 100644
index 000000000000..8beb5d7a669a
--- /dev/null
+++ b/mail/php74-imap/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= mail
+
+MASTERDIR= ${.CURDIR}/../../lang/php74
+
+PKGNAMESUFFIX= -imap
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/php74-imap/files/patch-config.m4 b/mail/php74-imap/files/patch-config.m4
new file mode 100644
index 000000000000..b2a153543fe3
--- /dev/null
+++ b/mail/php74-imap/files/patch-config.m4
@@ -0,0 +1,47 @@
+--- config.m4.orig 2019-08-20 14:09:27 UTC
++++ config.m4
+@@ -105,6 +105,13 @@ PHP_ARG_WITH([imap-ssl],
+ [no],
+ [no])
+
++PHP_ARG_WITH([pcre-dir],
++ [pcre install prefix],
++ [AS_HELP_STRING([[--with-pcre-dir]],
++ [IMAP: pcre install prefix])],
++ [no],
++ [no])
++
+ if test "$PHP_IMAP" != "no"; then
+ PHP_SUBST(IMAP_SHARED_LIBADD)
+ PHP_NEW_EXTENSION(imap, php_imap.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
+@@ -120,6 +127,30 @@ if test "$PHP_IMAP" != "no"; then
+ fi
+ done
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ dnl Check for c-client version 2004
+ AC_EGREP_HEADER(mail_fetch_overview_sequence, $IMAP_INC_DIR/mail.h, [
+ AC_DEFINE(HAVE_IMAP2004,1,[ ])