aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-06 18:07:22 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-06 18:07:22 +0000
commit82f108df3064ff3c1a1e2286a12f648d68dae4cd (patch)
treeb4d5bf951a26d05982f5c0f534d2f244ff41ae41 /mail
parent7be404eb3fcc6b1994712ba54ceb56f81ab474e5 (diff)
downloadports-82f108df3064ff3c1a1e2286a12f648d68dae4cd.tar.gz
ports-82f108df3064ff3c1a1e2286a12f648d68dae4cd.zip
Add USES=xorg USES=gl, ports categories m
Add USES=xorg and USES=gl to ports in categories starting with 'm' While here, try to sprinkle other USES (mostly gnome and sdl) as needed.
Notes
Notes: svn path=/head/; revision=516916
Diffstat (limited to 'mail')
-rw-r--r--mail/asmail/Makefile2
-rw-r--r--mail/bbmail/Makefile2
-rw-r--r--mail/claws-mail/Makefile2
-rw-r--r--mail/coolmail/Makefile2
-rw-r--r--mail/evolution/Makefile2
-rw-r--r--mail/hbiff/Makefile1
-rw-r--r--mail/wmbiff/Makefile2
-rw-r--r--mail/wmmaiload/Makefile2
-rw-r--r--mail/xbuffy/Makefile2
-rw-r--r--mail/xfaces/Makefile2
-rw-r--r--mail/xmail/Makefile2
-rw-r--r--mail/xmailbox/Makefile2
-rw-r--r--mail/xmailwatcher/Makefile2
-rw-r--r--mail/xpbiff/Makefile2
14 files changed, 14 insertions, 13 deletions
diff --git a/mail/asmail/Makefile b/mail/asmail/Makefile
index ef9d8b47ab60..e4cb563a8386 100644
--- a/mail/asmail/Makefile
+++ b/mail/asmail/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= AFTERSTEP/apps/asmail/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Biff-type program, designed to match AfterStep
-USES= ssl
+USES= ssl xorg
USE_XORG= xpm
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shaping \
diff --git a/mail/bbmail/Makefile b/mail/bbmail/Makefile
index 2f8d0c2baf69..0d7d0e23d905 100644
--- a/mail/bbmail/Makefile
+++ b/mail/bbmail/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2+
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libbt.pc:x11-wm/blackbox
-USES= pkgconfig
+USES= pkgconfig xorg
USE_XORG= xext
GNU_CONFIGURE= yes
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index ccec65f199c9..24d4ce668125 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
RUN_DEPENDS= mime-support>0:misc/mime-support
USES= autoreconf gettext-tools compiler:c++11-lang cpe desktop-file-utils gettext gnome pathfix pkgconfig \
- python:3.6 shebangfix ssl
+ python:3.6 shebangfix ssl xorg
USE_XORG= ice sm
USE_GNOME= cairo gtk20 librsvg2
SHEBANG_FILES= tools/*.pl tools/*.py tools/tb2claws-mail
diff --git a/mail/coolmail/Makefile b/mail/coolmail/Makefile
index 238476525cba..72e559c5a3b4 100644
--- a/mail/coolmail/Makefile
+++ b/mail/coolmail/Makefile
@@ -13,7 +13,7 @@ COMMENT= Xbiff like mail tool with animated 3D graphics
PLIST_FILES= bin/coolmail \
man/man1/coolmail.1.gz
-USES= tar:tgz
+USES= tar:tgz xorg
USE_XORG= x11 xext xmu xi
PATCH_STRIP= -p1
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index 9841d1406857..8e2466749b72 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -45,7 +45,7 @@ PORTSCOUT= limitw:1,even
USES= compiler:c11 desktop-file-utils cmake gettext gnome \
iconv:wchar_t sqlite libarchive localbase pathfix pkgconfig \
- tar:xz
+ tar:xz xorg
USE_GNOME= cairo evolutiondataserver3 gnomedesktop3 intltool
GNU_CONFIGURE= yes
USE_XORG= x11
diff --git a/mail/hbiff/Makefile b/mail/hbiff/Makefile
index 79a2b7e4a25a..9b186e8fa3d9 100644
--- a/mail/hbiff/Makefile
+++ b/mail/hbiff/Makefile
@@ -11,6 +11,7 @@ MASTER_SITES= ftp://nuxi.ucdavis.edu/pub/misc/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Replacement for xbiff that handles popup window with mail headers
+USES= xorg
USE_XORG= x11
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
diff --git a/mail/wmbiff/Makefile b/mail/wmbiff/Makefile
index c89f40d70884..f70013d5d8c5 100644
--- a/mail/wmbiff/Makefile
+++ b/mail/wmbiff/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
OPTIONS_DEFINE= GNUTLS
-USES= shebangfix
+USES= shebangfix xorg
SHEBANG_FILES= scripts/security.debian.rb
USE_XORG= xpm
GNU_CONFIGURE= yes
diff --git a/mail/wmmaiload/Makefile b/mail/wmmaiload/Makefile
index 57e6dd08f0f0..c7019925656d 100644
--- a/mail/wmmaiload/Makefile
+++ b/mail/wmmaiload/Makefile
@@ -12,7 +12,7 @@ COMMENT= Incoming mail monitor dockapp with a similar look to wmcpuload
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake localbase:ldflags pkgconfig ssl tar:bzip2
+USES= gmake gnome localbase:ldflags pkgconfig ssl tar:bzip2 xorg
USE_XORG= xpm
USE_GNOME= gtk20
HAS_CONFIGURE= yes
diff --git a/mail/xbuffy/Makefile b/mail/xbuffy/Makefile
index 824b78c7d2c3..3a26f4e15023 100644
--- a/mail/xbuffy/Makefile
+++ b/mail/xbuffy/Makefile
@@ -11,8 +11,8 @@ DISTNAME= ${PORTNAME}-3.3.bl.3
MAINTAINER= ports@FreeBSD.org
COMMENT= Replacement for xbiff that handles multiple mail files
+USES= cpe gmake xorg
USE_XORG= xext xt xaw
-USES= cpe gmake
CPE_VENDOR= xbuffy_project
GNU_CONFIGURE= yes
PLIST_FILES= bin/xbuffy lib/X11/app-defaults/XBuffy man/man1/xbuffy.1.gz
diff --git a/mail/xfaces/Makefile b/mail/xfaces/Makefile
index 5dfe790058a1..cfbc48f4b3fc 100644
--- a/mail/xfaces/Makefile
+++ b/mail/xfaces/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= libcompface.so:mail/faces
# GNU make properly processes some overridden rules in the makefile that
# imake generates. Specifically, installing the html docs.
-USES= imake gmake tar:Z
+USES= imake gmake tar:Z xorg
USE_XORG= ice sm x11 xaw xext xmu xt xpm
post-install:
diff --git a/mail/xmail/Makefile b/mail/xmail/Makefile
index 19d5c88d20fb..bb2b0d5a7ad7 100644
--- a/mail/xmail/Makefile
+++ b/mail/xmail/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= sjroz@verizon.net
COMMENT= X-based interface to the Berkeley mail program
-USES= imake
+USES= imake xorg
USE_XORG= xbitmaps xaw
.include <bsd.port.mk>
diff --git a/mail/xmailbox/Makefile b/mail/xmailbox/Makefile
index 4fe138392cfd..3eb0b92e0da6 100644
--- a/mail/xmailbox/Makefile
+++ b/mail/xmailbox/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= XCONTRIB/applications
MAINTAINER= ports@FreeBSD.org
COMMENT= Mailbox checker with sound and animation for X Window System
-USES= imake
+USES= imake xorg
USE_XORG= xaw
OPTIONS_DEFINE= DOCS
diff --git a/mail/xmailwatcher/Makefile b/mail/xmailwatcher/Makefile
index 93d792482f93..149224e1dab7 100644
--- a/mail/xmailwatcher/Makefile
+++ b/mail/xmailwatcher/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Mailbox checker which displays sender and subject lines of mails
PLIST_FILES= bin/xmailwatcher man/man1/xmailwatcher.1.gz
-USES= imake
+USES= imake xorg
USE_XORG= ice sm x11 xaw xext xmu xpm xt
post-install:
diff --git a/mail/xpbiff/Makefile b/mail/xpbiff/Makefile
index 628b046262f5..eb84c5668a85 100644
--- a/mail/xpbiff/Makefile
+++ b/mail/xpbiff/Makefile
@@ -13,7 +13,7 @@ DISTFILES= xpbiff-1.27-with-YOUBIN.tar.gz.uu
MAINTAINER?= sanpei@FreeBSD.org
COMMENT?= Replacement for xbiff that handles popup window with mail header
-USES= imake:noman
+USES= imake:noman xorg
USE_XORG= xpm xaw xmu
PLIST_FILES= bin/xpbiff
WRKSRC= ${WRKDIR}/xpbiff