aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2016-05-27 07:02:55 +0000
committerDima Panov <fluffy@FreeBSD.org>2016-05-27 07:02:55 +0000
commit8ca6393dd40544d9c095d7a52c31e5bcdc2b1e85 (patch)
tree5209307cd7828e4e3142c42a97bbb39de475d1a7 /mail
parent0b8bed9f5412d258ec66124fce04f76bf7a146fa (diff)
downloadports-8ca6393dd40544d9c095d7a52c31e5bcdc2b1e85.tar.gz
ports-8ca6393dd40544d9c095d7a52c31e5bcdc2b1e85.zip
- Allow custom config file in rc script for both stable/devel ports
- While here, create makemap symlink only with TABLE_DB enabled Reported by: myself (for adamw) Reviewed by: adamw Approved by: miwi (mentor, implicit)
Notes
Notes: svn path=/head/; revision=415927
Diffstat (limited to 'mail')
-rw-r--r--mail/opensmtpd-devel/Makefile1
-rw-r--r--mail/opensmtpd-devel/files/smtpd.in14
-rw-r--r--mail/opensmtpd/Makefile3
-rw-r--r--mail/opensmtpd/files/smtpd.in14
4 files changed, 16 insertions, 16 deletions
diff --git a/mail/opensmtpd-devel/Makefile b/mail/opensmtpd-devel/Makefile
index dcc378e2c539..5db9c5afa3e4 100644
--- a/mail/opensmtpd-devel/Makefile
+++ b/mail/opensmtpd-devel/Makefile
@@ -5,6 +5,7 @@ PORTNAME= opensmtpd
PORTVERSION= 201602131907
DISTVERSIONSUFFIX= p1
PORTEPOCH= 1
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.opensmtpd.org/archives/ \
http://distfiles.pirateparty.in/ashish/
diff --git a/mail/opensmtpd-devel/files/smtpd.in b/mail/opensmtpd-devel/files/smtpd.in
index 5530b1c2b14d..46fe0be02ed0 100644
--- a/mail/opensmtpd-devel/files/smtpd.in
+++ b/mail/opensmtpd-devel/files/smtpd.in
@@ -18,11 +18,6 @@
. /etc/rc.subr
-check_process()
-{
- /bin/pgrep -j none -f "^$smtpd_procname\$"
-}
-
name="smtpd"
rcvar=smtpd_enable
@@ -34,18 +29,21 @@ extra_commands="configtest"
load_rc_config $name
: ${smtpd_enable:="NO"}
-: ${smtpd_config:="%%PREFIX%%/etc/mail/smtpd.conf"}
-: ${smtpd_procname:="%%PREFIX%%/sbin/smtpd"}
+: ${smtpd_config:="%%PREFIX%%/etc/mail/${name}.conf"}
+: ${smtpd_procname:="%%PREFIX%%/sbin/${name}"}
: ${smtpd_flags:=""}
command=${smtpd_procname}
+command_args="-f ${smtpd_config} ${command_args}"
+required_files="${smtpd_config}"
procname=${smtpd_procname}
+pidfile="/var/run/${name}.pid"
smtpd_checkconfig()
{
echo "Performing sanity check on smtpd configuration:"
- eval ${command} ${smtpd_flags} -n
+ eval ${command} ${command_args} ${smtpd_flags} -n
}
smtpd_precmd()
diff --git a/mail/opensmtpd/Makefile b/mail/opensmtpd/Makefile
index e0b41e1cbee4..38f607b7e4a9 100644
--- a/mail/opensmtpd/Makefile
+++ b/mail/opensmtpd/Makefile
@@ -4,6 +4,7 @@
PORTNAME= opensmtpd
PORTVERSION= 5.9.2p1
PORTEPOCH= 1
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.opensmtpd.org/archives/ \
http://distfiles.pirateparty.in/ashish/
@@ -68,7 +69,9 @@ CONFIGURE_ARGS+= --with-libasr=${LOCALBASE} \
post-patch:
${REINPLACE_CMD} -e '/chmod 2555/d' ${WRKSRC}/mk/smtpctl/Makefile.in
+.if ${PORT_OPTIONS:MTABLE_DB}
post-install:
@${LN} -sf ${PREFIX}/sbin/smtpctl ${STAGEDIR}${PREFIX}/libexec/opensmtpd/makemap
+.endif
.include <bsd.port.post.mk>
diff --git a/mail/opensmtpd/files/smtpd.in b/mail/opensmtpd/files/smtpd.in
index 6fa92ca45c12..46fe0be02ed0 100644
--- a/mail/opensmtpd/files/smtpd.in
+++ b/mail/opensmtpd/files/smtpd.in
@@ -18,11 +18,6 @@
. /etc/rc.subr
-check_process()
-{
- /bin/pgrep -j none -f "${smtpd_procname}"
-}
-
name="smtpd"
rcvar=smtpd_enable
@@ -34,18 +29,21 @@ extra_commands="configtest"
load_rc_config $name
: ${smtpd_enable:="NO"}
-: ${smtpd_config:="%%PREFIX%%/etc/mail/smtpd.conf"}
-: ${smtpd_procname:="%%PREFIX%%/sbin/smtpd"}
+: ${smtpd_config:="%%PREFIX%%/etc/mail/${name}.conf"}
+: ${smtpd_procname:="%%PREFIX%%/sbin/${name}"}
: ${smtpd_flags:=""}
command=${smtpd_procname}
+command_args="-f ${smtpd_config} ${command_args}"
+required_files="${smtpd_config}"
procname=${smtpd_procname}
+pidfile="/var/run/${name}.pid"
smtpd_checkconfig()
{
echo "Performing sanity check on smtpd configuration:"
- eval ${command} ${smtpd_flags} -n
+ eval ${command} ${command_args} ${smtpd_flags} -n
}
smtpd_precmd()