aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2021-02-19 15:14:10 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2021-02-19 15:14:10 +0000
commit8ec37e4f4203b2cdd0b58fb5c6b251153f72abb4 (patch)
treefd8562e01e3daf1d493c95682179d9e964dd8ee6 /mail
parent58eb7b74b1785d33249cfb05f75369c7d9856e2f (diff)
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/cleanup-maildir/Makefile32
-rw-r--r--mail/cleanup-maildir/distinfo3
-rw-r--r--mail/cleanup-maildir/pkg-descr5
4 files changed, 41 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 4114a494a118..963c8d257faa 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -68,6 +68,7 @@
SUBDIR += claws-mail-tnef_parse
SUBDIR += claws-mail-vcalendar
SUBDIR += clawsker
+ SUBDIR += cleanup-maildir
SUBDIR += cone
SUBDIR += coolmail
SUBDIR += courier
diff --git a/mail/cleanup-maildir/Makefile b/mail/cleanup-maildir/Makefile
new file mode 100644
index 000000000000..1a2ff42ca492
--- /dev/null
+++ b/mail/cleanup-maildir/Makefile
@@ -0,0 +1,32 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cleanup-maildir
+PORTVERSION= 0.3.1
+DISTVERSIONPREFIX= v
+CATEGORIES= mail python
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Script for cleaning up mails in Maildir folders based on arival date
+
+LICENSE= AS-IS
+LICENSE_NAME= AS-IS
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygraph>=0.2.1:graphics/py-pygraph@${PY_FLAVOR}
+
+USES= python:3.6+ shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= ehaupt
+SHEBANG_FILES= cleanup-maildir.py
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/cleanup-maildir
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/cleanup-maildir.py \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/mail/cleanup-maildir/distinfo b/mail/cleanup-maildir/distinfo
new file mode 100644
index 000000000000..6001a3a46ace
--- /dev/null
+++ b/mail/cleanup-maildir/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1613746863
+SHA256 (ehaupt-cleanup-maildir-v0.3.1_GH0.tar.gz) = b34946750417e0464db346fc5de22bd33a1dab2d7efa24b6d72148e160ef52ed
+SIZE (ehaupt-cleanup-maildir-v0.3.1_GH0.tar.gz) = 7075
diff --git a/mail/cleanup-maildir/pkg-descr b/mail/cleanup-maildir/pkg-descr
new file mode 100644
index 000000000000..9929521afb1c
--- /dev/null
+++ b/mail/cleanup-maildir/pkg-descr
@@ -0,0 +1,5 @@
+This is a script for cleaning up and archiving mails in Maildir folders based on
+the date the mail was received.
+
+The script supports thread detection and can distinguish between read and
+partially read threads.