aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 20:02:36 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 20:02:36 +0000
commit90de766569e2016b035ea1820ab2e2a7fc791e99 (patch)
tree0fef6645882a50543f2d219070270a3777f5969a /mail
parentbc11476c641b7a842ddc6ac5b9e3003d0d7b9e07 (diff)
downloadports-90de766569e2016b035ea1820ab2e2a7fc791e99.tar.gz
ports-90de766569e2016b035ea1820ab2e2a7fc791e99.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/rubygem-net-smtp/Makefile23
-rw-r--r--mail/rubygem-net-smtp/distinfo3
-rw-r--r--mail/rubygem-net-smtp/pkg-descr4
4 files changed, 31 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 213c201bdaa8..bd5c4a0c2112 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -580,6 +580,7 @@
SUBDIR += rubygem-mini_mime
SUBDIR += rubygem-net-imap
SUBDIR += rubygem-net-pop
+ SUBDIR += rubygem-net-smtp
SUBDIR += rubygem-pony
SUBDIR += rubygem-premailer
SUBDIR += rubygem-premailer-rails
diff --git a/mail/rubygem-net-smtp/Makefile b/mail/rubygem-net-smtp/Makefile
new file mode 100644
index 000000000000..f75f9feeb5b9
--- /dev/null
+++ b/mail/rubygem-net-smtp/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= net-smtp
+PORTVERSION= 0.2.1
+CATEGORIES= mail rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple Mail Transfer Protocol client library for Ruby
+
+LICENSE= BSD2CLAUSE RUBY
+LICENSE_COMB= dual
+LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-net-protocol>=0:net/rubygem-net-protocol
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/mail/rubygem-net-smtp/distinfo b/mail/rubygem-net-smtp/distinfo
new file mode 100644
index 000000000000..7faf1e0b4349
--- /dev/null
+++ b/mail/rubygem-net-smtp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609598819
+SHA256 (rubygem/net-smtp-0.2.1.gem) = d1ae74d4b75970915d7c7a548275583974cb54d09ca9c56312dc8cb7f40ff40f
+SIZE (rubygem/net-smtp-0.2.1.gem) = 16384
diff --git a/mail/rubygem-net-smtp/pkg-descr b/mail/rubygem-net-smtp/pkg-descr
new file mode 100644
index 000000000000..e8d765bd30ce
--- /dev/null
+++ b/mail/rubygem-net-smtp/pkg-descr
@@ -0,0 +1,4 @@
+Net::SMTP provides functionality to send internet mail via SMTP, the Simple Mail
+Transfer Protocol.
+
+WWW: https://github.com/ruby/net-smtp