aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2007-10-21 18:35:12 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2007-10-21 18:35:12 +0000
commit9e3978507d6555beee7fa7cc7971254216a30048 (patch)
tree5613ce5117386983458af944776b232b40295857 /mail
parente46560b18a434e748bc0c9f993c466ea28d6eacc (diff)
downloadports-9e3978507d6555beee7fa7cc7971254216a30048.tar.gz
ports-9e3978507d6555beee7fa7cc7971254216a30048.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/xf-spf/Makefile36
-rw-r--r--mail/xf-spf/distinfo3
-rw-r--r--mail/xf-spf/files/pkg-message.in39
-rw-r--r--mail/xf-spf/pkg-descr10
5 files changed, 89 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index dd5ca1c16276..856105c1c448 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -653,6 +653,7 @@
SUBDIR += wmymail
SUBDIR += xbuffy
SUBDIR += xc-mail
+ SUBDIR += xf-spf
SUBDIR += xfaces
SUBDIR += xfce4-mailwatch-plugin
SUBDIR += xfmail
diff --git a/mail/xf-spf/Makefile b/mail/xf-spf/Makefile
new file mode 100644
index 000000000000..dfa8e0b758f1
--- /dev/null
+++ b/mail/xf-spf/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: xf-spf
+# Date created: 2007-09-12
+# Whom: Felippe de Meirelles Motta <lippe@freebsdbrasil.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xf-spf
+PORTVERSION= 0.2
+CATEGORIES= mail
+MASTER_SITES= http://www6.freebsdbrasil.com.br/~eksffa/l/dev/qmail-smtpextfork/
+
+MAINTAINER= lippe@freebsdbrasil.com.br
+COMMENT= SPF checker for Qmail's SMTPEXTFORK patch
+
+LIB_DEPENDS+= spf2.2:${PORTSDIR}/mail/libspf2
+
+USE_QMAIL= yes
+USE_BZIP2= yes
+
+SUB_FILES= pkg-message
+SUB_LIST= QMAIL_PREFIX=${QMAIL_PREFIX}
+PLIST_SUB= QMAIL_PREFIX=${QMAIL_PREFIX}
+
+PORTDOCS= README TODO CHANGELOG COPYRIGHT
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/mail/xf-spf/distinfo b/mail/xf-spf/distinfo
new file mode 100644
index 000000000000..859b248e5a80
--- /dev/null
+++ b/mail/xf-spf/distinfo
@@ -0,0 +1,3 @@
+MD5 (xf-spf-0.2.tar.bz2) = 882cd99ef898a693caff3be1dec12d67
+SHA256 (xf-spf-0.2.tar.bz2) = 9ad031c1545d6b60b6cfc008ee3815ed85951f10b6795690d0ea210df0754db7
+SIZE (xf-spf-0.2.tar.bz2) = 6148
diff --git a/mail/xf-spf/files/pkg-message.in b/mail/xf-spf/files/pkg-message.in
new file mode 100644
index 000000000000..38a847cbdbfe
--- /dev/null
+++ b/mail/xf-spf/files/pkg-message.in
@@ -0,0 +1,39 @@
+=--=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
+
+The enviroment var, SPFBEHAVIOR needs to be set. If it is not set,
+xf-spf will not run, and will log a message stating SPFBEHAVIOR en-
+viroment var is not available. SPFBEHAVIOR will define the proper
+behavior of xf-spf.
+
+SPFBEHAVIOR enviroment may have values between 0 and 6, similar to
+qmail's SPF patch. You can have a full description off all behavior
+values reading the installed README file:
+
+ %%DOCSDIR%%/README
+
+If you want to disable xf-spf for some reason, or disable it's che-
+cking for one particular IP address, using tcprules(1), set
+SPFBEHAVIOR to 0.
+
+Configure xf-spf usage on qmail-smtpd's SMTPEXTFORK patch:
+
+Add %%QMAIL_PREFIX%%/bin/xf-spf to the appropriated enviroment var:
+
+ echo %%QMAIL_PREFIX%%/bin/xf-spf > /var/service/smtpd/env/SMTPEXTFORK
+
+Or use it with tcprules:
+
+ :allow,SMTPEXTFORK="%%QMAIL_PREFIX%%/bin/xf-spf"
+
+Remember that more than one program can be used with SMTPEXTFORK patch.
+If you already use any other, add xf-spf separated by comma:
+
+ :allow,SMTPEXTFORK="%%QMAIL_PREFIX%%/bin/xf-spf,/some/other/prog"
+
+Or
+
+ echo "/some/other/prog,%%QMAIL_PREFIX%%/bin/xf-spf" \
+ > /var/service/smtpd/env/SMTPEXTFORK
+
+=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
+
diff --git a/mail/xf-spf/pkg-descr b/mail/xf-spf/pkg-descr
new file mode 100644
index 000000000000..29074e01402e
--- /dev/null
+++ b/mail/xf-spf/pkg-descr
@@ -0,0 +1,10 @@
+When an SMTP session starts, xf-spf is expected to be forked from
+qmail-smtpd - this is why you need SMTPEXTFORK. When forked, this processes
+gets all enviroment variables which were available for the parent process
+(qmail-smtpd).
+
+A customized SPF checker for qmail to be used with
+SMTPEXTFORM patch, used and approved by a number of FreeBSD Brasil LTDA's
+customers.
+
+WWW: http://www6.freebsdbrasil.com.br/~eksffa/l/dev/qmail-smtpextfork/