aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-02 19:40:59 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-06-02 19:40:59 +0000
commit9fa05cbab26c31bb4844d99f33bcf4472948646e (patch)
tree6ebaf5829c72142d3a5c3a96a70bb72c787b49e2 /mail
parent2d9234768bd3255380394766d8932f1d698dffe5 (diff)
downloadports-9fa05cbab26c31bb4844d99f33bcf4472948646e.tar.gz
ports-9fa05cbab26c31bb4844d99f33bcf4472948646e.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/courier-imap/Makefile2
-rw-r--r--mail/maildrop/Makefile8
-rw-r--r--mail/sqwebmail/Makefile2
3 files changed, 6 insertions, 6 deletions
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index ec40cba081e1..cd0b2902f17f 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libcourier-unicode.so:devel/courier-unicode
CONFLICTS= courier-[0-9]* imap-uw-[0-9]* panda-imap-[0-9]*
-USES= gmake localbase:ldflags perl5 ssl tar:bzip2
+USES= compiler:c++11-lang gmake localbase:ldflags perl5 ssl tar:bzip2
GNU_CONFIGURE= yes
USE_RC_SUBR= courier-imap-imapd courier-imap-imapd-ssl \
courier-imap-pop3d courier-imap-pop3d-ssl
diff --git a/mail/maildrop/Makefile b/mail/maildrop/Makefile
index e1b6b8a4f863..766840238281 100644
--- a/mail/maildrop/Makefile
+++ b/mail/maildrop/Makefile
@@ -25,7 +25,10 @@ COMMENT= Mail delivery agent (MDA) with filtering abilities
LICENSE= GPLv3
-USES= iconv localbase:ldflags perl5 tar:bzip2
+LIB_DEPENDS= libpcre.so:devel/pcre \
+ libcourier-unicode.so:devel/courier-unicode
+
+USES= compiler:c++11-lang iconv localbase:ldflags perl5 tar:bzip2
USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-syslog=1 \
@@ -36,9 +39,6 @@ INSTALL_TARGET= install-strip
CONFLICTS= courier-0.65* libunicode-[0-9]*
-LIB_DEPENDS= libpcre.so:devel/pcre \
- libcourier-unicode.so:devel/courier-unicode
-
MAILDROP_LOG_COLUMNS?= 72 # lenght of 'File:' line in log
FIXDOCPATH= libs/liblock/lockmail.1 libs/maildir/deliverquota.8.in \
diff --git a/mail/sqwebmail/Makefile b/mail/sqwebmail/Makefile
index c1033f0fb8cf..9ec06fdb6b18 100644
--- a/mail/sqwebmail/Makefile
+++ b/mail/sqwebmail/Makefile
@@ -57,7 +57,7 @@ MAILGRP?= courier
#
# End of user variables
-USES= gettext gmake iconv perl5 tar:bzip2
+USES= compiler:c++11-lang gettext gmake iconv perl5 tar:bzip2
USE_RC_SUBR= sqwebmail-sqwebmaild
GNU_CONFIGURE= yes