aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2018-02-01 13:23:40 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2018-02-01 13:23:40 +0000
commita73c7312d70feabf0a44f220f275efcaeeba6bc9 (patch)
tree0a5a21691b88629dcfcac8ce9e26b42a828c1baa /mail
parentd39802fdd0c94e4ba66ad99e4486c975d86430cd (diff)
downloadports-a73c7312d70feabf0a44f220f275efcaeeba6bc9.tar.gz
ports-a73c7312d70feabf0a44f220f275efcaeeba6bc9.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/dovecot/Makefile2
-rw-r--r--mail/dovecot/files/patch-src_lib-auth_auth-client-request.c6
-rw-r--r--mail/dovecot/files/patch-src_lib-auth_auth-server-connection.c13
-rw-r--r--mail/dovecot/files/patch-src_lib-auth_auth-server-connection.h9
4 files changed, 27 insertions, 3 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index e2b44792bce1..160e4f57eaf3 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -13,7 +13,7 @@
PORTNAME= dovecot
PORTVERSION= 2.2.33.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail ipv6
MASTER_SITES= https://www.dovecot.org/releases/2.2/
diff --git a/mail/dovecot/files/patch-src_lib-auth_auth-client-request.c b/mail/dovecot/files/patch-src_lib-auth_auth-client-request.c
index 7cc94b62f148..ea72b475af69 100644
--- a/mail/dovecot/files/patch-src_lib-auth_auth-client-request.c
+++ b/mail/dovecot/files/patch-src_lib-auth_auth-client-request.c
@@ -1,10 +1,12 @@
--- src/lib-auth/auth-client-request.c.orig 2017-10-05 17:10:44 UTC
+++ src/lib-auth/auth-client-request.c
-@@ -180,6 +180,7 @@ void auth_client_request_abort(struct auth_client_requ
+@@ -180,6 +180,9 @@ void auth_client_request_abort(struct auth_client_requ
auth_client_send_cancel(request->conn->client, request->id);
call_callback(request, AUTH_REQUEST_STATUS_ABORT, NULL, NULL);
-+ pool_unref(&request->pool);
++ /* remove the request */
++ auth_server_connection_remove_request(request->conn, request->id);
++ pool_unref(&request->pool);
}
unsigned int auth_client_request_get_id(struct auth_client_request *request)
diff --git a/mail/dovecot/files/patch-src_lib-auth_auth-server-connection.c b/mail/dovecot/files/patch-src_lib-auth_auth-server-connection.c
new file mode 100644
index 000000000000..69fa39426051
--- /dev/null
+++ b/mail/dovecot/files/patch-src_lib-auth_auth-server-connection.c
@@ -0,0 +1,13 @@
+--- src/lib-auth/auth-server-connection.c.orig 2017-10-05 17:10:44 UTC
++++ src/lib-auth/auth-server-connection.c
+@@ -481,3 +481,10 @@ auth_server_connection_add_request(struct auth_server_
+ hash_table_insert(conn->requests, POINTER_CAST(id), request);
+ return id;
+ }
++
++void auth_server_connection_remove_request(struct auth_server_connection *conn,
++ unsigned int id)
++{
++ i_assert(conn->handshake_received);
++ hash_table_remove(conn->requests, POINTER_CAST(id));
++}
diff --git a/mail/dovecot/files/patch-src_lib-auth_auth-server-connection.h b/mail/dovecot/files/patch-src_lib-auth_auth-server-connection.h
new file mode 100644
index 000000000000..e331bbdd2d61
--- /dev/null
+++ b/mail/dovecot/files/patch-src_lib-auth_auth-server-connection.h
@@ -0,0 +1,9 @@
+--- src/lib-auth/auth-server-connection.h.orig 2017-10-05 17:10:44 UTC
++++ src/lib-auth/auth-server-connection.h
+@@ -38,4 +38,6 @@ void auth_server_connection_disconnect(struct auth_ser
+ unsigned int
+ auth_server_connection_add_request(struct auth_server_connection *conn,
+ struct auth_client_request *request);
++void auth_server_connection_remove_request(struct auth_server_connection *conn,
++ unsigned int id);
+ #endif