aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-10 06:09:21 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-10 06:09:21 +0000
commita928f1a1ae734c08876020001c8a96ce1a8f99eb (patch)
treefc8e2c71a0267e11f2b32c96cca1b59a8a268dee /mail
parent31e8f0bdcd0f850708cd6797be3f215691e7b620 (diff)
downloadports-a928f1a1ae734c08876020001c8a96ce1a8f99eb.tar.gz
ports-a928f1a1ae734c08876020001c8a96ce1a8f99eb.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/mb2md/Makefile30
-rw-r--r--mail/mb2md/distinfo1
-rw-r--r--mail/mb2md/pkg-descr7
-rw-r--r--mail/mb2md/pkg-plist1
5 files changed, 40 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index e544d6a1de81..2dcbfb89619c 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -139,6 +139,7 @@
SUBDIR += majorcool
SUBDIR += majordomo
SUBDIR += mavbiff
+ SUBDIR += mb2md
SUBDIR += mboxgrep
SUBDIR += mbx2mbox
SUBDIR += mess822
diff --git a/mail/mb2md/Makefile b/mail/mb2md/Makefile
new file mode 100644
index 000000000000..ed9f9d4b3ba9
--- /dev/null
+++ b/mail/mb2md/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mb2md
+# Date created: 20 June 2003
+# Whom: Andy Gilligan
+#
+# $FreeBSD$
+#
+
+PORTNAME= mb2md
+PORTVERSION= 3.10
+CATEGORIES= mail
+MASTER_SITES= http://batleth.sapienti-sat.org/projects/mb2md/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.pl
+EXTRACT_SUFX= .gz
+
+MAINTAINER= andy@evo6.org
+COMMENT= Converts mbox mailboxes to Maildir
+
+RUN_DEPENDS= ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate
+
+USE_PERL5_RUN= yes
+EXTRACT_CMD= ${GZIP_CMD} -cd > ${DISTNAME}
+WRKSRC= ${.CURDIR}
+
+NO_BUILD= true
+INSTALL_TARGET= real-install
+
+real-install:
+ @${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/mail/mb2md/distinfo b/mail/mb2md/distinfo
new file mode 100644
index 000000000000..f790951a865b
--- /dev/null
+++ b/mail/mb2md/distinfo
@@ -0,0 +1 @@
+MD5 (mb2md-3.10.pl.gz) = b9a8cf81cd5c15ed1e04216661ad1122
diff --git a/mail/mb2md/pkg-descr b/mail/mb2md/pkg-descr
new file mode 100644
index 000000000000..1175d3408de6
--- /dev/null
+++ b/mail/mb2md/pkg-descr
@@ -0,0 +1,7 @@
+This is a Perl script that reads a directory of Mbox format
+mailboxes and converts them to Maildir format.
+
+Some details of this are to suit Courier IMAP's naming
+conventions for Maildir mailboxes.
+
+WWW: http://batleth.sapienti-sat.org/projects/mb2md/
diff --git a/mail/mb2md/pkg-plist b/mail/mb2md/pkg-plist
new file mode 100644
index 000000000000..f131a894517c
--- /dev/null
+++ b/mail/mb2md/pkg-plist
@@ -0,0 +1 @@
+bin/mb2md