aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-03-03 21:40:32 +0000
committerSteve Wills <swills@FreeBSD.org>2019-03-03 21:40:32 +0000
commita9d5731e9a89ef5215ca73f75eb74454e4f5fb32 (patch)
tree4fdc4503216e8d1fe62289e6829f845c0a90a640 /mail
parent494c41d17d7e6e160071c479b456622509b849f6 (diff)
downloadports-a9d5731e9a89ef5215ca73f75eb74454e4f5fb32.tar.gz
ports-a9d5731e9a89ef5215ca73f75eb74454e4f5fb32.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/notmuch/Makefile2
-rw-r--r--mail/notmuch/distinfo6
-rw-r--r--mail/notmuch/files/patch-bindings_python_docs_source_conf.py23
3 files changed, 27 insertions, 4 deletions
diff --git a/mail/notmuch/Makefile b/mail/notmuch/Makefile
index 19c96bc42e75..38dedd3bb68c 100644
--- a/mail/notmuch/Makefile
+++ b/mail/notmuch/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= notmuch
-PORTVERSION= 0.28.1
+PORTVERSION= 0.28.2
CATEGORIES?= mail
MASTER_SITES= https://notmuchmail.org/releases/
diff --git a/mail/notmuch/distinfo b/mail/notmuch/distinfo
index 47439f0bfbc1..bc3936fb0656 100644
--- a/mail/notmuch/distinfo
+++ b/mail/notmuch/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1549122016
-SHA256 (notmuch-0.28.1.tar.gz) = d111e938137d5a465afc2b133d14df1fa356537d9ce752c919fe5673f3749a55
-SIZE (notmuch-0.28.1.tar.gz) = 921529
+TIMESTAMP = 1551537254
+SHA256 (notmuch-0.28.2.tar.gz) = 85a6498033451e188bcebbb3a4841e77c8d07b7fb1db89f17a74d6038f73e931
+SIZE (notmuch-0.28.2.tar.gz) = 921580
diff --git a/mail/notmuch/files/patch-bindings_python_docs_source_conf.py b/mail/notmuch/files/patch-bindings_python_docs_source_conf.py
new file mode 100644
index 000000000000..8ed1ee25b2b2
--- /dev/null
+++ b/mail/notmuch/files/patch-bindings_python_docs_source_conf.py
@@ -0,0 +1,23 @@
+--- bindings/python/docs/source/conf.py.orig 2019-03-02 23:40:44 UTC
++++ bindings/python/docs/source/conf.py
+@@ -13,7 +13,19 @@
+
+ import sys, os
+
+-from unittest.mock import Mock
++try:
++ from unittest.mock import Mock
++except ImportError:
++ class Mock(object):
++ def __init__(self, *args, **kwargs):
++ pass
++
++ def __call__(self, *args, **kwargs):
++ return Mock()
++
++ @classmethod
++ def __getattr__(self, name):
++ return Mock() if name not in ('__file__', '__path__') else '/dev/null'
+
+ # If extensions (or modules to document with autodoc) are in another directory,
+ # add these directories to sys.path here. If the directory is relative to the