aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-07-04 21:53:31 +0000
committerFlorian Smeets <flo@FreeBSD.org>2013-07-04 21:53:31 +0000
commitad0beaf909ff4b54ca36eadad160da36c82f9666 (patch)
tree6b45b118fcf8cc4300c8a455bd5e989492b73ff3 /mail
parent2a03acfee04b88df08a56aa7d4248817d58ad74f (diff)
Don't manually rm wildcard directories, automatically add all files to the
plist. This should fixes warning on deinstall as the files were deleted in the pre-deinstall target, and once pkg wanted to remove files specified in the plist they were already gone.
Notes
Notes: svn path=/head/; revision=322291
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird-i18n/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/mail/thunderbird-i18n/Makefile b/mail/thunderbird-i18n/Makefile
index b3c49a5317eb..e0517a939923 100644
--- a/mail/thunderbird-i18n/Makefile
+++ b/mail/thunderbird-i18n/Makefile
@@ -67,8 +67,14 @@ do-install:
@${ECHO_CMD} '@exec ${INSTALL} -d ${XPI_SLDIRS_ALL:S,^${PREFIX},%D,}' ${_A}
@${ECHO_CMD} '@exec for _dir in ${XPI_LINKFARMS} ; { \
${LN} -sf ${XPI_LIBDIR}/${WDIR} $$_dir/ ${_Q}; }' ${_A}
- @${ECHO_CMD} '@unexec for _dir in ${XPI_LINKFARMS} ${XPI_LIBDIR}; { ${RM} -fR $$_dir/${WDIR} ; }' ${_A}
- @${ECHO_CMD} '@unexec ${RMDIR} ${XPI_DIRS_TRY:S,^,%D/,} ${_Q}' ${_A}
+ @for lang in ${THUNDERBIRD_I18N_}; do \
+ for xpi in ${XPI_LINKFARMS} ; do \
+ if [ -d $${xpi} ] ; \
+ then \
+ ${ECHO_CMD} $$xpi/langpack-$$lang@thunderbird.mozilla.org ${_A} ; \
+ fi ; \
+ done ; \
+ done
post-patch:
${FIND} ${WRKSRC} -name install.rdf -print0 | \