aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-21 15:03:21 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-21 15:03:21 +0000
commitd5ff8a6f266cf5de28db26e67f1419734cbb269a (patch)
tree5138a1fbaa5f365b05e0393b9a06c77bc072ae62 /mail
parent520d8028edcd62c3bc9ea788908e569cb3c36067 (diff)
downloadports-d5ff8a6f266cf5de28db26e67f1419734cbb269a.tar.gz
ports-d5ff8a6f266cf5de28db26e67f1419734cbb269a.zip
SquirrelMail (mail/suirrelmail) Plug-In to allow users to change their user
passwords stored in an LDAP directory from within SquirrelMail. PR: ports/83950 Submitted by: Alexander Wittig <alexander@wittig.name>
Notes
Notes: svn path=/head/; revision=148943
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/squirrelmail-change_ldappass-plugin/Makefile73
-rw-r--r--mail/squirrelmail-change_ldappass-plugin/distinfo3
-rw-r--r--mail/squirrelmail-change_ldappass-plugin/files/pkg-message.in5
-rw-r--r--mail/squirrelmail-change_ldappass-plugin/pkg-descr7
-rw-r--r--mail/squirrelmail-change_ldappass-plugin/pkg-plist45
6 files changed, 134 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 768f7a7f2381..72a52dc525a7 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -504,6 +504,7 @@
SUBDIR += spruce
SUBDIR += sqlgrey
SUBDIR += squirrelmail
+ SUBDIR += squirrelmail-change_ldappass-plugin
SUBDIR += squirrelmail-compatibility-plugin
SUBDIR += sqwebmail
SUBDIR += ssmtp
diff --git a/mail/squirrelmail-change_ldappass-plugin/Makefile b/mail/squirrelmail-change_ldappass-plugin/Makefile
new file mode 100644
index 000000000000..5b00ab2acfa5
--- /dev/null
+++ b/mail/squirrelmail-change_ldappass-plugin/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: squirrelmail-change_ldappass-plugin
+# Date created: 3 Jul 2005
+# Whom: Alexander Wittig <alexander@wittig.name>
+#
+# $FreeBSD$
+
+PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTVERSION= 1.8
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= alexander@wittig.name
+COMMENT= Allows users to change their passwords stored in LDAP Tree
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= change_ldappass
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
+.else
+. ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+. else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+. endif
+.endif
+
+SUB_FILES= pkg-message
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= ldap
+WANT_PHP_WEB= yes
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/squirrelmail-change_ldappass-plugin/distinfo b/mail/squirrelmail-change_ldappass-plugin/distinfo
new file mode 100644
index 000000000000..8d2f7f0b0b01
--- /dev/null
+++ b/mail/squirrelmail-change_ldappass-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/change_ldappass-1.8.tar.gz) = 63970d47d3d9a20c8732a76a673e012f
+SHA256 (squirrelmail/change_ldappass-1.8.tar.gz) = 975874a242a3c223ef3233a9395818e7b6e771d8c46edc15b131dc49b564fe7b
+SIZE (squirrelmail/change_ldappass-1.8.tar.gz) = 17275
diff --git a/mail/squirrelmail-change_ldappass-plugin/files/pkg-message.in b/mail/squirrelmail-change_ldappass-plugin/files/pkg-message.in
new file mode 100644
index 000000000000..f163e72fe7ab
--- /dev/null
+++ b/mail/squirrelmail-change_ldappass-plugin/files/pkg-message.in
@@ -0,0 +1,5 @@
+For the port to work properly you must copy the file
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/change_ldappass/config.php.sample
+to
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/change_ldappass/config.php
+and edit the configuration to meet your needs.
diff --git a/mail/squirrelmail-change_ldappass-plugin/pkg-descr b/mail/squirrelmail-change_ldappass-plugin/pkg-descr
new file mode 100644
index 000000000000..830519db85eb
--- /dev/null
+++ b/mail/squirrelmail-change_ldappass-plugin/pkg-descr
@@ -0,0 +1,7 @@
+SquirrelMail (mail/suirrelmail) Plug-In to allow users to change their user
+passwords stored in an LDAP directory from within SquirrelMail.
+
+WWW: http://www.squirrelmail.org
+
+- Alexander Wittig
+alexander@wittig.name
diff --git a/mail/squirrelmail-change_ldappass-plugin/pkg-plist b/mail/squirrelmail-change_ldappass-plugin/pkg-plist
new file mode 100644
index 000000000000..9c84c0d0ce3f
--- /dev/null
+++ b/mail/squirrelmail-change_ldappass-plugin/pkg-plist
@@ -0,0 +1,45 @@
+@unexec %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin change_ldappass
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/fr_FR/LC_MESSAGES/change_ldappass.mo
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/fr_FR/LC_MESSAGES/change_ldappass.po
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/pl/LC_MESSAGES/change_ldappass.mo
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/pl/LC_MESSAGES/change_ldappass.po
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/pt_BR/LC_MESSAGES/change_ldappass.mo
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/pt_BR/LC_MESSAGES/change_ldappass.po
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/no_NO/LC_MESSAGES/change_ldappass.mo
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/no_NO/LC_MESSAGES/change_ldappass.po
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/PL_pl/LC_MESSAGES/change_ldappass.mo
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/PL_pl/LC_MESSAGES/change_ldappass.po
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/de/LC_MESSAGES/change_ldappass.mo
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/fr/LC_MESSAGES/change_ldappass.mo
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/fr/LC_MESSAGES/change_ldappass.po
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/es/LC_MESSAGES/change_ldappass.mo
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/el_GR/LC_MESSAGES/change_ldappass.mo
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/el_GR/LC_MESSAGES/change_ldappass.po
+%%SQUIRRELDIR%%/plugins/change_ldappass/locale/change_ldappass.po
+%%SQUIRRELDIR%%/plugins/change_ldappass/README
+%%SQUIRRELDIR%%/plugins/change_ldappass/config.php.sample
+%%SQUIRRELDIR%%/plugins/change_ldappass/version
+%%SQUIRRELDIR%%/plugins/change_ldappass/setup.php
+%%SQUIRRELDIR%%/plugins/change_ldappass/INSTALL
+%%SQUIRRELDIR%%/plugins/change_ldappass/options.php
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/de/LC_MESSAGES
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/PL_pl/LC_MESSAGES
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/no_NO/LC_MESSAGES
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/pt_BR/LC_MESSAGES
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/fr_FR/LC_MESSAGES
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/el_GR/LC_MESSAGES
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/es/LC_MESSAGES
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/fr/LC_MESSAGES
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/pl/LC_MESSAGES
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/de
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/fr
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/es
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/PL_pl
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/no_NO
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/pt_BR
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/pl
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/fr_FR
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale/el_GR
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/locale
+@dirrm %%SQUIRRELDIR%%/plugins/change_ldappass/
+@exec %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin change_ldappass