aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-03-02 09:22:59 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-03-02 09:22:59 +0000
commitd86810aa80975f7a83eb6a023b37871a5f600369 (patch)
treead2b6f5141cbb1cbaaed878ee2e95ea9f08d4e07 /mail
parent7b72b3c9c2277de1d87ed57d07f1dcaf6e3bec1a (diff)
downloadports-d86810aa80975f7a83eb6a023b37871a5f600369.tar.gz
ports-d86810aa80975f7a83eb6a023b37871a5f600369.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/roundcube-markasjunk2/Makefile30
-rw-r--r--mail/roundcube-markasjunk2/distinfo2
-rw-r--r--mail/roundcube-markasjunk2/pkg-descr8
-rw-r--r--mail/roundcube-markasjunk2/pkg-plist42
5 files changed, 83 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index a37aa01a0f81..ea751ff3758e 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -573,6 +573,7 @@
SUBDIR += roundcube-groupvice
SUBDIR += roundcube-html5_notifier
SUBDIR += roundcube-login_info
+ SUBDIR += roundcube-markasjunk2
SUBDIR += roundcube-mobilecube
SUBDIR += roundcube-mvision2
SUBDIR += roundcube-sauserprefs
diff --git a/mail/roundcube-markasjunk2/Makefile b/mail/roundcube-markasjunk2/Makefile
new file mode 100644
index 000000000000..1eca15bd39e8
--- /dev/null
+++ b/mail/roundcube-markasjunk2/Makefile
@@ -0,0 +1,30 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= markasjunk2
+PORTVERSION= 1.9
+CATEGORIES= mail
+PKGNAMEPREFIX= roundcube-
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Roundcube mark-as-junk / mark-as-not-junk plugin
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= roundcube>=1.0:mail/roundcube
+RUN_DEPENDS= roundcube>=1.0:mail/roundcube
+
+USE_GITHUB= yes
+GH_ACCOUNT= JohnDoh
+GH_PROJECT= Roundcube-Plugin-Mark-as-Junk-2
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+WWWDIR= ${PREFIX}/www/roundcube/plugins/markasjunk2
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ cd ${WRKSRC} && ${PAX} -r -w . ${STAGEDIR}${WWWDIR}
+
+.include <bsd.port.mk>
diff --git a/mail/roundcube-markasjunk2/distinfo b/mail/roundcube-markasjunk2/distinfo
new file mode 100644
index 000000000000..7feae823cb27
--- /dev/null
+++ b/mail/roundcube-markasjunk2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (JohnDoh-Roundcube-Plugin-Mark-as-Junk-2-1.9_GH0.tar.gz) = e4cfd587ad4b4c44f77e100622ba869c45a5ac5d419642c4bd3f0665890b7b9c
+SIZE (JohnDoh-Roundcube-Plugin-Mark-as-Junk-2-1.9_GH0.tar.gz) = 28344
diff --git a/mail/roundcube-markasjunk2/pkg-descr b/mail/roundcube-markasjunk2/pkg-descr
new file mode 100644
index 000000000000..7290585c8821
--- /dev/null
+++ b/mail/roundcube-markasjunk2/pkg-descr
@@ -0,0 +1,8 @@
+This plugin adds "mark as spam" or "mark as not spam" button to the message
+menu. When not in the Junk mailbox, messages are moved into the Junk mailbox
+and marked as read. When in the Junk mailbox, the buttons are changed to "mark
+as not spam" or "this message is not spam" and the message is moved to the
+Inbox. The learning driver allows you to perform additional processing on each
+message marked as spam/ham.
+
+WWW: https://github.com/JohnDoh/Roundcube-Plugin-Mark-as-Junk-2
diff --git a/mail/roundcube-markasjunk2/pkg-plist b/mail/roundcube-markasjunk2/pkg-plist
new file mode 100644
index 000000000000..708681cdf4cb
--- /dev/null
+++ b/mail/roundcube-markasjunk2/pkg-plist
@@ -0,0 +1,42 @@
+%%WWWDIR%%/.gitignore
+%%WWWDIR%%/CHANGELOG
+%%WWWDIR%%/README.md
+%%WWWDIR%%/composer.json
+%%WWWDIR%%/config.inc.php.dist
+%%WWWDIR%%/drivers/amavis_blacklist.php
+%%WWWDIR%%/drivers/cmd_learn.php
+%%WWWDIR%%/drivers/dir_learn.php
+%%WWWDIR%%/drivers/edit_headers.php
+%%WWWDIR%%/drivers/email_learn.php
+%%WWWDIR%%/drivers/sa_blacklist.php
+%%WWWDIR%%/drivers/sa_detach.php
+%%WWWDIR%%/localization/ca_ES.inc
+%%WWWDIR%%/localization/cs_CZ.inc
+%%WWWDIR%%/localization/de_CH.inc
+%%WWWDIR%%/localization/de_DE.inc
+%%WWWDIR%%/localization/en_GB.inc
+%%WWWDIR%%/localization/en_US.inc
+%%WWWDIR%%/localization/es_AR.inc
+%%WWWDIR%%/localization/es_ES.inc
+%%WWWDIR%%/localization/fa_IR.inc
+%%WWWDIR%%/localization/fr_FR.inc
+%%WWWDIR%%/localization/gl_ES.inc
+%%WWWDIR%%/localization/hu_HU.inc
+%%WWWDIR%%/localization/it_IT.inc
+%%WWWDIR%%/localization/ja_JP.inc
+%%WWWDIR%%/localization/lv_LV.inc
+%%WWWDIR%%/localization/nl_NL.inc
+%%WWWDIR%%/localization/pl_PL.inc
+%%WWWDIR%%/localization/pt_BR.inc
+%%WWWDIR%%/localization/ro_RO.inc
+%%WWWDIR%%/localization/ru_RU.inc
+%%WWWDIR%%/localization/tr_TR.inc
+%%WWWDIR%%/localization/zh_TW.inc
+%%WWWDIR%%/markasjunk2.js
+%%WWWDIR%%/markasjunk2.php
+%%WWWDIR%%/skins/classic/images/mail_toolbar.png
+%%WWWDIR%%/skins/classic/images/messageactions.png
+%%WWWDIR%%/skins/classic/markasjunk2.css
+%%WWWDIR%%/skins/larry/images/mail_toolbar.png
+%%WWWDIR%%/skins/larry/images/messageactions.png
+%%WWWDIR%%/skins/larry/markasjunk2.css