aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-01-24 11:54:20 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-01-24 11:54:20 +0000
commitdb021968e3411b659e079e540742896abe4193f1 (patch)
treead7f282ff1e254cc6c54bfc24d23efee0af4d12e /mail
parent93028a155ae531c7c9a6c723a6d465b49a90e9df (diff)
downloadports-db021968e3411b659e079e540742896abe4193f1.tar.gz
ports-db021968e3411b659e079e540742896abe4193f1.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/php71-imap/Makefile9
-rw-r--r--mail/php71-imap/files/patch-config.m442
2 files changed, 51 insertions, 0 deletions
diff --git a/mail/php71-imap/Makefile b/mail/php71-imap/Makefile
new file mode 100644
index 000000000000..5eca0839451e
--- /dev/null
+++ b/mail/php71-imap/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= mail
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -imap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/php71-imap/files/patch-config.m4 b/mail/php71-imap/files/patch-config.m4
new file mode 100644
index 000000000000..ab7120b2c8c8
--- /dev/null
+++ b/mail/php71-imap/files/patch-config.m4
@@ -0,0 +1,42 @@
+--- config.m4.orig 2010-02-07 14:06:54.000000000 +0100
++++ config.m4 2010-03-08 11:56:24.000000000 +0100
+@@ -103,6 +103,8 @@
+ PHP_ARG_WITH(imap-ssl,for IMAP SSL support,
+ [ --with-imap-ssl[=DIR] IMAP: Include SSL support. DIR is the OpenSSL install prefix], no, no)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir IMAP: pcre install prefix], no, no)
+
+ if test "$PHP_IMAP" != "no"; then
+ PHP_SUBST(IMAP_SHARED_LIBADD)
+@@ -119,6 +121,30 @@
+ fi
+ done
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ dnl Check for c-client version 2004
+ AC_EGREP_HEADER(mail_fetch_overview_sequence, $IMAP_INC_DIR/mail.h, [
+ AC_DEFINE(HAVE_IMAP2004,1,[ ])