aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2007-02-09 10:39:37 +0000
committerRenato Botelho <garga@FreeBSD.org>2007-02-09 10:39:37 +0000
commitf5044e502515ba8f53c64056c7318266c0ebf447 (patch)
tree553d535382e25377120578df6d682b95a9dfa47c /mail
parent8c61a9f5e6bf55be1da0e5fc65d7069b99ba3589 (diff)
downloadports-f5044e502515ba8f53c64056c7318266c0ebf447.tar.gz
ports-f5044e502515ba8f53c64056c7318266c0ebf447.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/qmail-auditor/Makefile45
-rw-r--r--mail/qmail-auditor/distinfo3
-rw-r--r--mail/qmail-auditor/files/pkg-message.in28
-rw-r--r--mail/qmail-auditor/pkg-descr7
5 files changed, 84 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 72babcce2ecb..2d0650dc68d8 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -461,6 +461,7 @@
SUBDIR += qmHandle
SUBDIR += qmail
SUBDIR += qmail-activedir
+ SUBDIR += qmail-auditor
SUBDIR += qmail-autoresponder
SUBDIR += qmail-conf
SUBDIR += qmail-contrib
diff --git a/mail/qmail-auditor/Makefile b/mail/qmail-auditor/Makefile
new file mode 100644
index 000000000000..11d5c9c1ab55
--- /dev/null
+++ b/mail/qmail-auditor/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: qmail-auditor
+# Date created: 2007-02-08
+# Whom: Patrick Tracanelli <eksffa@freebsdbrasil.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qmail-auditor
+PORTVERSION= 0.47
+CATEGORIES= mail
+MASTER_SITES= SF http://www6.freebsdbrasil.com.br/~eksffa/l/qmail-auditor/
+
+MAINTAINER= eksffa@freebsdbrasil.com.br
+COMMENT= Selective e-mail auditing for qmail by means of qmail-queue wrapping
+
+WRKSRC= ${WRKDIR}/${PORTNAME:R}
+
+USE_QMAIL_RUN= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+SUB_FILES= pkg-message
+SUB_LIST= QMAIL_PREFIX=${QMAIL_PREFIX}
+
+PLIST_FILES= bin/qmail-auditor
+
+PORTDOCS= README
+
+INSTALL_TARGET= perm
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|@prefix@|g' \
+ ${WRKSRC}/src/Makefile.in
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/mail/qmail-auditor/distinfo b/mail/qmail-auditor/distinfo
new file mode 100644
index 000000000000..b1cc34b28e8e
--- /dev/null
+++ b/mail/qmail-auditor/distinfo
@@ -0,0 +1,3 @@
+MD5 (qmail-auditor-0.47.tar.gz) = 8da4a8408bb26c6d77f58ee5230f8b06
+SHA256 (qmail-auditor-0.47.tar.gz) = 8736c388bfc33277808aeddd6f37e173e9002ac65b314e4490fe99b28b2a9c46
+SIZE (qmail-auditor-0.47.tar.gz) = 220609
diff --git a/mail/qmail-auditor/files/pkg-message.in b/mail/qmail-auditor/files/pkg-message.in
new file mode 100644
index 000000000000..9a92e7a62529
--- /dev/null
+++ b/mail/qmail-auditor/files/pkg-message.in
@@ -0,0 +1,28 @@
+You have just installed %%PREFIX%%/bin/qmail-auditor
+which can be enabled by wrapping qmail-queue and naming the original qmail-queue
+as qmail-queue-real, for example:
+
+ mv %%QMAIL_PREFIX%%/bin/qmail-queue %%QMAIL_PREFIX%%/bin/qmail-queue-real-auditor
+ ln -s %%PREFIX%%/bin/qmail-auditor %%QMAIL_PREFIX%%/bin/qmail-queue
+
+Now you can configure qmail-auditor, its control file is
+
+ %%QMAIL_PREFIX%%/control/auditor
+
+This file's format must be in the form:
+
+ <field header> <regular expression> <e-mail to forward>
+
+Where
+ <field header> = from|to|all
+ <regular expression> = sender or recipient e-mail address (according
+ to <field header>), re_format(7) compatible
+ <e-mail to forward> = whom qmail-auditor will copy audited messages to
+
+You can have multiple rules (one per line). Working example of control file:
+
+from *@some.domain.br auditing@mycompany.com
+to user@some.domain.br auditing@mycompany.com
+all sales@domain.br salesauditing@mycompany.com
+
+The README file was installed on %%DOCSDIR%%
diff --git a/mail/qmail-auditor/pkg-descr b/mail/qmail-auditor/pkg-descr
new file mode 100644
index 000000000000..d3f7c5371570
--- /dev/null
+++ b/mail/qmail-auditor/pkg-descr
@@ -0,0 +1,7 @@
+This software provides an easy and functional way to audit incoming and
+outgoing e-mails from a qmail server. It works by means of qmail-queue
+wrapping. It has a control file which allows selective auditing of sender or
+recipient, as well as whom the messages should be forwarded to. This control
+file allows regular expressions, what increases its flexibility of use.
+
+WWW: http://qmail-auditor.sourceforge.net/