aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-07-13 00:07:35 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-07-13 00:07:35 +0000
commitfeee6ce9d61c0e3eb1c200e4adbe5dac8b2b887a (patch)
treeabd62ebf5876447e6703d59978de852efd7daca3 /mail
parentdf8230f473a59350229f2e498383a9029cfb1f82 (diff)
downloadports-feee6ce9d61c0e3eb1c200e4adbe5dac8b2b887a.tar.gz
ports-feee6ce9d61c0e3eb1c200e4adbe5dac8b2b887a.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/archiveopteryx-devel/Makefile4
-rw-r--r--mail/archiveopteryx/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/mail/archiveopteryx-devel/Makefile b/mail/archiveopteryx-devel/Makefile
index 04060afb1586..7c51a6b84ba6 100644
--- a/mail/archiveopteryx-devel/Makefile
+++ b/mail/archiveopteryx-devel/Makefile
@@ -19,7 +19,7 @@ GH_ACCOUNT= aox
GH_PROJECT= aox
GH_TAGNAME= 96ab17e
-USES= perl5 ssl
+USES= compiler perl5 ssl
USE_PERL5= build
WITH_PGSQL= client
@@ -44,7 +44,7 @@ OPTIONS_DEFINE= DOCS
# force Clang when on FreeBSD with clang in base
.if ${OPSYS} == FreeBSD
-.if ! ${ARCH:Mmips*} && ! ${ARCH:Mpowerpc*} && ! ${ARCH} == sparc64
+.if ${CHOSEN_COMPILER_TYPE} == clang
JAMARG+= "-sCLANG=1"
.endif
.endif
diff --git a/mail/archiveopteryx/Makefile b/mail/archiveopteryx/Makefile
index 99874103da22..a8fd53d92285 100644
--- a/mail/archiveopteryx/Makefile
+++ b/mail/archiveopteryx/Makefile
@@ -14,7 +14,7 @@ LICENSE= MIT
BUILD_DEPENDS= jam:devel/jam
-USES= perl5 ssl tar:bzip2
+USES= compiler perl5 ssl tar:bzip2
USE_PERL5= build
WITH_PGSQL= client
@@ -38,7 +38,7 @@ OPTIONS_DEFINE= DOCS
# force Clang when on FreeBSD with clang in base
.if ${OPSYS} == FreeBSD
-.if ! ${ARCH:Mmips*} && ! ${ARCH:Mpowerpc*} && ! ${ARCH} == sparc64
+.if ${CHOSEN_COMPILER_TYPE} == clang
JAMARG+= "-sCLANG=1"
.endif
.endif