aboutsummaryrefslogtreecommitdiff
path: root/math/4ti2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-05 00:52:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-05 00:52:37 +0000
commit4e82cc0e6f5702fc4a2cd8bf8e66e6cc1e9cf575 (patch)
tree46f3983bea3c0edb25da692aa2a7a7cc62ce0d17 /math/4ti2
parentbb90d6ab2ec1b23c12071c2e042606ffbfed089a (diff)
downloadports-4e82cc0e6f5702fc4a2cd8bf8e66e6cc1e9cf575.tar.gz
ports-4e82cc0e6f5702fc4a2cd8bf8e66e6cc1e9cf575.zip
New port: math/4ti2: Solve algebraic, geometric, combinatorial problems on linear spaces
Notes
Notes: svn path=/head/; revision=486644
Diffstat (limited to 'math/4ti2')
-rw-r--r--math/4ti2/Makefile25
-rw-r--r--math/4ti2/distinfo3
-rw-r--r--math/4ti2/pkg-descr21
-rw-r--r--math/4ti2/pkg-plist172
4 files changed, 221 insertions, 0 deletions
diff --git a/math/4ti2/Makefile b/math/4ti2/Makefile
new file mode 100644
index 000000000000..a0c115bc1f65
--- /dev/null
+++ b/math/4ti2/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= 4ti2
+DISTVERSIONPREFIX= Release_
+DISTVERSION= 1_6_9
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Solve algebraic, geometric, combinatorial problems on linear spaces
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libglpk.so:math/glpk \
+ libgmp.so:math/gmp
+
+USES= autoreconf gmake libtool
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static --enable-shared --with-glpk=${LOCALBASE} --with-gmp=${LOCALBASE}
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+
+TEST_TARGET= check # tests fail to run: https://github.com/4ti2/4ti2/issues/26
+
+.include <bsd.port.mk>
diff --git a/math/4ti2/distinfo b/math/4ti2/distinfo
new file mode 100644
index 000000000000..af4f22f37cfb
--- /dev/null
+++ b/math/4ti2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1543969170
+SHA256 (4ti2-4ti2-Release_1_6_9_GH0.tar.gz) = 7b1015718102d8cd4dc2de64f69094fdba0bc69a1878ada5960979b171ff89e4
+SIZE (4ti2-4ti2-Release_1_6_9_GH0.tar.gz) = 5000032
diff --git a/math/4ti2/pkg-descr b/math/4ti2/pkg-descr
new file mode 100644
index 000000000000..0ab690fedc15
--- /dev/null
+++ b/math/4ti2/pkg-descr
@@ -0,0 +1,21 @@
+4ti2 is a software package for algebraic, geometric and combinatorial problems
+on linear spaces. It computes
+* the circuits of a cone
+* a problem matrix corresponding to graphical statistical models
+* generators for the symmetry group acting on 4-way tables
+* the Graver basis of a matrix or a given lattice
+* a Groebner basis of the toric ideal of a matrix or, more general, of the
+ lattice ideal of a lattice
+* a Markov basis (generating set) of the toric ideal
+* the minimal solution of an integer linear program or, more general, a lattice
+ program, using a Groebner basis
+* the normal form of a list of feasible points
+* the primitive partition identities, that is, the Graver basis of [1 2 3 ... N]
+* a generator description of a cone
+* the extreme rays of a cone
+* the minimal solution of an integer linear program or, more general, a lattice
+ program using a Groebner basis
+* an integer lattice basis
+* solutions of linear inequality and equation systems over the integers
+
+WWW: https://4ti2.github.io/
diff --git a/math/4ti2/pkg-plist b/math/4ti2/pkg-plist
new file mode 100644
index 000000000000..08f64280b6da
--- /dev/null
+++ b/math/4ti2/pkg-plist
@@ -0,0 +1,172 @@
+bin/4ti2gmp
+bin/4ti2int32
+bin/4ti2int64
+bin/circuits
+bin/genmodel
+bin/gensymm
+bin/graver
+bin/groebner
+bin/hilbert
+bin/markov
+bin/minimize
+bin/normalform
+bin/output
+bin/ppi
+bin/qsolve
+bin/rays
+bin/walk
+bin/zbasis
+bin/zsolve
+include/4ti2/4ti2.h
+include/4ti2/4ti2_config.h
+include/4ti2/4ti2xx.h
+include/groebner/Algorithm.h
+include/groebner/BasicCompletion.h
+include/groebner/BasicGeneration.h
+include/groebner/BasicOptions.h
+include/groebner/BasicReduction.h
+include/groebner/Binomial.h
+include/groebner/BinomialArray.h
+include/groebner/BinomialArrayStream.h
+include/groebner/BinomialCollection.h
+include/groebner/BinomialFactory.h
+include/groebner/BinomialSet.h
+include/groebner/BinomialSetStream.h
+include/groebner/BinomialStream.h
+include/groebner/BitSet.h
+include/groebner/BitSetStream.h
+include/groebner/Bounded.h
+include/groebner/CircuitImplementation.h
+include/groebner/CircuitImplementation.tpp
+include/groebner/CircuitMatrixAlgorithm.h
+include/groebner/CircuitMatrixAlgorithm.tpp
+include/groebner/CircuitOptions.h
+include/groebner/CircuitSupportAlgorithm.h
+include/groebner/CircuitSupportAlgorithm.tpp
+include/groebner/CircuitsAPI.h
+include/groebner/Completion.h
+include/groebner/DataType.h
+include/groebner/Debug.h
+include/groebner/DiagonalAlgorithm.h
+include/groebner/DiagonalAlgorithm.tpp
+include/groebner/EliminateAlgorithm.h
+include/groebner/Euclidean.h
+include/groebner/Extract.h
+include/groebner/Feasible.h
+include/groebner/FeasibleStream.h
+include/groebner/Filter.h
+include/groebner/FilterReduction.h
+include/groebner/FlipCompletion.h
+include/groebner/GeneratingSet.h
+include/groebner/Generation.h
+include/groebner/Globals.h
+include/groebner/Grading.h
+include/groebner/GroebnerBasis.h
+include/groebner/HermiteAlgorithm.h
+include/groebner/HermiteAlgorithm.tpp
+include/groebner/HybridGenSet.h
+include/groebner/Index.h
+include/groebner/IndexBinomialSet.h
+include/groebner/IndexSetConverter.h
+include/groebner/LatticeBasis.h
+include/groebner/LongDenseIndexSet.h
+include/groebner/LongDenseIndexSetStream.h
+include/groebner/Markov.h
+include/groebner/MaxMinGenSet.h
+include/groebner/Minimize.h
+include/groebner/MinimizeOptions.h
+include/groebner/OnesReduction.h
+include/groebner/OnesTree.h
+include/groebner/OnesTree.tpp
+include/groebner/Optimise.h
+include/groebner/Options.h
+include/groebner/OrderedCompletion.h
+include/groebner/Permutation.h
+include/groebner/ProjectLiftGenSet.h
+include/groebner/QSolveAPI.h
+include/groebner/QSolveAlgorithm.h
+include/groebner/QSolveConsOrder.h
+include/groebner/QSolveVariant.h
+include/groebner/RayAlgorithm.h
+include/groebner/RayImplementation.h
+include/groebner/RayImplementation.tpp
+include/groebner/RayMatrixAlgorithm.h
+include/groebner/RayMatrixAlgorithm.tpp
+include/groebner/RaySupportAlgorithm.h
+include/groebner/RaySupportAlgorithm.tpp
+include/groebner/RaysAPI.h
+include/groebner/Reduction.h
+include/groebner/SaturationGenSet.h
+include/groebner/ShortDenseIndexSet.h
+include/groebner/ShortDenseIndexSetStream.h
+include/groebner/SignPattern.h
+include/groebner/Size.h
+include/groebner/Statistics.h
+include/groebner/SupportTree.h
+include/groebner/SupportTree.tpp
+include/groebner/SyzygyCompletion.h
+include/groebner/SyzygyGeneration.h
+include/groebner/TermOrder.h
+include/groebner/Timer.h
+include/groebner/Truncate.h
+include/groebner/Vector.h
+include/groebner/VectorArray.h
+include/groebner/VectorArrayAPI.h
+include/groebner/VectorArrayStream.h
+include/groebner/VectorStream.h
+include/groebner/WalkAlgorithm.h
+include/groebner/WalkOptions.h
+include/groebner/Weight.h
+include/groebner/WeightAlgorithm.h
+include/groebner/WeightedBinomialSet.h
+include/groebner/WeightedReduction.h
+include/util/genmodel.h
+include/util/gensymm.h
+include/util/myheader.h
+include/util/orbit.h
+include/util/output.h
+include/util/print.h
+include/util/vector.h
+include/zsolve/Algorithm.hpp
+include/zsolve/BitSet.h
+include/zsolve/BoundAPI.hpp
+include/zsolve/Controller.hpp
+include/zsolve/DefaultController.hpp
+include/zsolve/Exception.h
+include/zsolve/GraverAPI.hpp
+include/zsolve/Heuristics.hpp
+include/zsolve/HilbertAPI.hpp
+include/zsolve/Integer.h
+include/zsolve/Lattice.hpp
+include/zsolve/LinearSystem.hpp
+include/zsolve/Norms.hpp
+include/zsolve/Options.h
+include/zsolve/RelAPI.h
+include/zsolve/Relation.hpp
+include/zsolve/SignAPI.h
+include/zsolve/Timer.h
+include/zsolve/Variables.hpp
+include/zsolve/Vector.hpp
+include/zsolve/VectorArray.hpp
+include/zsolve/VectorArrayAPI.hpp
+include/zsolve/ZSolveAPI.hpp
+include/zsolve/zsolve.h
+lib/lib4ti2common.so
+lib/lib4ti2common.so.0
+lib/lib4ti2common.so.0.0.0
+lib/lib4ti2gmp.so
+lib/lib4ti2gmp.so.0
+lib/lib4ti2gmp.so.0.0.0
+lib/lib4ti2int32.so
+lib/lib4ti2int32.so.0
+lib/lib4ti2int32.so.0.0.0
+lib/lib4ti2int64.so
+lib/lib4ti2int64.so.0
+lib/lib4ti2int64.so.0.0.0
+lib/lib4ti2util.so
+lib/lib4ti2util.so.0
+lib/lib4ti2util.so.0.0.0
+lib/libzsolve.so
+lib/libzsolve.so.0
+lib/libzsolve.so.0.0.0
+%%DATADIR%%/doc/4ti2_manual.pdf