aboutsummaryrefslogtreecommitdiff
path: root/math/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-12-07 14:41:50 +0000
committerWen Heping <wen@FreeBSD.org>2009-12-07 14:41:50 +0000
commit2956f23b0948d4c88631551740eebf6abc8e22fa (patch)
treeaf9b21bff65c7521b866c8dd4e546ad52492a157 /math/Makefile
parent5ff2b98adedbfc317dceb3a765d3f3a9a80bfd2c (diff)
downloadports-2956f23b0948d4c88631551740eebf6abc8e22fa.tar.gz
ports-2956f23b0948d4c88631551740eebf6abc8e22fa.zip
As with other Pseudo-Random Number Generator (PRNG) algorithms like the
Mersenne Twister (see Math::Random::MT), this algorithm is designed to take some seed information and produce seemingly random results as output. However, ISAAC (Indirection, Shift, Accumulate, Add, and Count) has different goals than these commonly used algorithms. In particular, it's really fast - on average, it requires only 18.75 machine cycles to generate a 32-bit value. This makes it suitable for applications where a significant amount of random data needs to be produced quickly, such solving using the Monte Carlo method or for games. WWW: http://search.cpan.org/dist/Math-Random-ISAAC-XS/
Notes
Notes: svn path=/head/; revision=245340
Diffstat (limited to 'math/Makefile')
-rw-r--r--math/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 4f01b40143c5..be4c6ae2854e 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -330,6 +330,7 @@
SUBDIR += p5-Math-Polynomial-Solve
SUBDIR += p5-Math-Random
SUBDIR += p5-Math-Random-ISAAC
+ SUBDIR += p5-Math-Random-ISAAC-XS
SUBDIR += p5-Math-Random-MT
SUBDIR += p5-Math-Random-MT-Auto
SUBDIR += p5-Math-Random-OO