aboutsummaryrefslogtreecommitdiff
path: root/math/PDL
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-05 03:26:52 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-05 03:26:52 +0000
commit52573d4e578e2e0bae9500f401ef3872ec0c7de4 (patch)
tree3c45db9b9cd11f107435d0b0e37f8fe83145fa16 /math/PDL
parentbfa56b3a7e66ab03e273d57f2ce285c0b7d0be9a (diff)
downloadports-52573d4e578e2e0bae9500f401ef3872ec0c7de4.tar.gz
ports-52573d4e578e2e0bae9500f401ef3872ec0c7de4.zip
- Re-enable OPTIONS GL
- Bump PORTREVISION for dependency change Feature safe: yes
Notes
Notes: svn path=/head/; revision=286898
Diffstat (limited to 'math/PDL')
-rw-r--r--math/PDL/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index 3d6975ae3fb5..603678666b0f 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -7,6 +7,7 @@
PORTNAME= PDL
PORTVERSION= 2.4.9
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= CPAN/${PORTNAME}:cpan \
SF/pdl/PDL/${PORTVERSION}:sf
@@ -33,6 +34,7 @@ MAKE_JOBS_UNSAFE= yes
OPTIONS= PGPLOT "Enable PDL::Graphics::PGPLOT" on \
PLPLOT "Enable PDL::Graphics::PLplot" off \
+ GL "Enable PDL::Graphics::TriD and OpenGL" on \
GD "Enable PDL::IO::GD" off \
FFTW "Enable PDL::FFTW" on \
GSL "Enable PDL::GSL interface" off \
@@ -41,8 +43,6 @@ OPTIONS= PGPLOT "Enable PDL::Graphics::PGPLOT" on \
F77 "Enable PDL::Minuit and PDL::Slatec" on \
READLINE "Use GNU readline" off \
SINK "Include PDL kitchen sink" off
-# Please uncomment this option after updating graphics/p5-OpenGL to 0.60+
-# GL "Enable PDL::Graphics::TriD and OpenGL" on
.include <bsd.port.options.mk>
@@ -54,11 +54,11 @@ BUILD_DEPENDS+= p5-PGPLOT>=0:${PORTSDIR}/graphics/p5-PGPLOT
LIB_DEPENDS+= plplotd.11:${PORTSDIR}/math/plplot
.endif
-#.if defined(WITH_GL)
-#BUILD_DEPENDS+= p5-OpenGL>=0.60:${PORTSDIR}/graphics/p5-OpenGL
-#RUN_DEPENDS+= p5-OpenGL>=0.60:${PORTSDIR}/graphics/p5-OpenGL
-#USE_GL= yes
-#.endif
+.if defined(WITH_GL)
+BUILD_DEPENDS+= p5-OpenGL>=0.60:${PORTSDIR}/graphics/p5-OpenGL
+RUN_DEPENDS+= p5-OpenGL>=0.60:${PORTSDIR}/graphics/p5-OpenGL
+USE_GL= yes
+.endif
.if defined(WITH_GD)
LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd