aboutsummaryrefslogtreecommitdiff
path: root/math/R-cran-sf
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2017-06-27 08:03:09 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2017-06-27 08:03:09 +0000
commita9321e1c513935e6c04b0d2a5fd7d57ad9464a40 (patch)
tree79d433b350f16a1a0341d9db6f4897f37693ea03 /math/R-cran-sf
parent6360c03ea23f6d76f8c2ca8752c00932e8d9a299 (diff)
downloadports-a9321e1c513935e6c04b0d2a5fd7d57ad9464a40.tar.gz
ports-a9321e1c513935e6c04b0d2a5fd7d57ad9464a40.zip
Notes
Diffstat (limited to 'math/R-cran-sf')
-rw-r--r--math/R-cran-sf/Makefile26
-rw-r--r--math/R-cran-sf/distinfo3
-rw-r--r--math/R-cran-sf/pkg-descr6
3 files changed, 35 insertions, 0 deletions
diff --git a/math/R-cran-sf/Makefile b/math/R-cran-sf/Makefile
new file mode 100644
index 000000000000..887c7aa61d47
--- /dev/null
+++ b/math/R-cran-sf/Makefile
@@ -0,0 +1,26 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sf
+DISTVERSION= 0.5-1
+CATEGORIES= math
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Simple Features for R
+
+LICENSE= GPLv2
+
+CRAN_DEPENDS= R-cran-Rcpp>0:devel/R-cran-Rcpp \
+ R-cran-DBI>0:databases/R-cran-DBI \
+ R-cran-units>=0.4:math/R-cran-units \
+ R-cran-magrittr>0:devel/R-cran-magrittr
+LIB_DEPENDS= libgdal.so:graphics/gdal \
+ libgeos.so:graphics/geos \
+ libproj.so:graphics/proj
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+
+USES= cran:auto-plist,compiles
+
+.include <bsd.port.mk>
diff --git a/math/R-cran-sf/distinfo b/math/R-cran-sf/distinfo
new file mode 100644
index 000000000000..e94ae776bc2d
--- /dev/null
+++ b/math/R-cran-sf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1498443880
+SHA256 (sf_0.5-1.tar.gz) = af7fc4046c999c37e607eeaf3cd386ed58f006e2da64bfa355b15f302f52e7fb
+SIZE (sf_0.5-1.tar.gz) = 4073881
diff --git a/math/R-cran-sf/pkg-descr b/math/R-cran-sf/pkg-descr
new file mode 100644
index 000000000000..533b13bc2b89
--- /dev/null
+++ b/math/R-cran-sf/pkg-descr
@@ -0,0 +1,6 @@
+Support for simple features, a standardized way to encode spatial
+vector data. Binds to GDAL for reading and writing data, to GEOS
+for geometrical operations, and to Proj.4 for projection conversions
+and datum transformations.
+
+WWW: https://cran.r-project.org/web/packages/sf/