aboutsummaryrefslogtreecommitdiff
path: root/math/R-cran-sm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-22 13:32:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-22 13:32:38 +0000
commit964a7f8b5e829e381beec0863e044ada7bb22d15 (patch)
tree178bc5e1acefe3791a801fe154713579e89a8334 /math/R-cran-sm
parent630850335bbcf7c011a7c9a65f7cd7d274aaf3ae (diff)
downloadports-964a7f8b5e829e381beec0863e044ada7bb22d15.tar.gz
ports-964a7f8b5e829e381beec0863e044ada7bb22d15.zip
Notes
Diffstat (limited to 'math/R-cran-sm')
-rw-r--r--math/R-cran-sm/Makefile20
-rw-r--r--math/R-cran-sm/distinfo3
-rw-r--r--math/R-cran-sm/files/bsd.cran.mk28
-rw-r--r--math/R-cran-sm/pkg-descr6
-rw-r--r--math/R-cran-sm/pkg-plist300
5 files changed, 357 insertions, 0 deletions
diff --git a/math/R-cran-sm/Makefile b/math/R-cran-sm/Makefile
new file mode 100644
index 000000000000..fdee06807092
--- /dev/null
+++ b/math/R-cran-sm/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: sm
+# Date created: 2009-03-19
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sm
+PORTVERSION= 2.2.3
+CATEGORIES= math
+PKGNAMEPREFIX= R-cran-
+DISTNAME= ${PORTNAME}_2.2-3
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Smoothing methods for nonparametric regression and density estimation
+
+R_MOD= yes
+
+.include "${.CURDIR}/files/bsd.cran.mk"
+.include <bsd.port.mk>
diff --git a/math/R-cran-sm/distinfo b/math/R-cran-sm/distinfo
new file mode 100644
index 000000000000..d87da4126f5a
--- /dev/null
+++ b/math/R-cran-sm/distinfo
@@ -0,0 +1,3 @@
+MD5 (sm_2.2-3.tar.gz) = 181687ad2e2ba0f07b8d237addcd6aa3
+SHA256 (sm_2.2-3.tar.gz) = 422d41c4b7fbd927e2d88764d778cf36bc753d11c2787a3b79522009bafc258c
+SIZE (sm_2.2-3.tar.gz) = 152308
diff --git a/math/R-cran-sm/files/bsd.cran.mk b/math/R-cran-sm/files/bsd.cran.mk
new file mode 100644
index 000000000000..753ccdbfe5e8
--- /dev/null
+++ b/math/R-cran-sm/files/bsd.cran.mk
@@ -0,0 +1,28 @@
+# Date created: 2009-01-25
+# Whom: Wen Heping <wenheping@gmail.com>
+
+.if defined(R_MOD)
+MASTER_CRAN_SITES+= http://mirrors.geoexpat.com/cran/src/contrib/ \
+ http://cran.rakanu.com/src/contrib/ \
+ http://cran.cnr.berkeley.edu/src/contrib/
+.endif
+
+MASTER_SITES?= ${MASTER_CRAN_SITES}
+
+.if defined(R_MOD)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/R:${PORTSDIR}/math/R
+RUN_DEPENDS+= ${LOCALBASE}/bin/R:${PORTSDIR}/math/R
+.endif
+
+R_MOD_DIR?= lib/R/library/${PORTNAME}
+PLIST_SUB+= R_MOD_DIR=${R_MOD_DIR}
+
+NO_BUILD= yes
+R_COMMAND= ${LOCALBASE}/bin/R
+R_INS= ${R_COMMAND} CMD INSTALL
+
+do-install:
+.if defined(R_MOD)
+ @cd ${WRKDIR} && ${R_INS} ${PORTNAME}
+.endif
+
diff --git a/math/R-cran-sm/pkg-descr b/math/R-cran-sm/pkg-descr
new file mode 100644
index 000000000000..384762f5469b
--- /dev/null
+++ b/math/R-cran-sm/pkg-descr
@@ -0,0 +1,6 @@
+R-cran-sm is a R module for smoothing methods for nonparametric
+regression and density estimation. It is software linked to the
+book 'Applied Smoothing Techniques for Data Analysis: The Kernel
+Approach with S-Plus Illustrations' Oxford University Press.
+
+WWW: http://www.stats.gla.ac.uk/~adrian/sm
diff --git a/math/R-cran-sm/pkg-plist b/math/R-cran-sm/pkg-plist
new file mode 100644
index 000000000000..ea9d65f401cd
--- /dev/null
+++ b/math/R-cran-sm/pkg-plist
@@ -0,0 +1,300 @@
+%%R_MOD_DIR%%/CITATION
+%%R_MOD_DIR%%/CONTENTS
+%%R_MOD_DIR%%/COPYING
+%%R_MOD_DIR%%/DESCRIPTION
+%%R_MOD_DIR%%/INDEX
+%%R_MOD_DIR%%/Meta/Rd.rds
+%%R_MOD_DIR%%/Meta/data.rds
+%%R_MOD_DIR%%/Meta/hsearch.rds
+%%R_MOD_DIR%%/Meta/nsInfo.rds
+%%R_MOD_DIR%%/Meta/package.rds
+%%R_MOD_DIR%%/NAMESPACE
+%%R_MOD_DIR%%/R/sm
+%%R_MOD_DIR%%/R/sm.rdb
+%%R_MOD_DIR%%/R/sm.rdx
+%%R_MOD_DIR%%/R-ex/binning.R
+%%R_MOD_DIR%%/R-ex/h.select.R
+%%R_MOD_DIR%%/R-ex/hcv.R
+%%R_MOD_DIR%%/R-ex/hnorm.R
+%%R_MOD_DIR%%/R-ex/hsj.R
+%%R_MOD_DIR%%/R-ex/nise.R
+%%R_MOD_DIR%%/R-ex/nmise.R
+%%R_MOD_DIR%%/R-ex/nnbr.R
+%%R_MOD_DIR%%/R-ex/provide.data.R
+%%R_MOD_DIR%%/R-ex/sig.trace.R
+%%R_MOD_DIR%%/R-ex/sm.ancova.R
+%%R_MOD_DIR%%/R-ex/sm.autoregression.R
+%%R_MOD_DIR%%/R-ex/sm.binomial.R
+%%R_MOD_DIR%%/R-ex/sm.binomial.bootstrap.R
+%%R_MOD_DIR%%/R-ex/sm.density.R
+%%R_MOD_DIR%%/R-ex/sm.density.compare.R
+%%R_MOD_DIR%%/R-ex/sm.discontinuity.R
+%%R_MOD_DIR%%/R-ex/sm.monotonicity.R
+%%R_MOD_DIR%%/R-ex/sm.options.R
+%%R_MOD_DIR%%/R-ex/sm.poisson.R
+%%R_MOD_DIR%%/R-ex/sm.poisson.bootstrap.R
+%%R_MOD_DIR%%/R-ex/sm.regression.R
+%%R_MOD_DIR%%/R-ex/sm.rm.R
+%%R_MOD_DIR%%/R-ex/sm.script.R
+%%R_MOD_DIR%%/R-ex/sm.sigma.R
+%%R_MOD_DIR%%/R-ex/sm.sigma2.compare.R
+%%R_MOD_DIR%%/R-ex/sm.sphere.R
+%%R_MOD_DIR%%/R-ex/sm.surface3d.R
+%%R_MOD_DIR%%/R-ex/sm.survival.R
+%%R_MOD_DIR%%/R-ex/sm.ts.pdf.R
+%%R_MOD_DIR%%/R-ex/sm.variogram.R
+%%R_MOD_DIR%%/data/geyser.tab
+%%R_MOD_DIR%%/help/AnIndex
+%%R_MOD_DIR%%/help/binning
+%%R_MOD_DIR%%/help/geyser
+%%R_MOD_DIR%%/help/h.select
+%%R_MOD_DIR%%/help/hcv
+%%R_MOD_DIR%%/help/hnorm
+%%R_MOD_DIR%%/help/hsj
+%%R_MOD_DIR%%/help/nise
+%%R_MOD_DIR%%/help/nmise
+%%R_MOD_DIR%%/help/nnbr
+%%R_MOD_DIR%%/help/pause
+%%R_MOD_DIR%%/help/provide.data
+%%R_MOD_DIR%%/help/sig.trace
+%%R_MOD_DIR%%/help/sm
+%%R_MOD_DIR%%/help/sm-internal
+%%R_MOD_DIR%%/help/sm.ancova
+%%R_MOD_DIR%%/help/sm.autoregression
+%%R_MOD_DIR%%/help/sm.binomial
+%%R_MOD_DIR%%/help/sm.binomial.bootstrap
+%%R_MOD_DIR%%/help/sm.density
+%%R_MOD_DIR%%/help/sm.density.compare
+%%R_MOD_DIR%%/help/sm.discontinuity
+%%R_MOD_DIR%%/help/sm.monotonicity
+%%R_MOD_DIR%%/help/sm.options
+%%R_MOD_DIR%%/help/sm.poisson
+%%R_MOD_DIR%%/help/sm.poisson.bootstrap
+%%R_MOD_DIR%%/help/sm.regression
+%%R_MOD_DIR%%/help/sm.regression.autocor
+%%R_MOD_DIR%%/help/sm.rm
+%%R_MOD_DIR%%/help/sm.script
+%%R_MOD_DIR%%/help/sm.sigma
+%%R_MOD_DIR%%/help/sm.sigma2.compare
+%%R_MOD_DIR%%/help/sm.sphere
+%%R_MOD_DIR%%/help/sm.surface3d
+%%R_MOD_DIR%%/help/sm.survival
+%%R_MOD_DIR%%/help/sm.ts.pdf
+%%R_MOD_DIR%%/help/sm.variogram
+%%R_MOD_DIR%%/history.txt
+%%R_MOD_DIR%%/html/00Index.html
+%%R_MOD_DIR%%/html/binning.html
+%%R_MOD_DIR%%/html/geyser.html
+%%R_MOD_DIR%%/html/h.select.html
+%%R_MOD_DIR%%/html/hcv.html
+%%R_MOD_DIR%%/html/hnorm.html
+%%R_MOD_DIR%%/html/hsj.html
+%%R_MOD_DIR%%/html/nise.html
+%%R_MOD_DIR%%/html/nmise.html
+%%R_MOD_DIR%%/html/nnbr.html
+%%R_MOD_DIR%%/html/pause.html
+%%R_MOD_DIR%%/html/provide.data.html
+%%R_MOD_DIR%%/html/sig.trace.html
+%%R_MOD_DIR%%/html/sm-internal.html
+%%R_MOD_DIR%%/html/sm.ancova.html
+%%R_MOD_DIR%%/html/sm.autoregression.html
+%%R_MOD_DIR%%/html/sm.binomial.bootstrap.html
+%%R_MOD_DIR%%/html/sm.binomial.html
+%%R_MOD_DIR%%/html/sm.density.compare.html
+%%R_MOD_DIR%%/html/sm.density.html
+%%R_MOD_DIR%%/html/sm.discontinuity.html
+%%R_MOD_DIR%%/html/sm.html
+%%R_MOD_DIR%%/html/sm.monotonicity.html
+%%R_MOD_DIR%%/html/sm.options.html
+%%R_MOD_DIR%%/html/sm.poisson.bootstrap.html
+%%R_MOD_DIR%%/html/sm.poisson.html
+%%R_MOD_DIR%%/html/sm.regression.autocor.html
+%%R_MOD_DIR%%/html/sm.regression.html
+%%R_MOD_DIR%%/html/sm.rm.html
+%%R_MOD_DIR%%/html/sm.script.html
+%%R_MOD_DIR%%/html/sm.sigma.html
+%%R_MOD_DIR%%/html/sm.sigma2.compare.html
+%%R_MOD_DIR%%/html/sm.sphere.html
+%%R_MOD_DIR%%/html/sm.surface3d.html
+%%R_MOD_DIR%%/html/sm.survival.html
+%%R_MOD_DIR%%/html/sm.ts.pdf.html
+%%R_MOD_DIR%%/html/sm.variogram.html
+%%R_MOD_DIR%%/latex/binning.tex
+%%R_MOD_DIR%%/latex/geyser.tex
+%%R_MOD_DIR%%/latex/h.select.tex
+%%R_MOD_DIR%%/latex/hcv.tex
+%%R_MOD_DIR%%/latex/hnorm.tex
+%%R_MOD_DIR%%/latex/hsj.tex
+%%R_MOD_DIR%%/latex/nise.tex
+%%R_MOD_DIR%%/latex/nmise.tex
+%%R_MOD_DIR%%/latex/nnbr.tex
+%%R_MOD_DIR%%/latex/pause.tex
+%%R_MOD_DIR%%/latex/provide.data.tex
+%%R_MOD_DIR%%/latex/sig.trace.tex
+%%R_MOD_DIR%%/latex/sm-internal.tex
+%%R_MOD_DIR%%/latex/sm.ancova.tex
+%%R_MOD_DIR%%/latex/sm.autoregression.tex
+%%R_MOD_DIR%%/latex/sm.binomial.bootstrap.tex
+%%R_MOD_DIR%%/latex/sm.binomial.tex
+%%R_MOD_DIR%%/latex/sm.density.compare.tex
+%%R_MOD_DIR%%/latex/sm.density.tex
+%%R_MOD_DIR%%/latex/sm.discontinuity.tex
+%%R_MOD_DIR%%/latex/sm.monotonicity.tex
+%%R_MOD_DIR%%/latex/sm.options.tex
+%%R_MOD_DIR%%/latex/sm.poisson.bootstrap.tex
+%%R_MOD_DIR%%/latex/sm.poisson.tex
+%%R_MOD_DIR%%/latex/sm.regression.autocor.tex
+%%R_MOD_DIR%%/latex/sm.regression.tex
+%%R_MOD_DIR%%/latex/sm.rm.tex
+%%R_MOD_DIR%%/latex/sm.script.tex
+%%R_MOD_DIR%%/latex/sm.sigma.tex
+%%R_MOD_DIR%%/latex/sm.sigma2.compare.tex
+%%R_MOD_DIR%%/latex/sm.sphere.tex
+%%R_MOD_DIR%%/latex/sm.surface3d.tex
+%%R_MOD_DIR%%/latex/sm.survival.tex
+%%R_MOD_DIR%%/latex/sm.tex
+%%R_MOD_DIR%%/latex/sm.ts.pdf.tex
+%%R_MOD_DIR%%/latex/sm.variogram.tex
+%%R_MOD_DIR%%/man/sm.Rd.gz
+%%R_MOD_DIR%%/scripts/air_band.q
+%%R_MOD_DIR%%/scripts/air_boot.q
+%%R_MOD_DIR%%/scripts/air_cont.q
+%%R_MOD_DIR%%/scripts/air_dens.q
+%%R_MOD_DIR%%/scripts/air_hcv.q
+%%R_MOD_DIR%%/scripts/air_imag.q
+%%R_MOD_DIR%%/scripts/air_ind.q
+%%R_MOD_DIR%%/scripts/air_inds.q
+%%R_MOD_DIR%%/scripts/air_scat.q
+%%R_MOD_DIR%%/scripts/bin_use.q
+%%R_MOD_DIR%%/scripts/birth1.q
+%%R_MOD_DIR%%/scripts/birth2.q
+%%R_MOD_DIR%%/scripts/bissell1.q
+%%R_MOD_DIR%%/scripts/bissell2.q
+%%R_MOD_DIR%%/scripts/bissell3.q
+%%R_MOD_DIR%%/scripts/citrate.q
+%%R_MOD_DIR%%/scripts/dogs.q
+%%R_MOD_DIR%%/scripts/edfgrad.q
+%%R_MOD_DIR%%/scripts/follicle.q
+%%R_MOD_DIR%%/scripts/geys3d.q
+%%R_MOD_DIR%%/scripts/geys_ts.q
+%%R_MOD_DIR%%/scripts/index.doc
+%%R_MOD_DIR%%/scripts/lc_comp.q
+%%R_MOD_DIR%%/scripts/lc_dens.q
+%%R_MOD_DIR%%/scripts/lc_rr.q
+%%R_MOD_DIR%%/scripts/lynx.q
+%%R_MOD_DIR%%/scripts/mackgam.q
+%%R_MOD_DIR%%/scripts/mackmap.q
+%%R_MOD_DIR%%/scripts/mackplot.q
+%%R_MOD_DIR%%/scripts/mag_dens.q
+%%R_MOD_DIR%%/scripts/mag_scat.q
+%%R_MOD_DIR%%/scripts/mildew.q
+%%R_MOD_DIR%%/scripts/muscle.q
+%%R_MOD_DIR%%/scripts/noeff.q
+%%R_MOD_DIR%%/scripts/nyc.q
+%%R_MOD_DIR%%/scripts/onionbnd.q
+%%R_MOD_DIR%%/scripts/onionplt.q
+%%R_MOD_DIR%%/scripts/rc_alter.q
+%%R_MOD_DIR%%/scripts/rc_boot.q
+%%R_MOD_DIR%%/scripts/rc_plot.q
+%%R_MOD_DIR%%/scripts/rc_vband.q
+%%R_MOD_DIR%%/scripts/sin_cv.q
+%%R_MOD_DIR%%/scripts/sin_prop.q
+%%R_MOD_DIR%%/scripts/smackgam.q
+%%R_MOD_DIR%%/scripts/smackplt.q
+%%R_MOD_DIR%%/scripts/sp_alter.q
+%%R_MOD_DIR%%/scripts/sp_build.q
+%%R_MOD_DIR%%/scripts/sp_comp.q
+%%R_MOD_DIR%%/scripts/sp_comp2.q
+%%R_MOD_DIR%%/scripts/sp_hist.q
+%%R_MOD_DIR%%/scripts/sp_test1.q
+%%R_MOD_DIR%%/scripts/sp_test2.q
+%%R_MOD_DIR%%/scripts/speed.q
+%%R_MOD_DIR%%/scripts/speedvar.q
+%%R_MOD_DIR%%/scripts/stananim.q
+%%R_MOD_DIR%%/scripts/stanplot.q
+%%R_MOD_DIR%%/scripts/te_band.q
+%%R_MOD_DIR%%/scripts/te_hcvsj.q
+%%R_MOD_DIR%%/scripts/te_norm.q
+%%R_MOD_DIR%%/scripts/te_var.q
+%%R_MOD_DIR%%/scripts/trees.q
+%%R_MOD_DIR%%/scripts/trout1.q
+%%R_MOD_DIR%%/scripts/trout2.q
+%%R_MOD_DIR%%/scripts/trw_lf.q
+%%R_MOD_DIR%%/scripts/trw_lfsg.q
+%%R_MOD_DIR%%/scripts/trw_nebd.q
+%%R_MOD_DIR%%/scripts/trw_nesg.q
+%%R_MOD_DIR%%/scripts/trwlband.q
+%%R_MOD_DIR%%/scripts/trwlboot.q
+%%R_MOD_DIR%%/scripts/trwlcmp2.q
+%%R_MOD_DIR%%/scripts/trwlcomp.q
+%%R_MOD_DIR%%/scripts/trwlgam1.q
+%%R_MOD_DIR%%/scripts/trwlgam2.q
+%%R_MOD_DIR%%/scripts/trwlgam3.q
+%%R_MOD_DIR%%/scripts/trwlplot.q
+%%R_MOD_DIR%%/scripts/wormcomp.q
+%%R_MOD_DIR%%/smdata/aircraft.dat
+%%R_MOD_DIR%%/smdata/aircraft.doc
+%%R_MOD_DIR%%/smdata/airpc.dat
+%%R_MOD_DIR%%/smdata/airpc.doc
+%%R_MOD_DIR%%/smdata/birth.dat
+%%R_MOD_DIR%%/smdata/birth.doc
+%%R_MOD_DIR%%/smdata/bissell.dat
+%%R_MOD_DIR%%/smdata/bissell.doc
+%%R_MOD_DIR%%/smdata/bonions.dat
+%%R_MOD_DIR%%/smdata/bonions.doc
+%%R_MOD_DIR%%/smdata/britpts.dat
+%%R_MOD_DIR%%/smdata/citrate.dat
+%%R_MOD_DIR%%/smdata/citrate.doc
+%%R_MOD_DIR%%/smdata/coalash.dat
+%%R_MOD_DIR%%/smdata/coalash.doc
+%%R_MOD_DIR%%/smdata/dogs.dat
+%%R_MOD_DIR%%/smdata/dogs.doc
+%%R_MOD_DIR%%/smdata/follicle.dat
+%%R_MOD_DIR%%/smdata/follicle.doc
+%%R_MOD_DIR%%/smdata/geys3d.dat
+%%R_MOD_DIR%%/smdata/geys3d.doc
+%%R_MOD_DIR%%/smdata/lcancer.dat
+%%R_MOD_DIR%%/smdata/lcancer.doc
+%%R_MOD_DIR%%/smdata/mackerel.dat
+%%R_MOD_DIR%%/smdata/mackerel.doc
+%%R_MOD_DIR%%/smdata/magrem.dat
+%%R_MOD_DIR%%/smdata/magrem.doc
+%%R_MOD_DIR%%/smdata/mildew.dat
+%%R_MOD_DIR%%/smdata/mildew.doc
+%%R_MOD_DIR%%/smdata/muscle.dat
+%%R_MOD_DIR%%/smdata/muscle.doc
+%%R_MOD_DIR%%/smdata/nile.dat
+%%R_MOD_DIR%%/smdata/nile.doc
+%%R_MOD_DIR%%/smdata/phosphat.doc
+%%R_MOD_DIR%%/smdata/poles.dat
+%%R_MOD_DIR%%/smdata/poles.doc
+%%R_MOD_DIR%%/smdata/propsim.dat
+%%R_MOD_DIR%%/smdata/radioc.dat
+%%R_MOD_DIR%%/smdata/radioc.doc
+%%R_MOD_DIR%%/smdata/smacker.dat
+%%R_MOD_DIR%%/smdata/smacker.doc
+%%R_MOD_DIR%%/smdata/stanford.dat
+%%R_MOD_DIR%%/smdata/stanford.doc
+%%R_MOD_DIR%%/smdata/tephra.dat
+%%R_MOD_DIR%%/smdata/tephra.doc
+%%R_MOD_DIR%%/smdata/trawl.dat
+%%R_MOD_DIR%%/smdata/trawl.doc
+%%R_MOD_DIR%%/smdata/trees.dat
+%%R_MOD_DIR%%/smdata/trees.doc
+%%R_MOD_DIR%%/smdata/trout.dat
+%%R_MOD_DIR%%/smdata/trout.doc
+%%R_MOD_DIR%%/smdata/wonions.dat
+%%R_MOD_DIR%%/smdata/wonions.doc
+%%R_MOD_DIR%%/smdata/worm.dat
+%%R_MOD_DIR%%/smdata/worm.doc
+@dirrm %%R_MOD_DIR%%/Meta
+@dirrm %%R_MOD_DIR%%/R
+@dirrm %%R_MOD_DIR%%/R-ex
+@dirrm %%R_MOD_DIR%%/data
+@dirrm %%R_MOD_DIR%%/help
+@dirrm %%R_MOD_DIR%%/html
+@dirrm %%R_MOD_DIR%%/latex
+@dirrm %%R_MOD_DIR%%/man
+@dirrm %%R_MOD_DIR%%/scripts
+@dirrm %%R_MOD_DIR%%/smdata
+@dirrm %%R_MOD_DIR%%