aboutsummaryrefslogtreecommitdiff
path: root/math/aamath
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2009-03-31 11:08:44 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2009-03-31 11:08:44 +0000
commit3149e59fcbb465dc7abeeb231964d7ce594664c1 (patch)
tree1a36ed1f05a46e930f7304f21907615f6677ac25 /math/aamath
parent174510dcb82365b98bdbee59229163c4281e832f (diff)
downloadports-3149e59fcbb465dc7abeeb231964d7ce594664c1.tar.gz
ports-3149e59fcbb465dc7abeeb231964d7ce594664c1.zip
- Fix parallel build, mark port as MAKE_JOBS_SAFE
- Cleanup Makefile while here
Notes
Notes: svn path=/head/; revision=231381
Diffstat (limited to 'math/aamath')
-rw-r--r--math/aamath/Makefile15
-rw-r--r--math/aamath/files/patch-Makefile33
2 files changed, 32 insertions, 16 deletions
diff --git a/math/aamath/Makefile b/math/aamath/Makefile
index 2ddf9a7d85e0..75dc582b7fb1 100644
--- a/math/aamath/Makefile
+++ b/math/aamath/Makefile
@@ -1,6 +1,6 @@
# New ports collection makefile for: aamath
-# Date created: 2005-06-23
-# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+# Date created: 2005-06-23
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
#
# $FreeBSD$
#
@@ -12,17 +12,16 @@ CATEGORIES= math textproc
MASTER_SITES= http://fuse.superglue.se/aamath/
MAINTAINER= ports@FreeBSD.org
-COMMENT= Aamath is a tool for rendering mathematical expressions to ascii art
+COMMENT= Renders ASCII art from mathematical expressions
WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_JOBS_SAFE= yes
PLIST_FILES+= bin/${PORTNAME}
MAN1= aamath.1
-MAKE_ENV+= LDFLAGS="${LDFLAGS}"
-LDFLAGS= -lreadline
-
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/aamath ${PREFIX}/bin
- @${INSTALL_DATA} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/aamath ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+
.include <bsd.port.mk>
diff --git a/math/aamath/files/patch-Makefile b/math/aamath/files/patch-Makefile
index a3476d1e8e37..1557574f9a77 100644
--- a/math/aamath/files/patch-Makefile
+++ b/math/aamath/files/patch-Makefile
@@ -1,18 +1,35 @@
---- Makefile Wed Jun 22 22:12:18 2005
-+++ Makefile.port Tue Sep 6 13:29:09 2005
-@@ -3,9 +3,9 @@
+--- Makefile.orig
++++ Makefile
+@@ -1,17 +1,22 @@
+-CXX = g++
+-LD = g++
++CXX ?= g++
++LD = $(CXX)
CXXFILES = parser.cc lexer.cc expr.cc canvas.cc aamath.cc
OBJS = $(CXXFILES:.cc=.o)
TARGET = aamath
-CFLAGS = -Wall -O2 -g -DUSE_READLINE
-+CFLAGS += -Wall -g -DUSE_READLINE
- LFLAGS = -g
--LIBS = -lreadline -ltermcap
-+LIBS = $(LDFLAGS) -ltermcap
+-LFLAGS = -g
++CFLAGS += -Wall -DUSE_READLINE
+ LIBS = -lreadline -ltermcap
$(TARGET): $(OBJS)
$(LD) $(LFLAGS) $(OBJS) -o $@ $(LIBS)
-@@ -21,3 +21,5 @@
+
+-parser.cc parser.h: parser.y
+- yacc -d parser.y && mv y.tab.c parser.cc && mv y.tab.h parser.h
++yacc: parser.y
++ yacc -d parser.y
++
++parser.cc: yacc
++ mv y.tab.c parser.cc
++
++parser.h: yacc
++ mv y.tab.h parser.h
+
+ lexer.cc: lexer.l parser.h
+ lex lexer.l && mv lex.yy.c lexer.cc
+@@ -21,3 +26,5 @@
clean:
rm -f *.o lexer.cc parser.h parser.cc $(TARGET)