aboutsummaryrefslogtreecommitdiff
path: root/math/aamath
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-07-21 21:21:59 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-07-21 21:21:59 +0000
commit3e77d628c9dd647db1b060124a994e35a6da83cf (patch)
treeb0de1d478d69298063c653fa3f9fe8226d6987e4 /math/aamath
parente445944ac6bfb3b50440b41acc1544e6a81e3175 (diff)
downloadports-3e77d628c9dd647db1b060124a994e35a6da83cf.tar.gz
ports-3e77d628c9dd647db1b060124a994e35a6da83cf.zip
Second attempt to fix build on 11.0-CURRENT.
Notes
Notes: svn path=/head/; revision=362497
Diffstat (limited to 'math/aamath')
-rw-r--r--math/aamath/Makefile2
-rw-r--r--math/aamath/files/patch-Makefile7
2 files changed, 6 insertions, 3 deletions
diff --git a/math/aamath/Makefile b/math/aamath/Makefile
index e6455e0e8771..2bd6c2d5564f 100644
--- a/math/aamath/Makefile
+++ b/math/aamath/Makefile
@@ -19,6 +19,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/aamath man/man1/aamath.1.gz
+CFLAGS+= -I${LOCALBASE}/include
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
diff --git a/math/aamath/files/patch-Makefile b/math/aamath/files/patch-Makefile
index 1557574f9a77..7a62f71b33e1 100644
--- a/math/aamath/files/patch-Makefile
+++ b/math/aamath/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig
-+++ Makefile
+--- ./Makefile.orig 2005-06-22 22:12:18.000000000 +0200
++++ ./Makefile 2014-07-22 01:12:20.000000000 +0200
@@ -1,17 +1,22 @@
-CXX = g++
-LD = g++
@@ -14,7 +14,8 @@
LIBS = -lreadline -ltermcap
$(TARGET): $(OBJS)
- $(LD) $(LFLAGS) $(OBJS) -o $@ $(LIBS)
+- $(LD) $(LFLAGS) $(OBJS) -o $@ $(LIBS)
++ $(LD) $(LDFLAGS) $(OBJS) -o $@ $(LIBS)
-parser.cc parser.h: parser.y
- yacc -d parser.y && mv y.tab.c parser.cc && mv y.tab.h parser.h