aboutsummaryrefslogtreecommitdiff
path: root/math/aamath
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-12 10:58:41 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-12 10:58:41 +0000
commitd285f0f10135d59e30ee6ed71be23b37ed486ec5 (patch)
tree42381865cf7af661f0add1f3fdc9d6f64e435969 /math/aamath
parentdeb072054ded0bfe322f470c476a9be85b061bdf (diff)
downloadports-d285f0f10135d59e30ee6ed71be23b37ed486ec5.tar.gz
ports-d285f0f10135d59e30ee6ed71be23b37ed486ec5.zip
Enable readline support.
PR: 85793 Submitted by: Nicola Vitale <nivit@email.it>
Notes
Notes: svn path=/head/; revision=142520
Diffstat (limited to 'math/aamath')
-rw-r--r--math/aamath/Makefile15
-rw-r--r--math/aamath/files/patch-Makefile13
2 files changed, 21 insertions, 7 deletions
diff --git a/math/aamath/Makefile b/math/aamath/Makefile
index bea6045d0f38..57d192198056 100644
--- a/math/aamath/Makefile
+++ b/math/aamath/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aamath
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= math textproc
MASTER_SITES= http://fuse.superglue.se/aamath/
@@ -18,8 +19,18 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES+= bin/${PORTNAME}
MAN1= aamath.1
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+LDFLAGS= -lreadline
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS= ${LOCALBASE}/lib/libreadline.so
+.endif
+
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/aamath ${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/aamath/files/patch-Makefile b/math/aamath/files/patch-Makefile
index 8c178c8fdd50..a3476d1e8e37 100644
--- a/math/aamath/files/patch-Makefile
+++ b/math/aamath/files/patch-Makefile
@@ -1,14 +1,17 @@
---- Makefile.orig Thu Jun 23 00:12:18 2005
-+++ Makefile Thu Jun 23 15:08:04 2005
-@@ -3,7 +3,7 @@
+--- Makefile Wed Jun 22 22:12:18 2005
++++ Makefile.port Tue Sep 6 13:29:09 2005
+@@ -3,9 +3,9 @@
CXXFILES = parser.cc lexer.cc expr.cc canvas.cc aamath.cc
OBJS = $(CXXFILES:.cc=.o)
TARGET = aamath
-CFLAGS = -Wall -O2 -g -DUSE_READLINE
-+CFLAGS ?= -Wall -O2 -g -DUSE_READLINE
++CFLAGS += -Wall -g -DUSE_READLINE
LFLAGS = -g
- LIBS = -lreadline -ltermcap
+-LIBS = -lreadline -ltermcap
++LIBS = $(LDFLAGS) -ltermcap
+ $(TARGET): $(OBJS)
+ $(LD) $(LFLAGS) $(OBJS) -o $@ $(LIBS)
@@ -21,3 +21,5 @@
clean: