aboutsummaryrefslogtreecommitdiff
path: root/math/acalc
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-02-28 08:44:48 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-02-28 08:44:48 +0000
commit4c11b9d392cb6fae9fef08d4137b483db0d76092 (patch)
tree8974c13d6f77c47ce972dad93f1cb3e9e161d90a /math/acalc
parent8f570a803ca0243012b69e3b5a431d9f761a5240 (diff)
downloadports-4c11b9d392cb6fae9fef08d4137b483db0d76092.tar.gz
ports-4c11b9d392cb6fae9fef08d4137b483db0d76092.zip
`math/acalc' is a simple and pretty Qt4-based expression calculator.
Because GitHub releases (tarballs) are not fetched with correct modification time, set TIMESTAMP to 1481206796 which corresponds to commit 6c032ba tagged as this release. PR: 215158 Submitted by: Andrey Ponomarenko
Notes
Notes: svn path=/head/; revision=435007
Diffstat (limited to 'math/acalc')
-rw-r--r--math/acalc/Makefile30
-rw-r--r--math/acalc/distinfo3
-rw-r--r--math/acalc/pkg-descr5
3 files changed, 38 insertions, 0 deletions
diff --git a/math/acalc/Makefile b/math/acalc/Makefile
new file mode 100644
index 000000000000..ac9105cfa854
--- /dev/null
+++ b/math/acalc/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= acalc
+PORTVERSION= 0.21
+DISTVERSIONPREFIX= ${PORTNAME}-
+CATEGORIES= math
+
+MAINTAINER= andrey.nik.ponomarenko@gmail.com
+COMMENT= Simple and pretty Qt4-based expression calculator
+
+LICENSE= BSD4CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= anpp
+
+USES= qmake
+USE_QT4= corelib gui moc_build rcc_build uic_build
+WRKSRC_SUBDIR= aCalc/aCalc
+
+PLIST_FILES= bin/acalc share/pixmaps/Calculator-50.png
+
+DESKTOP_ENTRIES="acalc" "" "${PREFIX}/share/pixmaps/Calculator-50.png" \
+ "${PORTNAME}" "" ""
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/acalc ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/Icons/Calculator-50.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps
+
+.include <bsd.port.mk>
diff --git a/math/acalc/distinfo b/math/acalc/distinfo
new file mode 100644
index 000000000000..ba91a4d64ed5
--- /dev/null
+++ b/math/acalc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481206796
+SHA256 (anpp-acalc-acalc-0.21_GH0.tar.gz) = 0c4f0680a2e87ff7e7814c867c5ca8e3b31edfd36ce996912628bae913c6530c
+SIZE (anpp-acalc-acalc-0.21_GH0.tar.gz) = 52961
diff --git a/math/acalc/pkg-descr b/math/acalc/pkg-descr
new file mode 100644
index 000000000000..85a2755306b4
--- /dev/null
+++ b/math/acalc/pkg-descr
@@ -0,0 +1,5 @@
+Acalc is simple and pretty expression calculator, based on Qt 4 toolkit.
+It offers standard functions (sin, asinh, etc.), pre-defined constants,
+variables, hex/octal/binary I/O, original and user-friendly interface.
+
+WWW: https://github.com/anpp/acalc