aboutsummaryrefslogtreecommitdiff
path: root/math/adol-c
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-04 07:23:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-04 07:23:06 +0000
commit4be3726b572af8b258128fe9b401a14eaa7cee5b (patch)
tree192e180fbad5d9139b775a3577f99905996d2561 /math/adol-c
parentbc865f3d10ebc23d7afa4545b7d81d9d4fa97f96 (diff)
downloadports-4be3726b572af8b258128fe9b401a14eaa7cee5b.tar.gz
ports-4be3726b572af8b258128fe9b401a14eaa7cee5b.zip
New port: math/adol-c: Automatic differentiation library
Notes
Notes: svn path=/head/; revision=481207
Diffstat (limited to 'math/adol-c')
-rw-r--r--math/adol-c/Makefile29
-rw-r--r--math/adol-c/distinfo3
-rw-r--r--math/adol-c/files/patch-configure20
-rw-r--r--math/adol-c/pkg-descr11
-rw-r--r--math/adol-c/pkg-plist37
5 files changed, 100 insertions, 0 deletions
diff --git a/math/adol-c/Makefile b/math/adol-c/Makefile
new file mode 100644
index 000000000000..43a475d0fb44
--- /dev/null
+++ b/math/adol-c/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= adol-c
+DISTVERSION= 2.6.3
+CATEGORIES= math
+MASTER_SITES= https://www.coin-or.org/download/source/${PORTNAME:tu}/
+DISTNAME= ${PORTNAME:tu}-${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Automatic differentiation library
+
+LICENSE= EPL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= bash:shells/bash
+LIB_DEPENDS= libboost_system.so:devel/boost-libs
+
+USES= gmake libtool tar:tgz
+GNU_CONFIGURE= yes
+CONFIGURE_SHELL= ${LOCALBASE}/bin/bash
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= SPARSE # also uses AMPI, a seemingly obscure MPI implementation
+OPTIONS_SUB= yes
+
+SPARSE_DESC= Build sparse drivers
+SPARSE_CONFIGURE_ENABLE= sparse
+
+.include <bsd.port.mk>
diff --git a/math/adol-c/distinfo b/math/adol-c/distinfo
new file mode 100644
index 000000000000..9162fae9d29d
--- /dev/null
+++ b/math/adol-c/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1538635741
+SHA256 (ADOL-C-2.6.3.tgz) = 6ed74580695a0d2c960581e5430ebfcd380eb5da9337daf488bf2e89039e9c21
+SIZE (ADOL-C-2.6.3.tgz) = 2416928
diff --git a/math/adol-c/files/patch-configure b/math/adol-c/files/patch-configure
new file mode 100644
index 000000000000..082a01ca56cb
--- /dev/null
+++ b/math/adol-c/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig 2018-10-04 07:11:41 UTC
++++ configure
+@@ -16507,7 +16507,7 @@ _ACEOF
+
+
+ if test "x$ac_cv_sizeof_void_p" = "x8" ; then
+- _lib=lib64
++ _lib=lib
+ else
+ _lib=lib
+ fi
+@@ -17513,7 +17513,7 @@ $as_echo_n "checking for boostlib >= $bo
+ libsubdirs="lib"
+ ax_arch=`uname -m`
+ case $ax_arch in
+- x86_64)
++ amd64)
+ libsubdirs="lib64 libx32 lib lib64"
+ ;;
+ ppc64|s390x|sparc64|aarch64|ppc64le)
diff --git a/math/adol-c/pkg-descr b/math/adol-c/pkg-descr
new file mode 100644
index 000000000000..994376825b57
--- /dev/null
+++ b/math/adol-c/pkg-descr
@@ -0,0 +1,11 @@
+The package ADOL-C (Automatic Differentiation by OverLoading in C++) facilitates
+the evaluation of first and higher derivatives of vector functions that are
+defined by computer programs written in C or C++. The resulting derivative
+evaluation routines may be called from C/C++, Fortran, or any other language
+that can be linked with C.
+
+The numerical values of derivative vectors are obtained free of truncation
+errors at a small multiple of the run time and randomly accessed memory of the
+given function evaluation program.
+
+WWW: https://projects.coin-or.org/ADOL-C
diff --git a/math/adol-c/pkg-plist b/math/adol-c/pkg-plist
new file mode 100644
index 000000000000..273010ca89ec
--- /dev/null
+++ b/math/adol-c/pkg-plist
@@ -0,0 +1,37 @@
+include/adolc/adalloc.h
+include/adolc/adolc.h
+include/adolc/adolc_openmp.h
+include/adolc/adolc_sparse.h
+include/adolc/adouble.h
+include/adolc/adoublecuda.h
+include/adolc/adtl.h
+include/adolc/adutils.h
+include/adolc/adutilsc.h
+include/adolc/advector.h
+include/adolc/checkpointing.h
+include/adolc/convolut.h
+include/adolc/drivers/drivers.h
+include/adolc/drivers/odedrivers.h
+include/adolc/drivers/psdrivers.h
+include/adolc/drivers/taylor.h
+include/adolc/externfcts.h
+include/adolc/externfcts2.h
+include/adolc/fixpoint.h
+include/adolc/fortutils.h
+include/adolc/interfaces.h
+include/adolc/internal/adolc_settings.h
+include/adolc/internal/adubfunc.h
+include/adolc/internal/common.h
+include/adolc/internal/paramfunc.h
+include/adolc/internal/usrparms.h
+include/adolc/lie/drivers.h
+include/adolc/param.h
+include/adolc/revolve.h
+%%SPARSE%%include/adolc/sparse/sparse_fo_rev.h
+%%SPARSE%%include/adolc/sparse/sparsedrivers.h
+include/adolc/tapedoc/tapedoc.h
+include/adolc/taping.h
+lib/libadolc.so
+lib/libadolc.so.2
+lib/libadolc.so.2.1.0
+libdata/pkgconfig/adolc.pc