aboutsummaryrefslogtreecommitdiff
path: root/math/algae/files
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-12-22 16:22:28 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-12-22 16:22:28 +0000
commit3f80fdea42527c395d6bc87286b866c83eebe874 (patch)
treee9f8cc238027fcf93c3338cf77f61f09531e928f /math/algae/files
parentcc221c9416bc5ba24c8040bca7e6b8b3f95c00b8 (diff)
downloadports-3f80fdea42527c395d6bc87286b866c83eebe874.tar.gz
ports-3f80fdea42527c395d6bc87286b866c83eebe874.zip
- USES=fortran (eliminate FORTRANLIBS, LDFLAGS and pre-configure).
- Remove some patches and post-patch. - Remove USE_AUTOTOOLS=autoconf and patch configure script directly. - Replace BROKEN with BROKEN_${ARCH}. - Staging (add DESTDIR support to the makefiles). - Make sure the port uses its own arpack, blas, lapack and superlu.
Notes
Notes: svn path=/head/; revision=337197
Diffstat (limited to 'math/algae/files')
-rw-r--r--math/algae/files/patch-Makefile.in30
-rw-r--r--math/algae/files/patch-config.h.in13
-rw-r--r--math/algae/files/patch-configure43
-rw-r--r--math/algae/files/patch-configure.in11
-rw-r--r--math/algae/files/patch-doc-Makefile.in23
-rw-r--r--math/algae/files/patch-src-Makefile.in24
-rw-r--r--math/algae/files/patch-tools-Makefile.in13
7 files changed, 126 insertions, 31 deletions
diff --git a/math/algae/files/patch-Makefile.in b/math/algae/files/patch-Makefile.in
index e083595439b0..97d14af895aa 100644
--- a/math/algae/files/patch-Makefile.in
+++ b/math/algae/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Sun May 18 17:22:07 2003
-+++ Makefile.in Sun May 18 17:23:00 2003
+--- Makefile.in.orig
++++ Makefile.in
@@ -78,12 +78,12 @@
libdir = $(prefix)/lib
@@ -112,23 +112,39 @@
clean mostlyclean distclean maintainer-clean::
rm -f a.out core conft* algae-*.tar algae-*.tar.gz
-@@ -297,12 +293,9 @@
- $(INSTALL_DATA) algae.A $(RC0)
- $(INSTALL_DATA) COPYING $(htmldir)
- $(INSTALL_DATA) LICENSE $(htmldir)
+@@ -294,15 +290,12 @@
+ # >>>> End of deleted section.
+
+ install: algae.A installdirs
+- $(INSTALL_DATA) algae.A $(RC0)
+- $(INSTALL_DATA) COPYING $(htmldir)
+- $(INSTALL_DATA) LICENSE $(htmldir)
- cd src; \
- $(MAKE) bindir=$(bindir) install
- cd tools; \
- $(MAKE) tooldir=$(tooldir) install
- cd doc; \
- $(MAKE) mandir=$(mandir) datadir=$(datadir) \
++ $(INSTALL_DATA) algae.A $(DESTDIR)$(RC0)
++ $(INSTALL_DATA) COPYING $(DESTDIR)$(htmldir)
++ $(INSTALL_DATA) LICENSE $(DESTDIR)$(htmldir)
+ $(MAKE) -C src bindir=$(bindir) install
+ $(MAKE) -C tools tooldir=$(tooldir) install
+ $(MAKE) -C doc mandir=$(mandir) datadir=$(datadir) \
manext=$(manext) infodir=$(infodir) htmldir=$(htmldir) install
.PHONY: install
-@@ -318,9 +311,9 @@
+@@ -310,17 +303,17 @@
+ # if necessary.
+
+ installdirs: mkinstalldirs
+- $(srcdir)/mkinstalldirs $(bindir) $(datadir) $(libdir) $(infodir) \
+- $(mandir) $(tooldir) $(rcdir) $(htmldir)
++ $(srcdir)/mkinstalldirs $(DESTDIR)$(bindir) $(DESTDIR)$(datadir) $(DESTDIR)$(libdir) $(DESTDIR)$(infodir) \
++ $(DESTDIR)$(mandir) $(DESTDIR)$(tooldir) $(DESTDIR)$(rcdir) $(DESTDIR)$(htmldir)
+ .PHONY: installdirs
+
+ # Why would anyone want to uninstall?
uninstall:
rm -f $(RC0)
diff --git a/math/algae/files/patch-config.h.in b/math/algae/files/patch-config.h.in
deleted file mode 100644
index 58e9a2558df5..000000000000
--- a/math/algae/files/patch-config.h.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- config.h.in.orig Wed Oct 19 14:42:12 2005
-+++ config.h.in Wed Oct 19 14:42:38 2005
-@@ -317,8 +317,8 @@
- /*
- * True if the system has a <malloc.h> file.
- */
--#ifndef HAVE_MALLOC_H
--#define HAVE_MALLOC_H 0
-+#ifdef HAVE_MALLOC_H
-+#undef HAVE_MALLOC_H
- #endif
-
- /*
diff --git a/math/algae/files/patch-configure b/math/algae/files/patch-configure
new file mode 100644
index 000000000000..01997d12dd2d
--- /dev/null
+++ b/math/algae/files/patch-configure
@@ -0,0 +1,43 @@
+--- configure.orig
++++ configure
+@@ -2561,9 +2561,9 @@
+ cat > conftest.$ac_ext <<EOF
+ #line 2562 "configure"
+ #include "confdefs.h"
+-int main(int argc, char *argv);
++int main(int argc, char **argv);
+ int t(void);
+-int main(int argc, char *argv) { return t(); }
++int main(int argc, char **argv) { return t(); }
+ int t(void) { return 0; }
+ EOF
+ if eval $ac_compile; then
+@@ -4479,7 +4479,7 @@
+ *-unicos* ) f77_lib_names="F77 I77 sci f" ;;
+ * ) f77_lib_names="F77 I77" ;;
+ esac
+-f77_lib_names="$f77_lib_names g2c f2c"
++f77_lib_names=gfortran
+ for f in $f77_lib_names; do reversed_names="$f $reversed_names"; done
+
+ #---------------------------------------------------------------------
+@@ -5494,8 +5494,7 @@
+ # checks (except for LAPACK) don't need it and won't find it.
+
+ if test "$BLAS" = xblas; then
+- LDFLAGS="$LDFLAGS -L../blas"
+- LOCAL_LIBS="-lblas $LOCAL_LIBS"
++ LOCAL_LIBS="../blas/libblas.a $LOCAL_LIBS"
+ fi
+
+
+@@ -5590,8 +5589,7 @@
+ # checks don't need it and won't find it.
+
+ if test "$LAPACK" = xlapack; then
+- LDFLAGS="$LDFLAGS -L../lapack"
+- LOCAL_LIBS="-llapack $LOCAL_LIBS"
++ LOCAL_LIBS="../lapack/liblapack.a $LOCAL_LIBS"
+ fi
+
+
diff --git a/math/algae/files/patch-configure.in b/math/algae/files/patch-configure.in
deleted file mode 100644
index ddd2ef5eb44e..000000000000
--- a/math/algae/files/patch-configure.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.in~ Sat Dec 13 10:38:07 2003
-+++ configure.in Tue Jan 16 14:12:07 2007
-@@ -415,7 +415,7 @@
- *-unicos* ) f77_lib_names="F77 I77 sci f" ;;
- * ) f77_lib_names="F77 I77" ;;
- esac]
--f77_lib_names="$f77_lib_names g2c f2c"
-+f77_lib_names="%%FORTRANLIBS%%"
- for f in $f77_lib_names; do reversed_names="$f $reversed_names"; done
-
- #---------------------------------------------------------------------
diff --git a/math/algae/files/patch-doc-Makefile.in b/math/algae/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..a46c08f6fb32
--- /dev/null
+++ b/math/algae/files/patch-doc-Makefile.in
@@ -0,0 +1,23 @@
+--- doc/Makefile.in.orig
++++ doc/Makefile.in
+@@ -173,15 +173,13 @@
+ install: algae.info algae.1 algae_toc.html index.html info.db
+ -if test -f algae.info; then d=.; else d=$(srcdir); fi; \
+ for f in $$d/algae.info $$d/algae.info-*; do \
+- $(INSTALL_DATA) $$f $(infodir); \
+- done; \
+- if $(SHELL) -c 'install-info --version' > /dev/null 2>&1; then \
+- install-info --info-dir=$(infodir) $$d/algae.info; else true; fi
++ $(INSTALL_DATA) $$f $(DESTDIR)$(infodir); \
++ done
+ -if test -f algae_toc.html; then d=.; else d=$(srcdir); fi; \
+ for f in $$d/index.html $$d/algae*.html $$d/icon.gif $$d/info.db; do \
+- $(INSTALL_DATA) $$f $(htmldir); done
+- -rm -f $(datadir)/algae/html; ln -s $(htmldir) $(datadir)/algae/html
+- -$(INSTALL_DATA) algae.1 $(mandir)/algae.$(manext)
++ $(INSTALL_DATA) $$f $(DESTDIR)$(htmldir); done
++ -rm -f $(DESTDIR)$(datadir)/algae/html; ln -s $(htmldir) $(DESTDIR)$(datadir)/algae/html
++ -$(INSTALL_DATA) algae.1 $(DESTDIR)$(mandir)/algae.$(manext)
+
+ uninstall:
+ rm -f $(infodir)/algae.info* $(mandir)/algae.$(manext) \
diff --git a/math/algae/files/patch-src-Makefile.in b/math/algae/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..5415a9c344d9
--- /dev/null
+++ b/math/algae/files/patch-src-Makefile.in
@@ -0,0 +1,24 @@
+--- src/Makefile.in.orig
++++ src/Makefile.in
+@@ -48,7 +48,7 @@
+
+ # Libraries.
+
+-LIBS = -L../arpack -larpack -L../superlu -lsuperlu @LOCAL_LIBS@ @LIBS@
++LIBS = ../arpack/libarpack.a ../superlu/libsuperlu.a @LOCAL_LIBS@ @LIBS@
+
+ # Source files.
+
+@@ -218,9 +218,9 @@
+ # ========================== Installation ==========================
+
+ install: all
+- $(INSTALL_PROGRAM) algae $(bindir)/algae-$(VERSION_NUMBER)
+- rm -f $(bindir)/algae
+- ln -s $(bindir)/algae-$(VERSION_NUMBER) $(bindir)/algae
++ $(INSTALL_PROGRAM) algae $(DESTDIR)$(bindir)/algae-$(VERSION_NUMBER)
++ rm -f $(DESTDIR)$(bindir)/algae
++ ln -s algae-$(VERSION_NUMBER) $(DESTDIR)$(bindir)/algae
+ .PHONY: install
+
+ uninstall:
diff --git a/math/algae/files/patch-tools-Makefile.in b/math/algae/files/patch-tools-Makefile.in
new file mode 100644
index 000000000000..856bd8cd0102
--- /dev/null
+++ b/math/algae/files/patch-tools-Makefile.in
@@ -0,0 +1,13 @@
+--- tools/Makefile.in.orig
++++ tools/Makefile.in
+@@ -47,8 +47,8 @@
+ # ========================== Installation =========================
+
+ install: tools.algae
+- for f in *.A; do $(INSTALL_DATA) $$f $(tooldir); done
+- $(INSTALL_DATA) tools.algae $(tooldir)
++ for f in *.A; do $(INSTALL_DATA) $$f $(DESTDIR)$(tooldir); done
++ $(INSTALL_DATA) tools.algae $(DESTDIR)$(tooldir)
+ .PHONY: install
+
+ uninstall: