aboutsummaryrefslogtreecommitdiff
path: root/math/algotutor
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-07-26 07:33:41 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-07-26 07:33:41 +0000
commit19ae251b54b068aae1520c17885ecae948e723bc (patch)
treee2c71147def7c03ff268350288657b4e7692d180 /math/algotutor
parentbe856e74d2486c2042594b76c9cade12ee3f3c07 (diff)
downloadports-19ae251b54b068aae1520c17885ecae948e723bc.tar.gz
ports-19ae251b54b068aae1520c17885ecae948e723bc.zip
Notes
Diffstat (limited to 'math/algotutor')
-rw-r--r--math/algotutor/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/math/algotutor/Makefile b/math/algotutor/Makefile
index e304a089cb2e..0466d1d3ce3a 100644
--- a/math/algotutor/Makefile
+++ b/math/algotutor/Makefile
@@ -23,11 +23,13 @@ LIBFILES= BST.pm Board.pm Collection.pm Configurable.pm DCEdge.pm \
RecCanvas.pm RecDialog.pm TreeNode.pm Vector.pm Vector2.pm \
Vector3.pm Vertex.pm basic.pl utilalgo
+USES= shebangfix
+SHEBANG_FILES= algotutor
+
post-patch:
- ${REINPLACE_CMD} -e 's,#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/algotutor
- ${PERL} -pi -e "s'!!PREFIX!!'${PREFIX}'g" ${WRKSRC}/algotutor
- ${REINPLACE_CMD} -e 's,!!SITE_PERL!!,${SITE_PERL},' \
- ${WRKSRC}/algotutor
+ @${REINPLACE_CMD} -e 's,!!SITE_PERL!!,${SITE_PERL},' \
+ -e 's|!!PREFIX!!|${PREFIX}|g' \
+ ${WRKSRC}/algotutor
do-install:
${MKDIR} ${SITE_PERL}/algotutor