aboutsummaryrefslogtreecommitdiff
path: root/math/antic
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-03 23:14:57 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-03 23:14:57 +0000
commit0e126fd8b625171a93a1edf860c3f60d94727452 (patch)
tree15dc6e6869053764aab82deafb9ccd4910bdf9aa /math/antic
parentfd31417b15194fc573dee9d95736ea47ebc68dd1 (diff)
downloadports-0e126fd8b625171a93a1edf860c3f60d94727452.tar.gz
ports-0e126fd8b625171a93a1edf860c3f60d94727452.zip
New port: math/antic: Algebraic Number Theory In C
Notes
Notes: svn path=/head/; revision=466386
Diffstat (limited to 'math/antic')
-rw-r--r--math/antic/Makefile34
-rw-r--r--math/antic/distinfo3
-rw-r--r--math/antic/pkg-descr5
3 files changed, 42 insertions, 0 deletions
diff --git a/math/antic/Makefile b/math/antic/Makefile
new file mode 100644
index 000000000000..4034d2cc1276
--- /dev/null
+++ b/math/antic/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= antic
+DISTVERSION= g20180325
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Algebraic Number Theory In C
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libflint.so:math/flint2 \
+ libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr
+
+USES= gmake
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+USE_GITHUB= yes
+GH_ACCOUNT= wbhart
+GH_TAGNAME= 0063a41
+USE_LDCONFIG= yes
+
+PLIST_FILES= include/antic/nf.h \
+ include/antic/nf_elem.h \
+ include/antic/qfb.h \
+ lib/libantic.so \
+ lib/libantic.so.0 \
+ lib/libantic.so.0.0.1
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libantic.so
+
+.include <bsd.port.mk>
diff --git a/math/antic/distinfo b/math/antic/distinfo
new file mode 100644
index 000000000000..9303ec0d55b0
--- /dev/null
+++ b/math/antic/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522795005
+SHA256 (wbhart-antic-g20180325-0063a41_GH0.tar.gz) = a9ace5906d90e5442f40d186f825b08f4cc433b16357ddf85011bdf886ff7445
+SIZE (wbhart-antic-g20180325-0063a41_GH0.tar.gz) = 57231
diff --git a/math/antic/pkg-descr b/math/antic/pkg-descr
new file mode 100644
index 000000000000..d277cc60b48e
--- /dev/null
+++ b/math/antic/pkg-descr
@@ -0,0 +1,5 @@
+An algebraic number theory library allowing
+to perform comptations with algebraic numbers
+and fields.
+
+WWW: https://github.com/wbhart/antic