aboutsummaryrefslogtreecommitdiff
path: root/math/arb
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-30 06:48:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-30 06:48:06 +0000
commit3a0c5c28f27feb58b51a29c5e202d4307065bf5e (patch)
treec8392d3e2c5a7416c6994b6796b8eba489ddb03d /math/arb
parent141654c0c29c2453a251cc62eca2c5f1b16b06ea (diff)
downloadports-3a0c5c28f27feb58b51a29c5e202d4307065bf5e.tar.gz
ports-3a0c5c28f27feb58b51a29c5e202d4307065bf5e.zip
New port: math/arb: C library for arbitrary-precision interval arithmetic
Notes
Notes: svn path=/head/; revision=465949
Diffstat (limited to 'math/arb')
-rw-r--r--math/arb/Makefile27
-rw-r--r--math/arb/distinfo3
-rw-r--r--math/arb/pkg-descr15
-rw-r--r--math/arb/pkg-plist28
4 files changed, 73 insertions, 0 deletions
diff --git a/math/arb/Makefile b/math/arb/Makefile
new file mode 100644
index 000000000000..fe50413e9850
--- /dev/null
+++ b/math/arb/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= arb
+DISTVERSION= 2.13.0
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C library for arbitrary-precision interval arithmetic
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libflint.so:math/flint2 \
+ libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr
+
+USES= gmake
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+USE_GITHUB= yes
+GH_ACCOUNT= fredrik-johansson
+USE_LDCONFIG= yes
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libarb.so.*
+
+.include <bsd.port.mk>
diff --git a/math/arb/distinfo b/math/arb/distinfo
new file mode 100644
index 000000000000..acb62cddcd4c
--- /dev/null
+++ b/math/arb/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522369576
+SHA256 (fredrik-johansson-arb-2.13.0_GH0.tar.gz) = d075116d094bfda96f9c4ce10bb9bf23b333a8246f48c532427168d0f91b7788
+SIZE (fredrik-johansson-arb-2.13.0_GH0.tar.gz) = 1331452
diff --git a/math/arb/pkg-descr b/math/arb/pkg-descr
new file mode 100644
index 000000000000..029738af9f4b
--- /dev/null
+++ b/math/arb/pkg-descr
@@ -0,0 +1,15 @@
+Arb is an implementation of ball arithmetic, also known as mid-rad interval
+arithmetic. Ball arithmetic is an extension of floating-point arithmetic in
+which an error bound is attached to each variable. This allows computing
+rigorously with real and complex numbers.
+
+With plain floating-point arithmetic, the user must do an error analysis to
+guarantee that results are correct. Manual error analysis is time-consuming and
+bug-prone. Ball arithmetic effectively makes error analysis automatic.
+
+Arb is designed for computer algebra and computational number theory, but may be
+useful in any area demanding reliable or precise numerical computing. Arb scales
+seamlessly from tens of digits up to billions of digits. Efficiency is achieved
+by low level optimizations and use of asymptotically fast algorithms.
+
+WWW: http://arblib.org/
diff --git a/math/arb/pkg-plist b/math/arb/pkg-plist
new file mode 100644
index 000000000000..6bff739dbbdc
--- /dev/null
+++ b/math/arb/pkg-plist
@@ -0,0 +1,28 @@
+include/acb.h
+include/acb_calc.h
+include/acb_dft.h
+include/acb_dirichlet.h
+include/acb_elliptic.h
+include/acb_hypgeom.h
+include/acb_mat.h
+include/acb_modular.h
+include/acb_poly.h
+include/arb.h
+include/arb_calc.h
+include/arb_fmpz_poly.h
+include/arb_hypgeom.h
+include/arb_mat.h
+include/arb_poly.h
+include/arf.h
+include/bernoulli.h
+include/bool_mat.h
+include/dirichlet.h
+include/dlog.h
+include/fmpr.h
+include/fmpz_extras.h
+include/hypgeom.h
+include/mag.h
+include/partitions.h
+lib/libarb.so
+lib/libarb.so.2
+lib/libarb.so.2.4.0