aboutsummaryrefslogtreecommitdiff
path: root/math/armadillo
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2015-01-14 13:05:09 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2015-01-14 13:05:09 +0000
commit0ae1a710a3a58cd634a7cebf0555b8c1264692f8 (patch)
treeadb6ff88f4f1a0b5b7fa788c928edf051e7a8adc /math/armadillo
parent66686f4d261ceb373306069cb7e9358bbfdb1797 (diff)
downloadports-0ae1a710a3a58cd634a7cebf0555b8c1264692f8.tar.gz
ports-0ae1a710a3a58cd634a7cebf0555b8c1264692f8.zip
Notes
Diffstat (limited to 'math/armadillo')
-rw-r--r--math/armadillo/Makefile6
-rw-r--r--math/armadillo/distinfo4
-rw-r--r--math/armadillo/files/patch-include+armadillo_bits+config.hpp20
-rw-r--r--math/armadillo/pkg-plist2
4 files changed, 26 insertions, 6 deletions
diff --git a/math/armadillo/Makefile b/math/armadillo/Makefile
index 031b00ebc82f..1dbff861a833 100644
--- a/math/armadillo/Makefile
+++ b/math/armadillo/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= armadillo
-PORTVERSION= 4.600.1
+PORTVERSION= 4.600.2
CATEGORIES= math
MASTER_SITES= SF/arma
@@ -11,10 +11,10 @@ COMMENT= C++ linear algebra library
LICENSE= MPL
LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
- liblapack.so:${PORTSDIR}/math/lapack \
+ libarpack.so:${PORTSDIR}/math/arpack \
libhdf5.so:${PORTSDIR}/science/hdf5
-USES= cmake
+USES= cmake blaslapack
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/math/armadillo/distinfo b/math/armadillo/distinfo
index 978e2ba0f1db..bbc5990849bc 100644
--- a/math/armadillo/distinfo
+++ b/math/armadillo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (armadillo-4.600.1.tar.gz) = 142b26f1674ffdf2b9f7c0830610666ca589d1580be45c766ecc973e4b76f3bf
-SIZE (armadillo-4.600.1.tar.gz) = 5347965
+SHA256 (armadillo-4.600.2.tar.gz) = d5f85cac54db16d3cf25af54460eb5fde190c81ddbb8690a6c453012934891bf
+SIZE (armadillo-4.600.2.tar.gz) = 5347346
diff --git a/math/armadillo/files/patch-include+armadillo_bits+config.hpp b/math/armadillo/files/patch-include+armadillo_bits+config.hpp
new file mode 100644
index 000000000000..8e9286ec5423
--- /dev/null
+++ b/math/armadillo/files/patch-include+armadillo_bits+config.hpp
@@ -0,0 +1,20 @@
+--- include/armadillo_bits/config.hpp.orig 2015-01-09 19:09:21.294357075 -0500
++++ include/armadillo_bits/config.hpp 2015-01-09 19:12:51.862339555 -0500
+@@ -24,7 +24,7 @@
+ #endif
+
+ #if !defined(ARMA_USE_ARPACK)
+-// #define ARMA_USE_ARPACK
++#define ARMA_USE_ARPACK
+ //// Uncomment the above line if you have ARPACK or a high-speed replacement for ARPACK.
+ //// ARPACK is required for eigendecompositions of sparse matrices, eg. eigs_sym()
+ #endif
+@@ -54,7 +54,7 @@
+ //// Uncomment the above line if you want to use Intel MKL mkl_malloc() and mkl_free() instead of standard malloc() and free()
+
+ // #define ARMA_USE_ATLAS
+-// #define ARMA_ATLAS_INCLUDE_DIR /usr/include/
++// #define ARMA_ATLAS_INCLUDE_DIR /usr/local/include/
+ //// If you're using ATLAS and the compiler can't find cblas.h and/or clapack.h
+ //// uncomment the above define and specify the appropriate include directory.
+ //// Make sure the directory has a trailing /
diff --git a/math/armadillo/pkg-plist b/math/armadillo/pkg-plist
index 64ebcee163da..4cde5a2cf332 100644
--- a/math/armadillo/pkg-plist
+++ b/math/armadillo/pkg-plist
@@ -407,7 +407,7 @@ include/armadillo_bits/xvec_htrans_bones.hpp
include/armadillo_bits/xvec_htrans_meat.hpp
lib/libarmadillo.so
lib/libarmadillo.so.4
-lib/libarmadillo.so.4.600.1
+lib/libarmadillo.so.4.600.2
share/Armadillo/CMake/ArmadilloConfig.cmake
share/Armadillo/CMake/ArmadilloConfigVersion.cmake
share/Armadillo/CMake/ArmadilloLibraryDepends-release.cmake