aboutsummaryrefslogtreecommitdiff
path: root/math/arpack-ng
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-10-06 20:51:55 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-10-06 20:51:55 +0000
commite0139b43c265ff344dae144c54b44ee4a594b46a (patch)
tree08adb35f625dc4817fef98176514c37d6fe67a0d /math/arpack-ng
parentfa7c8f0597fb9e4a9982e5b77b34effb7c66b58d (diff)
downloadports-e0139b43c265ff344dae144c54b44ee4a594b46a.tar.gz
ports-e0139b43c265ff344dae144c54b44ee4a594b46a.zip
- Add an option MPI to build and install libparpack
- Create a slave port to build a package with this option - Switch to an external plist, because many files are added. PR: ports/193810 Submitted by: /me Approved by: bf (maintainer, by private mail)
Notes
Notes: svn path=/head/; revision=370227
Diffstat (limited to 'math/arpack-ng')
-rw-r--r--math/arpack-ng/Makefile26
-rw-r--r--math/arpack-ng/pkg-plist22
2 files changed, 35 insertions, 13 deletions
diff --git a/math/arpack-ng/Makefile b/math/arpack-ng/Makefile
index 5659043124f9..a336dbb1934b 100644
--- a/math/arpack-ng/Makefile
+++ b/math/arpack-ng/Makefile
@@ -3,14 +3,14 @@
PORTNAME= arpack-ng
PORTVERSION= 3.1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://forge.scilab.org/index.php/p/arpack-ng/downloads/get/ \
LOCAL/bf
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= bf@FreeBSD.org
-COMMENT= Revised Argand library for solving large-scale eigenvalue problems
+COMMENT+= Revised Argand library for solving large-scale eigenvalue problems
LICENSE= BSD
@@ -18,27 +18,27 @@ USES= fortran libtool
USE_LDCONFIG= yes
CONFLICTS= arpack-[0-9]*
+SLAVEDIRS= math/arpack-ng-mpich
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-mpi --with-blas="${BLAS}" \
- --with-lapack="${LAPACK}"
+CONFIGURE_ARGS= --with-blas="${BLAS}" \
+ --with-lapack="${LAPACK}"
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_FILES= lib/libarpack.a \
- lib/libarpack.so \
- lib/libarpack.so.2 \
- lib/libarpack.so.2.0.0 \
- libdata/pkgconfig/arpack.pc
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS MPI
+OPTIONS_SUB= yes
+MPI_CONFIGURE_ENABLE= mpi
+MPI_LIB_DEPENDS= libmpich.so.8:${PORTSDIR}/net/mpich2
+MPI_CONFLICTS_INSTALL+= arpack-ng-3.*
+MPI_CONFLICTS_INSTALL_OFF+= arpack-ng-mpich-3.*
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= *
+.if ${PORT_OPTIONS:MMPI}
+PKGNAMESUFFIX= -mpich
.endif
WITH_BLAS?= blas
diff --git a/math/arpack-ng/pkg-plist b/math/arpack-ng/pkg-plist
new file mode 100644
index 000000000000..1ecde1102e65
--- /dev/null
+++ b/math/arpack-ng/pkg-plist
@@ -0,0 +1,22 @@
+%%MPI%%bin/pcndrv1
+%%MPI%%bin/pdndrv1
+%%MPI%%bin/pdndrv3
+%%MPI%%bin/pdsdrv1
+%%MPI%%bin/psndrv3
+%%MPI%%bin/pssdrv1
+%%MPI%%bin/pzndrv1
+lib/libarpack.a
+lib/libarpack.so
+lib/libarpack.so.2
+lib/libarpack.so.2.0.0
+%%MPI%%lib/libparpack.a
+%%MPI%%lib/libparpack.so
+%%MPI%%lib/libparpack.so.2
+%%MPI%%lib/libparpack.so.2.0.0
+libdata/pkgconfig/arpack.pc
+%%DOCS%%%%DOCSDIR%%/README
+%%DOCS%%%%DOCSDIR%%/debug.doc
+%%DOCS%%%%DOCSDIR%%/ex-complex.doc
+%%DOCS%%%%DOCSDIR%%/ex-nonsym.doc
+%%DOCS%%%%DOCSDIR%%/ex-sym.doc
+%%DOCS%%%%DOCSDIR%%/stat.doc