aboutsummaryrefslogtreecommitdiff
path: root/math/bcal
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2018-12-28 11:21:53 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2018-12-28 11:21:53 +0000
commitae85afe71211b8eaf024e8b9b95a9f6710300209 (patch)
treed806123e900fe6deba5d859a9764ea47f1a95394 /math/bcal
parent5c513cb46879ac108493bd808550f74fd31970de (diff)
downloadports-ae85afe71211b8eaf024e8b9b95a9f6710300209.tar.gz
ports-ae85afe71211b8eaf024e8b9b95a9f6710300209.zip
New port: math/bcal: Storage expression, unit conversion & address offset CLI calculator
bcal (Byte CALculator) is a REPL CLI utility for storage expressions, unit conversions or address calculations. If you can't calculate the hex address offset for (512 - 16) MiB, or the value when the 43rd bit of a 64-bit address is set mentally, bcal is for you. It has a bc mode for general-purpose numerical calculations. bcal follows Ubuntu's standard unit conversion and notation policy. Only 64-bit operating systems are supported. Features: - evaluate arithmetic expressions involving storage units - perform general purpose calculations (using bc) - convert to IEC/SI standard data storage units - interactive mode with the last valid result stored for reuse - show the address in bytes - show address as LBA:OFFSET - convert CHS to LBA and vice versa - base conversion to binary, decimal and hex - custom sector size, max heads/cylinder and max sectors/track - minimal dependencies WWW: https://github.com/jarun/bcal Reviewed by: mat Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D18556
Notes
Notes: svn path=/head/; revision=488595
Diffstat (limited to 'math/bcal')
-rw-r--r--math/bcal/Makefile44
-rw-r--r--math/bcal/distinfo3
-rw-r--r--math/bcal/pkg-descr24
3 files changed, 71 insertions, 0 deletions
diff --git a/math/bcal/Makefile b/math/bcal/Makefile
new file mode 100644
index 000000000000..23f87ed55d7b
--- /dev/null
+++ b/math/bcal/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= bcal
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.1-12
+DISTVERSIONSUFFIX= -g6867abd
+CATEGORIES= math
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Storage expression, unit conversion & address offset CLI calculator
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ONLY_FOR_ARCHS= amd64
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= gmake python:test,3.5+ readline
+
+USE_GITHUB= yes
+GH_ACCOUNT= jarun
+
+MAKE_ARGS= MANDIR=${STAGEDIR}${MAN1PREFIX}/man/man1
+
+PLIST_FILES= bin/bcal \
+ man/man1/bcal.1.gz
+
+PORTDOCS= CHANGELOG \
+ README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/bcal
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+do-test:
+ cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -v test.py
+
+.include <bsd.port.mk>
diff --git a/math/bcal/distinfo b/math/bcal/distinfo
new file mode 100644
index 000000000000..a2a70bed660f
--- /dev/null
+++ b/math/bcal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1545051676
+SHA256 (jarun-bcal-v2.1-12-g6867abd_GH0.tar.gz) = a7850da96b146824933534811078e3ae9f804c29e406cf5e89eb4be83d584f47
+SIZE (jarun-bcal-v2.1-12-g6867abd_GH0.tar.gz) = 34348
diff --git a/math/bcal/pkg-descr b/math/bcal/pkg-descr
new file mode 100644
index 000000000000..bb515228675f
--- /dev/null
+++ b/math/bcal/pkg-descr
@@ -0,0 +1,24 @@
+bcal (Byte CALculator) is a REPL CLI utility for storage expressions, unit
+conversions or address calculations. If you can't calculate the hex address
+offset for (512 - 16) MiB, or the value when the 43rd bit of a 64-bit address
+is set mentally, bcal is for you.
+
+It has a bc mode for general-purpose numerical calculations.
+
+bcal follows Ubuntu's standard unit conversion and notation policy. Only 64-bit
+operating systems are supported.
+
+Features:
+
+- evaluate arithmetic expressions involving storage units
+- perform general purpose calculations (using bc)
+- convert to IEC/SI standard data storage units
+- interactive mode with the last valid result stored for reuse
+- show the address in bytes
+- show address as LBA:OFFSET
+- convert CHS to LBA and vice versa
+- base conversion to binary, decimal and hex
+- custom sector size, max heads/cylinder and max sectors/track
+- minimal dependencies
+
+WWW: https://github.com/jarun/bcal