aboutsummaryrefslogtreecommitdiff
path: root/math/blacs
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2020-04-21 20:35:34 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2020-04-21 20:35:34 +0000
commit15352b139f1109275f880a098270286ab6f54a01 (patch)
treef18b02b32bc9f7937b2e80f56a3e2f94bd75ae97 /math/blacs
parenteec8cf3df9f3406ac48d16349dcae0d9e5d163c4 (diff)
downloadports-15352b139f1109275f880a098270286ab6f54a01.tar.gz
ports-15352b139f1109275f880a098270286ab6f54a01.zip
- Fix build with OpenMPI 4 and swap from net/openmpi3 to net/openmpi
Notes
Notes: svn path=/head/; revision=532418
Diffstat (limited to 'math/blacs')
-rw-r--r--math/blacs/Makefile4
-rw-r--r--math/blacs/files/Bmake.inc-openmpi.diff10
-rw-r--r--math/blacs/files/patch-SRC_MPI_Bdef.h14
3 files changed, 21 insertions, 7 deletions
diff --git a/math/blacs/Makefile b/math/blacs/Makefile
index 7e7c6a8554d8..84723a811e41 100644
--- a/math/blacs/Makefile
+++ b/math/blacs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= blacs
PORTVERSION= 1.7
-PORTREVISION= 36
+PORTREVISION= 37
CATEGORIES= math
MASTER_SITES= NETLIB/blacs
DISTNAME= BLACS
@@ -26,7 +26,7 @@ OPTIONS_DEFAULT= DOCS MPICH
DOCS_DISTFILES= blacs_install.ps f77blacsqref.ps lawn94.ps \
cblacsqref.ps mpi_prop.ps mpiblacs_issues.ps
-OPENMPI_LIB_DEPENDS= libmpi.so:net/openmpi3
+OPENMPI_LIB_DEPENDS= libmpi.so:net/openmpi
OPENMPI_EXTRA_PATCHES= ${FILESDIR}/Bmake.inc-openmpi.diff
MPICH_LIB_DEPENDS= libmpich.so:net/mpich2
diff --git a/math/blacs/files/Bmake.inc-openmpi.diff b/math/blacs/files/Bmake.inc-openmpi.diff
index 2800f5c6b390..e5eba68cfeea 100644
--- a/math/blacs/files/Bmake.inc-openmpi.diff
+++ b/math/blacs/files/Bmake.inc-openmpi.diff
@@ -32,7 +32,7 @@
# -------------------------------------
- MPIdir = /usr/local/mpich
- MPILIBdir = $(MPIdir)/lib/
-+ MPIdir = @LOCALBASE@/mpi/openmpi3
++ MPIdir = @LOCALBASE@/mpi/openmpi
+ MPILIBdir =
MPIINCdir = $(MPIdir)/include
- MPILIB = $(MPILIBdir)/libmpich.a
@@ -78,14 +78,14 @@
- CC = gcc
- CCFLAGS = -O4
- CCLOADER = $(CC)
-+ F77 = @LOCALBASE@/mpi/openmpi3/bin/mpif77
++ F77 = @LOCALBASE@/mpi/openmpi/bin/mpif77
+ F77NO_OPTFLAGS = @F77EXTRAFLAGS@
+ F77FLAGS = @FFLAGS@
-+ F77LOADER = @LOCALBASE@/mpi/openmpi3/bin/mpif77
++ F77LOADER = @LOCALBASE@/mpi/openmpi/bin/mpif77
+ F77LOADFLAGS = @FFLAGS@
-+ CC = @LOCALBASE@/mpi/openmpi3/bin/mpicc
++ CC = @LOCALBASE@/mpi/openmpi/bin/mpicc
+ CCFLAGS = @CFLAGS@
-+ CCLOADER = @LOCALBASE@/mpi/openmpi3/bin/mpicc
++ CCLOADER = @LOCALBASE@/mpi/openmpi/bin/mpicc
CCLOADFLAGS =
-
# --------------------------------------------------------------------------
diff --git a/math/blacs/files/patch-SRC_MPI_Bdef.h b/math/blacs/files/patch-SRC_MPI_Bdef.h
new file mode 100644
index 000000000000..75a6acbe5696
--- /dev/null
+++ b/math/blacs/files/patch-SRC_MPI_Bdef.h
@@ -0,0 +1,14 @@
+--- SRC/MPI/Bdef.h.orig 2020-04-21 20:22:36 UTC
++++ SRC/MPI/Bdef.h
+@@ -1605,9 +1605,9 @@ int BI_ContxtNum();
+ #else
+ #define BI_MPI_Type_struct(count_, lens_, disps_, types_, newtype_, ierr_) \
+ { \
+- (ierr_) = MPI_Type_struct((count_), (lens_), (disps_), (types_), \
++ (ierr_) = MPI_Type_create_struct((count_), (lens_), (disps_), (types_), \
+ (newtype_)); \
+- Mmpierror((ierr_), "MPI_Type_struct", NULL, __LINE__, __FILE__); \
++ Mmpierror((ierr_), "MPI_Type_create_struct", NULL, __LINE__, __FILE__); \
+ }
+ #endif
+