aboutsummaryrefslogtreecommitdiff
path: root/math/blas
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2012-01-23 01:16:10 +0000
committerMaho Nakata <maho@FreeBSD.org>2012-01-23 01:16:10 +0000
commita20eb23df8df51f80dd45c14e905c4967521e81c (patch)
tree83ece9a40dab6aad473f6441f8e6e3f5fc91ddec /math/blas
parent98556abd4401ee223eb58168facdedcb6bd71262 (diff)
downloadports-a20eb23df8df51f80dd45c14e905c4967521e81c.tar.gz
ports-a20eb23df8df51f80dd45c14e905c4967521e81c.zip
* Make the BLAS port the secondary port of LAPACK.
* Version number of BLAS port is now accord with LAPACK port. Submitted by: bf
Notes
Notes: svn path=/head/; revision=289643
Diffstat (limited to 'math/blas')
-rw-r--r--math/blas/Makefile52
-rw-r--r--math/blas/files/makefile.lib32
-rw-r--r--math/blas/pkg-descr18
3 files changed, 15 insertions, 87 deletions
diff --git a/math/blas/Makefile b/math/blas/Makefile
index 20ac9ee40438..fefbb787f8b6 100644
--- a/math/blas/Makefile
+++ b/math/blas/Makefile
@@ -6,54 +6,14 @@
#
PORTNAME= blas
-PORTVERSION= 1.0
-PORTREVISION= 6
-CATEGORIES= math
-MASTER_SITES= http://www.netlib.org/blas/ \
- http://www.mirrorservice.org/sites/netlib.bell-labs.com/netlib/blas/ \
- ftp://ftp.mirrorservice.org/sites/netlib.bell-labs.com/netlib/blas/ \
- http://netlib.sandia.gov/blas/ \
- http://www.netlib.no/netlib/blas/
-DISTNAME= ${PORTNAME}
-EXTRACT_SUFX= .tgz
+PORTREVISION= 0
MAINTAINER= maho@FreeBSD.org
-COMMENT= Basic Linear Algebra, level 1, 2, and 3
+COMMENT= Basic Linear Algebra Subroutines
-USE_LDCONFIG= yes
-USE_FORTRAN= yes
-WRKSRC= ${WRKDIR}/BLAS
-SHLIB_MAJOR= 2
+DESCR= ${.CURDIR}/pkg-descr
+BLAS_SLAVEPORT = yes
-PLIST_FILES= lib/libblas.a lib/libblas.so lib/libblas.so.${SHLIB_MAJOR}
+MASTERDIR= ${.CURDIR}/../lapack
-LDFLAGS+= ${FFLAGS}
-LDADD ?= -lgfortran -lm
-SRCCONF= ${NONEXISTENT}
-MAKE_ENV+= LDADD="${LDADD}" \
- SHLIB_MAJOR="${SHLIB_MAJOR}" SRCCONF="${SRCCONF}"
-.for _u in AR NM RANLIB
-MAKE_ENV+= ${_u}="${LOCALBASE}/bin/${_u:L}"
-.endfor
-
-OPTIONS= PROFILE "Build and install a profiling library" Off
-
-.include <bsd.port.options.mk>
-
-.if defined(WITH_PROFILE)
-.if defined(NOPROFILE) || defined(NO_PROFILE) || defined(WITHOUT_PROFILE)
-IGNORE = you have defined WITH_PROFILE, but have also defined\
-WITHOUT_PROFILE, NOPROFILE, or NO_PROFILE
-.elif !exists(/usr/lib/libc_p.a)
-IGNORE = you have chosen WITH_PROFILE, but have not installed the\
-base system profiling libraries
-.endif
-PLIST_FILES+= lib/libblas_p.a
-.else
-MAKE_ENV+= NO_PROFILE=
-.endif
-
-post-patch:
- @${CP} ${FILESDIR}/makefile.lib ${WRKSRC}/Makefile
-
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/math/blas/files/makefile.lib b/math/blas/files/makefile.lib
deleted file mode 100644
index aa4cd504781e..000000000000
--- a/math/blas/files/makefile.lib
+++ /dev/null
@@ -1,32 +0,0 @@
-# @(#)Makefile 5.7 (Berkeley) 6/27/91
-
-LIBDIR= ${PREFIX}/lib
-
-# BLAS sources
-LIB=blas
-SRCS = caxpy.f ccopy.f cdotc.f cdotu.f cgbmv.f cgemm.f cgemv.f \
- cgerc.f cgeru.f chbmv.f chemm.f chemv.f cher.f cher2.f \
- cher2k.f cherk.f chpmv.f chpr.f chpr2.f crotg.f cscal.f \
- csrot.f csscal.f cswap.f csymm.f csyr2k.f csyrk.f ctbmv.f \
- ctbsv.f ctpmv.f ctpsv.f ctrmm.f ctrmv.f ctrsm.f ctrsv.f \
- dasum.f daxpy.f dcabs1.f dcopy.f ddot.f dgbmv.f dgemm.f \
- dgemv.f dger.f dnrm2.f drot.f drotg.f drotm.f drotmg.f \
- dsbmv.f dscal.f dsdot.f dspmv.f dspr.f dspr2.f dswap.f \
- dsymm.f dsymv.f dsyr.f dsyr2.f dsyr2k.f dsyrk.f dtbmv.f \
- dtbsv.f dtpmv.f dtpsv.f dtrmm.f dtrmv.f dtrsm.f dtrsv.f \
- dzasum.f dznrm2.f icamax.f idamax.f isamax.f izamax.f lsame.f \
- sasum.f saxpy.f scabs1.f scasum.f scnrm2.f scopy.f sdot.f \
- sdsdot.f sgbmv.f sgemm.f sgemv.f sger.f snrm2.f srot.f \
- srotg.f srotm.f srotmg.f ssbmv.f sscal.f sspmv.f sspr.f \
- sspr2.f sswap.f ssymm.f ssymv.f ssyr.f ssyr2.f ssyr2k.f \
- ssyrk.f stbmv.f stbsv.f stpmv.f stpsv.f strmm.f strmv.f \
- strsm.f strsv.f xerbla.f zaxpy.f zcopy.f zdotc.f zdotu.f \
- zdrot.f zdscal.f zgbmv.f zgemm.f zgemv.f zgerc.f zgeru.f \
- zhbmv.f zhemm.f zhemv.f zher.f zher2.f zher2k.f zherk.f \
- zhpmv.f zhpr.f zhpr2.f zrotg.f zscal.f zswap.f zsymm.f \
- zsyr2k.f zsyrk.f ztbmv.f ztbsv.f ztpmv.f ztpsv.f ztrmm.f \
- ztrmv.f ztrsm.f ztrsv.f
-
-CLEANFILES+= *.c
-
-.include <bsd.lib.mk>
diff --git a/math/blas/pkg-descr b/math/blas/pkg-descr
index de0aa93ec97a..4310939603fd 100644
--- a/math/blas/pkg-descr
+++ b/math/blas/pkg-descr
@@ -1,12 +1,12 @@
-The BLAS (Basic Linear Algebra Subprograms) are high quality "building
-block" routines for performing basic vector and matrix operations. Level 1
-BLAS do vector-vector operations, Level 2 BLAS do matrix-vector operations,
-and Level 3 BLAS do matrix-matrix operations. Because the BLAS are
-efficient, portable, and widely available, they're commonly used in the
-development of high quality linear algebra software, LINPACK and LAPACK for
-example.
+The BLAS (Basic Linear Algebra Subprograms) are high quality "building block"
+routines for performing basic vector and matrix operations. Level 1 BLAS do
+vector-vector operations, Level 2 BLAS do matrix-vector operations, and Level
+3 BLAS do matrix-matrix operations. Because the BLAS are efficient, portable,
+and widely available, they're commonly used in the development of high quality
+linear algebra software -- LINPACK and LAPACK, for example.
-A Fortran77 reference implementation of the BLAS is located in the blas
-directory of Netlib.
+The original Fortran77 reference implementation of the BLAS is located in the
+blas directory of Netlib. However, this port uses the updated sources
+distributed with LAPACK.
WWW: http://www.netlib.org/blas/