aboutsummaryrefslogtreecommitdiff
path: root/math/blas
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-04-13 17:53:11 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-04-13 17:53:11 +0000
commitca5d0a975589c6a3dea45ba976b06c0c76cf3300 (patch)
tree6930948dc81aba44facad4bb25a1c2e149019b7e /math/blas
parentf45c8ee6fb39e1e7842ffa0410d3844e4585963c (diff)
downloadports-ca5d0a975589c6a3dea45ba976b06c0c76cf3300.tar.gz
ports-ca5d0a975589c6a3dea45ba976b06c0c76cf3300.zip
This port now respects FFLAGS.
PR: 95521 Submitted by: Pedro F. Giffuni <giffunip@asme.org>
Notes
Notes: svn path=/head/; revision=159439
Diffstat (limited to 'math/blas')
-rw-r--r--math/blas/Makefile5
-rw-r--r--math/blas/files/makefile.lib4
2 files changed, 6 insertions, 3 deletions
diff --git a/math/blas/Makefile b/math/blas/Makefile
index e06aa86d5367..7a6890043c78 100644
--- a/math/blas/Makefile
+++ b/math/blas/Makefile
@@ -20,7 +20,8 @@ COMMENT= Basic Linear Algebra, level 1, 2, and 3
INSTALLS_SHLIB= yes
NO_WRKSUBDIR= yes
-pre-build:
- ${CP} ${FILESDIR}/makefile.lib ${WRKSRC}/Makefile
+do-configure:
+ @${INSTALL_DATA} ${FILESDIR}/makefile.lib ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's+@FFLAGS@+${FFLAGS}+g' ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/math/blas/files/makefile.lib b/math/blas/files/makefile.lib
index c50b4fc8d889..001cdf3f08b0 100644
--- a/math/blas/files/makefile.lib
+++ b/math/blas/files/makefile.lib
@@ -1,6 +1,8 @@
# @(#)Makefile 5.7 (Berkeley) 6/27/91
+FFLAGS= @FFLAGS@
+
LIBDIR= ${PREFIX}/lib
-NOPROFILE= no
+NO_PROFILE= no
SHLIB_MAJOR= 1