aboutsummaryrefslogtreecommitdiff
path: root/math/blis
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-11-23 19:47:43 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-11-23 19:47:43 +0000
commite7be24ee66bc4de72ff2e7aecd2a96af32567e3b (patch)
treed5032640e725ccf8d128f9bc8334f986978e9df0 /math/blis
parenta9ddcbcb8a5c38a352d33d80dc54b5d72154a42e (diff)
downloadports-e7be24ee66bc4de72ff2e7aecd2a96af32567e3b.tar.gz
ports-e7be24ee66bc4de72ff2e7aecd2a96af32567e3b.zip
math/blis: pacify portlint, add test target, optimize for power9 on powerpc64
1. Move USES block to pacify portlint. 2. Add test target. 3. Add perl as a build dependency, I'm not sure how it worked before. 4. Optimize for power9 on powerpc64. This will break blis on all earlier POWER generations, but nothing depends on this port so I guess it's ok. make test passes fine on both elfv1 and elfv2. 5. Remove LIBNAME, it's not necessary. PR: 246194 Approved by: jmd (maintainer timeout)
Notes
Notes: svn path=/head/; revision=556121
Diffstat (limited to 'math/blis')
-rw-r--r--math/blis/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/math/blis/Makefile b/math/blis/Makefile
index 49f58c8162a4..656d2b1b2340 100644
--- a/math/blis/Makefile
+++ b/math/blis/Makefile
@@ -3,6 +3,7 @@
PORTNAME= blis
PORTVERSION= 0.7.0
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= jmd@FreeBSD.org
@@ -13,21 +14,23 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= bash:shells/bash
+USES= compiler gmake perl5 python shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= flame
+USE_LDCONFIG= yes
+USE_PERL5= build
+SHEBANG_FILES= build/flatten-headers.py
+
OPTIONS_DEFINE= PARA CBLAS
PARA_DESC= use pthread parallelization
CBLAS_DESC= build the CBLAS compatibility layer
OPTIONS_DEFAULT= PARA CBLAS
OPTIONS_SUB= yes
-USE_GITHUB= yes
-GH_ACCOUNT= flame
-
-USES= compiler gmake python shebangfix
-USE_LDCONFIG= yes
-SHEBANG_FILES= build/flatten-headers.py
-
HAS_CONFIGURE= yes
+TEST_TARGET= test
+
.include <bsd.port.options.mk>
# enable BLAS and static/shared libs by default
@@ -46,11 +49,13 @@ CONFIGURE_ARGS+= --enable-cblas
.endif
.if ${ARCH} == amd64
-LIBNAME= x86_64
CONFIGURE_ARGS+= x86_64
PLIST_SUB+= ARCH="x86_64"
+.elif ${ARCH} == powerpc64
+CONFIGURE_ARGS+= power9
+PLIST_SUB+= ARCH="power9"
+USE_GCC= yes
.else
-LIBNAME= generic
CONFIGURE_ARGS+= generic
PLIST_SUB+= ARCH="generic"
.endif